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Renesas RA 

如何将应用程序从 e² studio 迁移至 IAR 和 Keil 

要点 

使用瑞萨 RA MCU 开发产品时，有多种集成开发环境可供选择。本应用说明以瑞萨 e2 studio 工

程为参考，提供了在 IAR Embedded Workbench for ARM 和 Keil Microcontroller Development Kit - 

Arm 等 IDE 中创建工程的指南。此过程以下称为“IDE 迁移”。指南适用于瑞萨官网上大多数样例

工程和应用程序。由于底层编译器及所选选项的差异，完成本文档推荐的步骤后，建议用户在 RA 

MCU 上对新生成的工程以及原 e2 studio 工程进行全面的测试和比较。 

 

所需资源 

开发工具及软件 

• e2 studio IDE v2021-04 或更高版本 （链接） 

• RA Standalone Configurator (RASC) v2021-04 或更高版本 （链接） 

• IAR Embedded Workbench for Arm v8.50.9 或更高版本 （链接） 

• Keil MDK 5.34 或更高版本 （链接） 

• Flexible Software Package v3.1.0 或更高版本（链接） 

 

先决条件和目标受众 

本应用说明需要您在瑞萨 e2 studio IDE 和 RA 灵活软件包 (FSP) 方面有一定的经验。在执行本

应用说明中的步骤之前，请按照 FSP 用户手册中的步骤来创建和运行 Blinky 工程。这样可以熟悉 e2 

studio 和 FSP，也可以验证与主板的调试连接是否正常工作。 

本文档的目标受众是希望将通常随 e2 studio 和 GCC 发布的样例工程和应用项目扩展到其他 IDE

和编译器的用户。 

注意：如果您是 e2 studio 和 FSP 的新用户，强烈建议您在系统上先安装 e2 studio 和 FSP 以完成

Blinky 工程，并在继续下一节之前熟悉 e2 studio 和 FSP 开发环境。 

 

先决条件 

• 获取瑞萨 FSP 的最新文档 

• 熟悉 e2 studio 和内置（或独立）RA Configurator 的操作 

• 熟悉 IAR Embedded Workbench 和 IAR 编译器的操作 

• 熟悉 Keil MDK 和 Arm 编译器的操作  

https://github.com/renesas/fsp/releases/download/v3.1.0/setup_fsp_v3_1_0_e2s_v2021-04.exe
https://github.com/renesas/fsp/releases/download/v3.1.0/setup_fsp_v3_1_0_rasc_v2021-04.exe
https://www.iar.com/ewarm
https://www2.keil.com/mdk5
https://www.renesas.com/fsp
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1 概述 

将 IDE 迁移至 IAR EW 和 Keil MDK 需要遵循以下常见步骤。这些步骤在接下来的章节中还会

有详细描述。 

1. IDE 配置与组件安装 

1. RASC 安装与注册 

2. FSP 安装 

3. 补丁/DFP 安装 

2. 创建空白模板工程 

1. 创建空白工程 

3. 添加源代码 

1. 添加源文件 

2. 生成 FSP 自动生成的文件 

4. 编译二进制文件 

1. 调整编译器选项（包括路径、编译标志、链接器标志等） 

2. 构建工程 

3. 处理警告和错误 

5. 下载并调试二进制文件 

1. 调试器设置 

2. 验证下载 

 

1.1 安装 RASC  

可用的 RASC 可执行文件可以直接运行。按照以下步骤进行安装。 

1. 安装 RASC 并启动设置时，如需安装到不同的位置，请选择 All Users。如果选择 Current User，则

可能无法更改安装路径。 

 

图 1.  选择 All Users 安装方式 
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2. 选择 Install (Install to a different location)，创建新的 RASC 独立实例。然后单击 Next 开始安装。 

 

图 2.  选择 Install 

过程中会检查安装所需的条件。默认情况下，会安装在 C:\Renesas\RA\ 目录下，但也可以

更改为其他路径。 

 

图 3.  选择 Install Directory 
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3. 单击 Next 以继续。 

4. 勾选许可协议条款，然后单击 Install 开始安装。完成后显示如下界面。 

 

图 4.  安装 

5. 在安装目录中检查新建的 RASC 文件夹（默认路径示例如下）： 

 

图 5.  安装文件夹 

注：新安装的软件包应位于 RASC 文件夹的 internal 目录内，如图 6 所示。 

 

图 6.  internal 目录 
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1.2 安装 FSP 

此步骤对迁移到 Keil 和 IAR 均通用。可通过以下方式完成： 

• 直接下载已预装特定版本软件包的新 RASC。 

• 软件包位于 <rasc installation directory>¥sc_v2021-

04_fsp_v3.1.0¥internal¥projectgen¥ra¥packs 

• 将 FSP 软件包（.pack 文件）直接复制到当前 RASC 的软件包目录： 

<installation directory>¥sc_v2021-

04_fsp_v3.1.0¥internal¥projectgen¥ra¥packs 

 

2 将 e2 studio 工程迁移至 IAR EW/IARCC 

2.1 IAR IDE 配置与组件安装 

参考最新 FSP 用户手册中的文档：Starting Development → Using RA Smart Configurator with IAR 

EWARM 

https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-ewarm 

2.1.1 IAR IDE 与 RASC 配置 

要求： 

• IAR EW for Arm (当前版本：8.50.9) 

• Flex Software Package (FSP) (当前版本：3.1.0) 

• RA Smart Configurator (RASC) (当前版本：3.1.0) 

 

为已安装的 IAR EW 软件配置 RASC： 

打开 IAR Embedded Workbench：Tools → Configure Tools... 

1. 单击 Configure tools → New 后出现如下界面。按图 7 进行相关配置。 

https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-ewarm
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图 7.  配置工具选项 

2. 按照图 7 配置工具选项： 

- Menu Text：在 RA Configurator 工具中显示的名称。需正确命名以便识别。 

- Command:：指定 RASC 的迁移路径。浏览并指定到已安装的 rasc.exe（例如：

C:\Renesas\RA\sc_v2021-04_fsp_v3.1.0\eclipse\rasc.exe）。 

- Argument：设置为 --compiler IAR configuration.xml，以使 RASC 生成与 IAR 编译器兼容的代

码。 

- Initial Directory：使用$PROJ_DIR$。 

注意：若更换了 FSP 版本，需在 Command 中修改 rasc.exe 的路径。例如：使用 FSP 

v3.1.0 时，路径应设为 C:¥Renesas¥RA¥sc_v2021-

04_fsp_v3.1.0¥eclipse¥rasc.exe。 

3. 点击 OK 完成 RASC 配置。 

配置完成后，可在 IDE 中使用在 Configure Tools 的 Menu Text 定义的名称运行 RASC。打开 

IAR IDE，点击 Tools→RA Configurator，可由此运行 RA Configurator（如下图所示）。若在 IDE 未

打开 IAR EW 工程的情况下打开 RASC，则可能会遇到“Failed to Expand Argument Variable 

“$PROJ_DIRS$” ”错误。当使用 IAR EW IDE 打开有效的 *.ewp 文件时会解析 $PROJ_DIR$。因

此可以忽略此错误。 
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图 8.  运行 RA Configurator 

2.1.2 在 IAR 中安装补丁 

如果 IAR Embedded Workbench 未包含对目标 RA MCU 的支持，可能需要为其打补丁。否则，

您将无法生成或操作所选 MCU 的工程。 

建议您通过官方渠道联系 IAR 获取补丁文件。获得补丁后，需将其复制到已安装 IAR 版本的 arm 目

录内。 

默认路径为：C:¥Program Files (x86)¥IAR Systems¥Embedded Workbench 

8.4¥arm 

1. 在 IAR 安装目录中找到 arm 文件夹。 

2. 解压缩补丁文件，获取新的目录结构，即如下图所示的 config、inc、src 等。 

 

图 9.  新目录 

3. 将上述目录复制并粘贴到默认位置，或粘贴到 IAR 安装目录下的 arm目录位置。 

 

2.2 为 IAR 创建空白模板工程 

IAR 创建新工程的要求： 

• IAR EW for Arm（当前使用版本：8.50.9） 

- 注意：与 FSP 版本配套的最新 IDE 版本可在 GitHub 上的 FSP release 中查看。 

• Flex Software Package (FSP)（当前使用版本：3.1.0） 

• RA Smart Configurator (RASC)（当前使用版本：3.1.0） 

2.2.1 在 IAR 中创建空白模板工程的步骤 

1. 按照上一节所述安装软件包后运行 RASC (rasc.exe)。 

2. 为工程命名，为 Workspace 指定合适的位置。 
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图 10.  指定工程的名称及路径 

3. 单击“Next”后出现如下界面。选择“FSP Version”、“Board”、“Device”和“IDE”。 

 

图 11.  设置 FSP Version, Board, Device 和 IDE 

4. FSP Version 下拉菜单中有可用软件包，这些软件包必须存放在 RASC 安装目录下的 internal 文件夹

中。 

5. Device 和 Language 会自动选择为 Default（默认）。 

6. IDE Project type 选择 IAR EWARM Version 8，以便在 IAR 中创建示例工程。 

 

图 12.  设置 IDE 工程类型 
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7. 单击 Next 并按照以下步骤创建 Flat 工程。如果选择了支持 TrustZone® 的 MCU（RA4M2、

RA4M3、RA6M4、RA6M5），系统将提示您选择 Flat、Secure 或 Non Secure 工程。 

 

图 13.  Flat、Secure、Non-Secure 选项 

8. 选择工程类型（第 6 步）后，根据工程要求选择 RTOS。默认设置为 No RTOS。单击 Next 继续。 

 

图 14.  选择 RTOS 
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9. 选择 Bare Metal - Minimal 创建工程示例模板。单击 Finish 完成工程模板的创建。 

 

图 15.  选择 Bare Metal – Minimal 

 

2.3 添加源代码 

2.3.1 添加 src 文件 

• 如果已成功完成上述步骤，src 文件夹将已存在于 IAR 工程模板创建的位置。 

模板中的 src文件夹可以被 e2 studio 工程文件夹中的 src文件替换。 

 

2.3.2 添加 src 文件后配置并生成工程 

工程模板创建完成后，将以.eww文件的形式创建在所选工程位置中，该文件关联了所有必要的

初始化文件以及其他配置文件。 

 

图 16.  工程文件 
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工程生成步骤： 

• 如前所述，模板创建时会生成一个 <project name>.eww文件。运行该文件后在 IAR 

Embedded Workbench（EW）中打开工程。 

• 单击 Tools 选项，选择 RA Configurator（RASC 已配置到 IAR EW，参考前文所述“为已安

装的 IAR EW 软件配置 RASC”的步骤）。 

• RASC 打开后，将显示如图 17 所示的界面，包含多个选项卡和配置选项。 

 

图 17.  BSP 配置 

• 在 RASC 的标签栏中选择所需选项卡，并根据项目需求配置各个组件的属性。 

• 工程生成前的常规配置： 

a.  选择 BSP 选项卡，在 Properties 窗口中配置 BSP 参数。 

b.  根据需求在 RASC 配置中添加模块，通过 New Stack 选项选择所需的模块。 

 

图 18.  添加新模块 
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c.  根据要配置的模块设置 Pins。 

 

图 19.  设置 Pins  

• 在完成所需模块的所有相关选项卡配置（如 BSP、Stack、Clock 等）后，按下保存快捷键

（Ctrl+S），然后点击 Generate Project Content 按钮，如下图所示： 

 

图 20.  生成工程内容（Generate Project Content） 

 

2.4 工程的配置与编译 

2.4.1 编译器选项设置 

可按以下步骤修改工程的编译器选项： 

1. 打开 <project_name>.eww 文件，在 workspace 中点击 Project → Options 或使用 Alt+F7 快捷

键。 

2. 在 Options 窗口中，Category 选择 C/C++ Compiler。如图 21 所示，在右侧选择

Optimizations，如图 21 所示。 
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图 21.  优化（Optimizations） 

3. 将 Level 设为 High，在下拉菜单中选择 Balanced，并取消勾选 Code Motion 选项。 

4. 在同一 Options 菜单中，选择 Category 中的 Output Converter。勾选 Generate additional 

output，Output format 选择为 Intel Extended hex，如图 22 所示。 
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图 22.  输出转换器（Output Converter） 

5. 单击 Options 窗口底部的 OK，使应用设置生效。 

 

2.4.2 构建工程 

在构建项目之前，请确保已完成以下预构建操作： 

• 特定模块的 src 文件夹位于工程文件夹目录内。 

• 生成了包含所需配置（BSP、Clocks、Pins 等）的工程文件。 

• 完成编译器调整。 

• IAR EW 许可证有效。 
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1. 生成工程后打开该工程（.eww文件）。 

2. 右击工程后单击 Rebuild All 选项。 

 

图 23.  重构（Rebuild All） 
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3. 启用 Live Logging 选项可查看日志。 

- 右键单击工作区下方的 Build 窗口。 

- 选择 Live Log to File，并选择日志所在的文件位置。 

 

图 24.  将实时日志保存到文件 

2.4.3 处理构建操作中的警告和错误 

完成工程的生成和构建程序后，可在 Build 窗口的 Build logs 中查看操作成功与否。若 Build 窗

口被隐藏，请选择 View → Messages → Build。 

 

图 25.  显示 Build 窗口 
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在 Build 窗口中，可以查看错误和警告的详情以及数目。如图 26 所示。 

 

 

图 26.  错误与警告 

 

2.5 下载和调试应用代码 

调试前要确保没有错误，并查看编译器生成的警告。确认目标板已连接到主机系统。 

• 要调试二进制文件，请单击选项面板上的 Download and Debug 选项，如图所示。 

 

图 27.  Download and Debug 选项 

• 重新配置 TrustZone®边界设置时，会执行 Renesas Device Partition Manager (RDPM)，位于 

RASC > Run > Renesas Debug Tools > RDPM 下。请阅读 FSP 用户手册中的 Notes and 

Restrictions。 

• 成功下载并调试后，单击 Go 以运行代码。 

 

图 28.  运行代码 

• 若 RTT 被编译到二进制文件中并被应用程序调用，则变为可见。 

 

https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-ewarm-notes-restrictions
https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-ewarm-notes-restrictions
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将 e2 studio 程序迁移至 Keil MDK 和 Arm C 编译器 

关于如何在 RA 板上使用 Keil IDE 的详细信息，请参阅以下文档：

https://www.keil.com/appnotes/files/apnt_330_v0.35.pdf 

关于将 RA Smart Configurator 与 Keil MDK 结合使用的说明，请参阅以下文档：

https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-keil-mdk 

有关 RASC/FSP 安装过程，请参阅 FSP 安装部分。 

注意：更改 FSP 版本时，请相应调整 User Command 中 Options for Target 的 rasc.exe 路

径。 

 

2.5.1 DFP 安装 

1. 下载最新的 DFP 软件包并解压缩。 

最新的 Device Family Packs 均可从以下链接获取：https://www.keil.com/dd2/pack/。 

2. 打开 Keil IDE  

注意：安装软件包需要管理员权限。 

3. 打开软件包安装程序。 

 

图 29. 软件包安装程序 

4. 按照图 30 依次打开 File > Import from Folder… 

 

图 30.  从文件夹中导入（Import from Folder） 

https://www.keil.com/appnotes/files/apnt_330_v0.35.pdf
https://renesas.github.io/fsp/_s_t_a_r_t__d_e_v.html#using-ra-smart-configurator-with-keil-mdk
https://www.keil.com/dd2/pack/


Renesas RA 如何将应用程序从 e² studio 迁移至 IAR 和 Keil 

R11AN0555CU0101  Rev. 1.01   Page 20 of 36 

2024.2.15  

 

5. 在打开的窗口中选择解压后的文件夹（步骤 1）。 

6. 可以在 Packs 选项卡下选择 Device Specific 来检查已安装的软件包，如下图所示。 

 

图 31.  已安装的软件包 

2.5.2 为 Keil 创建空白模板工程 

1. 进入文件夹 <rasc installation directory>¥sc_v2021-

04_fsp_v3.1.0¥eclipse，打开 rasc.exe。 

2. 在打开的 Smart Configurator 中输入工程名称和位置，然后单击“Next”。 

 

图 32.  Smart Configurator 
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3. 下一步是选择所需的 FSP 版本和电路板。如图 33 所示，可在此选定 IDE 的工程类型。选择 

Keil MDK Version 5。 

 

图 33.  选定工程类型 
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4. 下一步根据要求选择 Flat, TrustZone Secure 或 TrustZone Non-secure。该选项仅适用于支持 

TrustZone 的 MCU。 

 

图 34.  选择 Flat, TrustZone Secure 或 TrustZone Non-secure 

 

5. 接下来可设 RTOS Selection，如下图所示，为工程选择合适的选项。 

  

图 35.  选择 RTOS 
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6. 选择 Bare Metal – Minimal 工程，创建示例模板工程。单击 Finish 完成工程模板的创建。 

 

图 36.  工程模板 
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2.5.3 添加源代码 

1. 完成工程模板的创建后，导航到包含已创建 Keil 工程的文件夹。在此文件夹中，之前生成的

src文件夹需替换为 e2 studio 工程的 src文件夹。 

 

图 37.  e2 studio 的 src 文件夹 

2. 打开文件夹中的 uVision5 工程文件，以在 Keil IDE 中打开工程。 

 

图 38.  uVision5 工程文件 
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3. 如图 39 所示，打开了 Keil 工程。 

 

图 39.  Keil 工程 

4. 若要打开 RASC，请选择 Manage Run-Time Environment 图标。 

 

图 40.  管理运行环境（Manage Run-Time Environment） 
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5. 出现如下对话框： 

 

图 41.  Manage Run-Time Environment 对话框 

6. 要运行 RASC，请展开 Flex Software 并运行 RA Configuration，如下图所示。 

 

图 42.  RA Configuration 
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7. 窗口将显示已安装的 RASC 版本。输入对应的数字以选择所需版本。 

 

图 43.  选择 RASC 版本 

8. Smart Configurator 打开后，可通过高亮显示的选项卡配置 BSP、Pins 和 Stacks 等的属性。 

  

图 44.  Smart Configurator 

BSP、Pins、Stacks 和 Clocks 下需配置的参数要做调整，以与 e2 studio 工程的配置相匹配。 
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9. 完成所需配置后，按下 Ctrl+S（保存）并选择 Generate Project Content。 

 

图 45.  生成工程内容（Generate Project Content） 

10. 关闭 RASC 后，在 Manage Run-Time Environment 窗口单击 OK。 

11. 完成后会出现以下对话框。选择 Yes 导入在 Configurator 中所做的修改。 

 

图 46.  保存修改 
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2.5.4 编译工程 

1. 在新窗口中设置目标选项。该窗口通过点击高亮显示的 Target 图标选择。 

 

图 47.  Target 选项 

2. 选择 ARM Compiler 版本，如图 48 所示。 

 

图 48.  Arm Compiler 版本 
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3. 确保在 Output 选项卡中选择了 Create HEX File，这样可在创建过程中生成十六进制文件。 

 

图 49.  创建 HEX 文件 

4. 在 C/C++ (AC6) 选项卡下为目标设置优化。Optimization 选择-O2。为 Misc Controls 添加参

数 -Os，如下图所示。 

 

图 50.  优化（Optimization）与其他设置（Misc Controls） 
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5. 在 Debug 选项下选择 J-Link/J-TRACE Cortex。同时选择 Settings 选项并确保设置了 J-Link 

Settings。 

 

图 51.  Debug 选项 

6. 上图的 Debug 窗口下选择 Settings 后会出现以下窗口。请确保选择了正确的 J-Link ID。 

 

图 52.  选择 J-Link ID 

7. 单击 OK。  
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8. 选择工程。选择 Project → Build Target。完成构建后，查看警告和错误。 

 

图 53.  构建 Target 
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2.5.5 下载并调试工程 

1. 成功构建一个无错误及警告的工程后，选择 Start/Stop Debug Session 图标。需确保在配置

Target 选项时设置好了 J-Link。 

 

图 54.  开启调试（Start Debugging Session） 

2. 出现 Debug 窗口后，点击 Reset 和 Run 的图标以运行工程。 

 

图 55.  Reset 图标 
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图 56.  Run 图标 

3. 点击 Stop 图标即可停止调试。 

 

图 57.  Stop 图标 

运行后，可以通过 SEGGER RTT Viewer（仅在与应用程序二进制文件一起编译并使用时可用）

查看结果。  
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网站和支持  

可从以下链接了解更多关于 RA 系列的要点，下载组件和相关文档，以获得支持。 

RA 产品  www.renesas.com/ra  

RA 产品支持论坛  www.renesas.com/ra/forum  

RA FSP www.renesas.com/FSP 

瑞萨技术支持 www.renesas.com/support 
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注意 
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法和应用示例）而引起的侵权或与第三方有关的专利、版权或其他知识产权的任何其他索赔，概不承担任何责任和赔偿。 

3. 对 Renesas Electronics 或其他公司的任何专利、版权或其他知识产权均不授予任何明示、暗示或其他形式的许可。 

4. 您应负责确定需要从任何第三方获得哪些许可，并在需要时为合法进口、出口、制造、销售、使用、分销或以其他方式处置包含 Renesas Electronics 

产品的任何产品获得此类许可。 

5. 不得对 Renesas Electronics 产品的全部或部分进行更改、修改、复制或逆向工程。对于因更改、修改、复制或逆向工程而导致您或第三方蒙受的任何

损失或损害，Renesas Electronics 不承担任何责任。 

6. Renesas Electronics 产品根据以下两个质量等级进行分类：“标准”和“优质”。Renesas Electronics 每种产品的预期应用取决于产品的质量等级，

具体如下所示。 

“标准”：计算机、办公设备、通信设备、测试和测量设备、视听设备、家用电器、机械工具、个人电子设备、工业机器人等 

“优质”：运输设备（汽车、火车、轮船等）；交通管制（交通信号灯）；大型通信设备；关键金融终端系统；安全控制设备等 

除非在  Renesas Electronics 数据手册或  Renesas Electronics 其他文档中明确指定为高可靠性产品或用于恶劣环境的产品，否则  Renesas 

Electronics 产品不适合或不授权用于可能对人类生命构成直接威胁或造成人身伤害（人造生命支持设备或系统；手术植入物等），或者可能造成严重

的财产损失（空间系统、海底中继器、核动力控制系统、飞机控制系统、关键设备系统、军事装备等）的产品或系统。对于因使用任何与 Renesas 

Electronics 数据手册、用户手册或其他 Renesas Electronics 文档不一致的 Renesas Electronics 产品而引起的您或任何第三方所造成的任何损坏

或损失，Renesas Electronics 不承担任何责任。 

7. 没有任何半导体产品是绝对安全的。尽管 Renesas Electronics 的硬件或软件产品中可能实施了任何安全措施或功能， Renesas Electronics 对因任何

漏洞或侵骇（包括但不限于以任何未经授权的方式访问或使用 Renesas Electronics 产品或使用 Renesas Electronics 产品的系统）而产生的任何后果

概不负责。RENESAS ELECTRONICS 不担保或保证 RENESAS ELECTRONICS 产品或使用 RENESAS ELECTRONICS 产品创建的任何系统不会

被破坏，或者可免于数据损坏、攻击、病毒、干扰、黑客攻击、数据丢失或失窃或其他安全入侵（“漏洞问题”）。RENESAS ELECTRONICS 不承

担由任何漏洞问题引起的或与之相关的任何和所有责任或义务。此外，在适用法律允许的范围内，RENESAS ELECTRONICS 不对本文件和任何相关

或附带的软件或硬件提供任何和所有明示或暗示的保证，包括但不限于对适销性或对特定用途的适用性的暗示保证。 

8. 使用 Renesas Electronics 产品时，请参见最新的产品信息（数据手册、用户手册、应用笔记、可靠性手册中的“处理和使用半导体器件的一般说明”

等），并确保使用条件符合 Renesas Electronics 在最大额定值、工作电源电压范围、散热特性和安装等方面的规定。对于因在超出上述规定范围的

条件下使用 Renesas Electronics 产品而引起的任何失常、故障或事故，Renesas Electronics 不承担任何责任。 

9. 尽管 Renesas Electronics 致力于提高 Renesas Electronics 产品的质量和可靠性，但半导体产品具有特定的特性，例如在特定速率下发生故障以及在

某些使用条件下出现故障。除非在 Renesas Electronics 数据手册或 Renesas Electronics 其他文档中指定为高可靠性产品或用于恶劣环境的产品，否

则 Renesas Electronics 的产品将不受抗辐射设计的约束。用户应负责采取安全措施，以防止人身伤害、火灾造成的伤害，和/或因 Renesas Electronics 

产品发生故障或失常而对公众造成的危险，例如硬件和设备的安全设计，包括但不限于冗余、火控和故障预防、针对老化退化的适当处理或任何其他

适当的措施。由于对微型计算机软件进行评估非常困难且无实操性，因此用户有责任评估自己生产的最终产品或系统的安全性。 

10. 请联系 Renesas Electronics 销售办事处，以获取有关环境事宜的详细信息，例如每个 Renesas Electronics 产品的环境相容性。用户有责任认真、充

分地研究有关纳入或使用受控物质的适用法律和法规（包括但不限于欧盟 RoHS 指令），并按照所有适用法律和法规使用 Renesas Electronics 产

品。对于因您未遵守适用的法律和法规而造成的损坏或损失，Renesas Electronics 不承担任何责任。 

11. Renesas Electronics 产品和技术不得被用于或纳入为任何适用的本国或外国法律、法规所禁止制造、使用或销售的产品或系统范围内。用户应遵守由

对当事方或交易拥有管辖权的任何国家/地区的政府颁布和管理的任何可适用的出口控制法律和法规。 

12. 应由Renesas Electronics 产品的购买方或分销商，或者对产品进行分发、处置或以其他方式出售或转让给第三方的任何其他当事方，负责将本文档中

阐明的内容和条件提前通知前述第三方。 

13. 未经 Renesas Electronics 事先书面同意，不得以任何形式全部或部分重印、再现或复制本文档。 

14. 如果对本文档中包含的信息或 Renesas Electronics 产品有任何疑问，请联系 Renesas Electronics 销售办事处。 

（注 1）本文档中的“Renesas Electronics”是指 Renesas Electronics Corporation，也包括其直接或间接控制的子公司。 

（注 2）“Renesas Electronics 产品”是指 Renesas Electronics 开发或制造的任意产品。 
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TOYOSU FORESIA, 3-2-24 Toyosu, 

Koto-ku, Tokyo 135-0061, Japan 

www.renesas.com 

有关产品、技术、文档最新版本或离您最近的销售办事处的更多信息，

请访问：www.renesas.com/contact/。 
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