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Notice 
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5. When exporting the products or technology described in this document, you should comply with the applicable export control 
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the military, including but not limited to the development of weapons of mass destruction.  Renesas Electronics products and 
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does not warrant that such information is error free.  Renesas Electronics assumes no liability whatsoever for any damages 
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7. Renesas Electronics products are classified according to the following three quality grades:  “Standard”, “High Quality”, and 
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indicated below.  You must check the quality grade of each Renesas Electronics product before using it in a particular 
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expressly specified in a Renesas Electronics data sheets or data books, etc. 

“Standard”: Computers; office equipment; communications equipment; test and measurement equipment; audio and visual 
equipment; home electronic appliances; machine tools; personal electronic equipment; and industrial robots. 

“High Quality”: Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-
crime systems; safety equipment; and medical equipment not specifically designed for life support. 

“Specific”:  Aircraft; aerospace equipment; submersible repeaters; nuclear reactor control systems; medical equipment or 
systems for life support (e.g. artificial life support devices or systems), surgical implantations, or healthcare 
intervention (e.g. excision, etc.), and any other applications or purposes that pose a direct threat to human life. 

8. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, 
especially with respect to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation 
characteristics, installation and other product characteristics. Renesas Electronics shall have no liability for malfunctions or 
damages arising out of the use of Renesas Electronics products beyond such specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have 
specific characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Further, 
Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to 
guard them against the possibility of physical injury, and injury or damage caused by fire in the event of the failure of a 
Renesas Electronics product, such as safety design for hardware and software including but not limited to redundancy, fire 
control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because 
the evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or system 
manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental 
compatibility of each Renesas Electronics product.  Please use Renesas Electronics products in compliance with all applicable 
laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS 
Directive.  Renesas Electronics assumes no liability for damages or losses occurring as a result of your noncompliance with 
applicable laws and regulations. 

11. This document may not be reproduced or duplicated, in any form, in whole or in part, without prior written consent of Renesas 
Electronics. 

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this 
document or Renesas Electronics products, or if you have any other inquiries. 

(Note 1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its majority-
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Notes regarding these materials

1.   This document is provided for reference purposes only so that Renesas customers may select the appropriate  
      Renesas products for their use. Renesas neither makes warranties or representations with respect to the
      accuracy or completeness of the information contained in this document nor grants any license to any 
      intellectual property rights or any other rights of Renesas or any third party with respect to the information in 
      this document. 
2.   Renesas shall have no liability  for damages or infringement of any intellectual property or other rights arising 
      out of the use of any information in this document, including, but not limited to, product data, diagrams, charts, 
      programs, algorithms, and application circuit examples.
3.   You should not use the products or the technology described in this document for the purpose of military  
      applications such as the development of weapons of mass destruction or for the purpose of any other military 
      use. When exporting the products or technology described herein, you should follow the applicable export 
      control laws and regulations, and procedures required by such laws and regulations.
4.   All information included in this document such as product data, diagrams, charts, programs, algorithms, and 
      application circuit examples, is current as of the date this document is issued. Such information, however,  is 
      subject to change without any prior notice. Before purchasing or using any Renesas products listed in this 
      document, please confirm the latest product information  with a Renesas sales office. Also, please pay regular 
      and careful attention to additional and different information to be disclosed by Renesas such as that disclosed 
      through our website. (http://www.renesas.com )
5.   Renesas has used reasonable care in compiling the information included in this document, but Renesas 
      assumes no liability whatsoever for any damages incurred as a result of errors or omissions in the information 
      included in this document.
6.   When using or otherwise relying on the information in this document, you should evaluate the information in 
      light of the total system before deciding about the applicability of such information to the intended application.
      Renesas makes no representations, warranties or guaranties regarding the suitability of its products for any 
      particular application and specifically disclaims any liability arising out of the application and use of the 
      information in this document or Renesas products.
7.   With the exception of products specified by Renesas as suitable for automobile applications, Renesas 
      products are not designed, manufactured or tested for applications or otherwise in systems the failure or 
      malfunction of which may cause a direct threat to human life or create a risk of human injury or which require 
      especially high quality and reliability such as safety systems, or equipment or systems for transportation and 
      traffic, healthcare, combustion control, aerospace and aeronautics, nuclear power, or undersea communication 
      transmission. If you are considering the use of our products for such purposes, please contact a Renesas 
      sales office beforehand. Renesas shall have no liability for damages arising out of the uses set forth above.
8.   Notwithstanding the preceding paragraph, you should not use Renesas products for the purposes listed below:
        (1) artificial life support devices or systems
        (2) surgical implantations
        (3) healthcare intervention (e.g., excision, administration of medication, etc.)
        (4) any other purposes that pose a direct threat to human life
      Renesas shall have no liability for damages arising out of the uses set forth in the above and purchasers who
      elect to use Renesas products in any of the foregoing applications shall indemnify and hold harmless Renesas 
      Technology Corp., its affiliated companies and their officers, directors, and employees against any and all 
      damages arising out of such applications. 
9.   You should use the products described herein within the range specified by Renesas, especially with respect 
      to the maximum rating, operating supply voltage range, movement power voltage range, heat radiation 
      characteristics, installation and other product characteristics. Renesas shall have no liability for malfunctions or 
      damages arising out of the use of Renesas products beyond such specified ranges.
10. Although Renesas endeavors to improve the quality and reliability of its products, IC products have specific 
      characteristics such as the occurrence of failure at a certain rate and malfunctions under certain use 
      conditions. Please be sure to implement safety measures to guard against the possibility of physical injury, and 
      injury or damage caused by fire in the event of the failure of a Renesas product, such as safety design for 
      hardware and software including but not limited to redundancy, fire control and malfunction prevention, 
      appropriate treatment for aging degradation or any other applicable measures.  Among others, since the 
      evaluation of microcomputer software alone is very difficult, please evaluate the safety of the final products or  
      system manufactured by you.
11. In case Renesas products listed in this document are detached from the products to which the Renesas 
      products are attached or affixed, the risk of accident such as swallowing by infants and small children is very 
      high. You should implement safety measures so that Renesas products may not be easily detached from your 
      products. Renesas shall have no liability for damages arising out of such detachment.
12. This document may not be reproduced or duplicated, in any form, in  whole or in part, without prior written 
      approval from Renesas. 
13. Please contact a Renesas sales office if you have any questions regarding the information contained in this  
      document, Renesas semiconductor products, or if you have any other inquiries.
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前言

关于本手册

本手册将说明瑞萨 FLASH 开发工具箱 （以下简称 FDT）的使用方法。

第 1 章， [ 简介 ]，对本工具及其特点进行了简要说明。

第 2 章， [ 系统概要 ]，说明 FDT 图形用户界面 （GUI）的功能构成。

第 3 章， [FDT 的使用方法 ]，对 FDT 的启动和 FLASH ROM 的写入进行简单的说明。

第 4 章， [ 等待脚本 ]
第 5 章， [ 存取权限 ]，说明用户名和密码的设定。

第 6 章， [ 用户界面的配置 ]，说明 FDT 图形用户界面的配置方法。

第 7 章， [ 菜单 ] 和第 8 章， [ 窗口 ]，说明菜单和窗口的操作方法及功能。

第 9 章， [Simple Interface Mode]，说明简化的 FDT 图形用户界面的使用方法。

第 10 章， [Basic Simple Interface Mode]，说明无需设置工作空间 （Workspace）及工程 （Project）的简化

FDT 图形用户界面的使用方法。

第 11 章， [ 现场写入 ]，说明如何利用现场写入功能向其他的 FDT 用户发送工程，以及如何使用该工程。

第 12 章， [E8 和 E8a 的升级 ]，说明 FDT 如何更新 E8 或 E8a 固件。

第 13 章， [ 接口板 ]，说明可对应的接口板。

第 14 章， [QzROM 的程序设计 ]，说明瑞萨 FLASH 产品的新型程序设计。

第 15 章， [ 锁定 ]，说明当使用具有擦除块锁定功能的芯片时的 FDT 运行。

第 16 章， [ 识别码的写入 ]，说明如何对 FDT 工程进行序列编号。

第 17 章， [ 升级到 FDT4.01]，说明升级到 FDT4.01 时的注意事项。

前提

本手册以用户使用过 Microsoft® Windows® 的应用程序为前提。



缩写

Target / Device 连接到 （用于编程的） PC 的可编程微控制器或微机

DLL Dynamic Linked Library

FDT FLASH Development Toolkit

QzROM 只可编程一次的存储器

HEW Renesas High-performance Embedded Workshop

PC Personal Computer

USB Universal Serial Bus 1.1 以上

FDM FLASH Development Module （USB 接口板）

UPB Universal Programming Board – 结合 Protocol A (Legacy) 核心程序使用的 Legacy HMSE 接口板

HMSE Hitachi Micro Systems Europe Ltd. – Renesas Technology Europe Engineering Division 部分以前的名

称

FCF FLASH Configuration File – 用于保存芯片及闪存特性的信息。

DDI Device Data Image – 这是一种混合型 S-Record 文件格式，可在拥有多个闪存区的芯片中保存数据。

Kernel 这是用于控制芯片的代码，拥有再编程功能。这种代码多被下载到芯片中。

Micro Kernel 这是核心程序中最先被执行的部分，可进行初始配置及主核心程序的下载。

Main Kernel 这是核心程序中被微核心程序下载的部分，（若需要）可下载具有读、写、空白检查、擦除等功能的

附加模块。

E8 / E8USB 这是一种 USB 接口板。支持单线接口的编程及 4 线接口的时钟同步编程等。

FoUSB 是由 RTA 开发的 USB 接口板，用于闪存的写入以及内部电路的调试。在亚洲地区的 FDT 版本中暂不

支持。

Field 
Programming – 
Publishing

此功能可将所有的核心程序文件及数据文件合成一个文件，轻松发送到其他 FDT 用户。

E8Direct （使用现有的 E8 硬件）对于 E8 进行了升级的固件。其设计与 FDM 极其相似。

E8a E8a 为下一代 E8 产品，在原有产品的基础上增加了新的功能。E8a 是 on-chip 调试仿真器和闪存编程

器。

E8aDirect E8aDirect 为 E8a 的备用运行模式，其设计与 E8Direct/FDM 相似。



手册表示方法

本手册中，使用以下的表示方法。

表 1.1　表示方法

Windows® 是美国 Microsoft Corporation 的注册商标。

表示 意义

[Menu → MenuOption] 粗体字和“→”一起表示菜单选项

（例如： [File → Save As...])。

“对话框名称” 引号“”中表示的是对话框或菜单的名称。

“Filename.ext” 粗体的 Courier 字体表示文件名。

“输入文字” 表示输入的文字（不包括引号 “”）。

Key+Key 表示输入的键。例如， CTRL+N 是指按住 CTRL 键不

放，同时按下 N 键。

（操作方法记号）

本记号在左端，其右边的文章表示操作方法。
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第 1 章 简介

瑞萨 FLASH 开发工具箱 (FDT) 是用于瑞萨闪存微机的板上闪存写入工具，提供了高性能、便利的图形用

户界面 （Graphical User Interface, GUI）。

使用瑞萨 High-performance Embedded Workshop (HEW) 建立的嵌入式软件开发工程（Project）可通过 FDT
写入瑞萨闪存芯片。

另外， FDT 可作为通用的 S-Record 形式或 16 进制编辑器使用。

1.1 主要特点

· 基于 32 位 Windows ®GUI 的标准窗口操作

· 丰富的在线帮助功能

· 可选择信息输出等级

· 简化的写入环境；可任意控制适配器电路板

· 串行通信

· 支持通过 USB 接口板 （包括 E8a）进行的 USB 通信

· 可与选择的目标芯片直接进行 USB 通信

· 等待脚本文件功能

· 一个图像中有多个闪存区 （DDI）

· QzROM 的程序设计

1.2 新特点

FDT4.01 具有以下新功能：

· 具有识别码写入功能，可进行序列编号等

· 可使用调试接口和 E8a 对 H8-Tiny / H8-SLP 进行编程 （仅限于某些芯片）

· 在上传和选择时，可显示校验和
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第 2 章 系统概要

FDT 提供对瑞萨闪存芯片写入、擦除、读取的方法。工作空间 （Workspace）及工程 （Project）可用于保

存 session （会话）的设置，以便在不同的设置间简单地切换，并允许有经验的用户为没有经验的操作人员创

建设置。 FDT 旨在提供共同的界面风格，与被写入的实际芯片无关，具有相同的操作性。

FDT 采用了层级结构，因此能以逻辑方式进行工作。最上层是工作空间。

使用 FDT 时，工作空间至少必须包含一个工程。创建工程前，先创建工作空间。

在创建工程时各个工程设定其目标芯片的配置，并指定写入芯片的目标文件 （S-Record/16 进制 /2 进

制）。

连接目标芯片的工程设置只需进行一次，因为通过保存工程，可保存这些设置。即使 session 改变，这些

设置仍然有效。

工作空间中，通常只有一个工程处于激活状态。“Device”菜单、“Project”菜单、“Project”工具栏只对

激活的工程起作用。

创建工程后，可添加目标文件。这些文件可以：

· 用于芯片的写入

· 用于创建 Device Image （芯片映像）

· 用 16 进制编辑器打开

· 被指定为 User Boot Area （用户引导区）专用 （只限于支持此功能的芯片）

· 计算校验和

· 显示数据块的使用方法

· 与已经写入芯片的数据进行比较

使用工程时，可使用 FDT 的以下特点。

· 高级信息等级

· Device Image 创建器

· 从目标芯片上传数据

· 以大端法、小端法或浮点显示方式显示上传的数据

· Simple Interface （简化界面）模式 （用于构建工程后用户界面的简化）

· 打开工程时，自动屏蔽文件的非闪存区

· 自动屏蔽闪存区中的保留区
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2.1 用户界面（User Interface）
FDT 图形用户界面是对应 Windows® 的应用程序，提供了允许用户写入闪存的工作环境。

图 2.1　FDT 图形用户界面

2.1.1 Menu Bar （菜单栏）

在菜单栏中，命令被分为相关的若干个组，并配以菜单标题。用户可使用鼠标选择命令，调用对话框或窗

口来指挥系统的工作。在菜单标题上单击左键，打开下拉菜单，在这里可以选择菜单选项。

某些菜单选项并不直接工作，而是在打开对话框或窗口后，等待用户的指示。这样的菜单选项在名字后面

附有省略符号 （3 个点：…）。

图 2.2　菜单的省略符号

也有通过快捷键 （多个键的组合）调用的菜单选项。此时，快捷键显示在菜单选项的右侧。

菜单选项的功能可在 On / Off 间切换，当此功能处于 On 状态时，在菜单选项旁边会显示选定标记。
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图 2.3　选定的菜单项目

旁边标有三角记号 （ ）的菜单选项，可使用层叠 （或阶层）菜单。单击菜单选项时，将显示层叠菜

单。

图 2.4　层叠菜单

也可从键盘直接选择菜单。按下 ALT 键的同时，一并按下用户想选择的菜单选项中带有下划线的文字或

者数字的键。例如，保存当前的文件时 （[File → Save]），依次按下 ALT+F 键、 ALT+S 键。

2.1.2 Toolbars （工具栏）

在 FDT 的菜单栏下方有多个工具栏。用鼠标单击各按钮，可快速访问 FDT 的功能。

图 2.5　FDT 工具栏

各个工具栏中的按钮分为相关的几个组。

想要知道按钮的功能时，将鼠标放在按钮上，按钮旁边和状态栏中将显示其功能概要。

可以自定义工具栏。FDT 中几乎所有的功能都可作为按钮添加，按钮的配置顺序也可根据用户的喜好进行

更改。

有关工具栏按钮配置的更改、各个按钮的功能等详细情况，请参照 [ 第 6 章 ]。



第 2 章   系统概要

Rev.2.00  2008.04.24  Page 5 of 115
RCJ10J0052-0200

Edit toolbar （编辑工具栏）

图 2.6　编辑工具栏

Save File： 保存当前的文件。

Cut： 剪切数据到剪贴板中。

Copy： 复制数据到剪贴板中。

Paste： 从剪贴板中粘贴数据。

Open a Data File： 打开 S-Record 文件或其他数据文件。

FDT toolbar （FDT 工具栏）

图 2.7　FDT 工具栏

Connect： 连接芯片和 FDT 接口。

Disconnect： 切断芯片和 FDT 接口的连接。

Erase Blocks： 打开 “Erase Block”对话框，擦除芯片闪存的特定块或者全部块。

Blank Check： 检查目标芯片的闪存区是否空白。

Upload： 打开 “Upload Image”对话框，从目标芯片中上传数据。

Download Active File： 在 16 进制编辑器中下载当前的文件。

Checksum： 返回闪存数据的校验和。

Go from Address： 打开选择执行地址的对话框。

Run： 将芯片置为用户模式，必要时，提供电源以检测写入的芯片代码。。

Cancel： 取消当前的闪存操作。

Configure Flash Project： 打开 “Project Properties”（工程属性）对话框 （未创建工程时是 Project 
Wizard）。

Save File
Cut

Copy
Paste

Open a Data File

Connect
Disconnect

Erase Blocks
Blank Check

Upload
Download Active File

Checksum
Go from Address

Run
Block Locking

Cancel
Configure Flash Project
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S-Record / Data File Toolbar （S-Record / 数据文件工具栏）

图 2.8　S-Record / 数据文件工具栏

View as Bytes： 以字节 （8 位）为单位显示数据。

View as Words： 以字 （16 位）为单位显示数据。

View as DWords： 以双字 （32 位）为单位显示数据。

Endian： 在小端 （Little Endian）显示和大端 （Big Endian）显示间切换。

Align view to 8 bytes： 每 8 字节一组显示数据。各行能显示的字节数因窗口大小而异。

Toggle ASCII： 切换数据是否以 ASCII 码显示。

Find： 打开 “Find”（查找）对话框。

Find and Replace： 打开 “Replace”（替换）对话框。

Create Selection： 选择当前文件中指定大小的块。

Fill selection： 打开 “Fill”（填写）对话框。

Properties： 打开关于当前文件信息的对话框。

QzROM toolbar （QzROM 工具栏）

图 2.9　QzROM 工具栏

Automatic Protection： 断开连接时，自动设置 QzROM 安全性保护。（有多个选项时，将显示对话

框，供用户选择自动适用的类型。）

Query Protection： 断开连接时，询问用户是否设置 QzROM 安全性保护。

No Protection： 断开连接时不设置 QzROM 安全性保护。

【注】 设置保护后，可能再也不能与此特定目标芯片进行连接。

View as Bytes
View as Words

View as DWords
Endian

Align view to 8 byte
Toggle ASCII

Find
Find and Replace
Create Selection

Fill selection
Properties

Automatic Protection
Query Protection

No Protection
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Search toolbar （检索工具栏）

图 2.10　检索工具栏

Find in Files： 从所选文件中查找选择的数据。

Data： 检索内容。

Find： 在当前文件中查找。

Find Next： 查找下一个。

Find Previous： 查找前一个。

2.1.3 Status Bar （状态栏）

FDT 应用程序窗口的底部有状态栏。状态栏中显示应用程序的运行情况。

把鼠标指针置于某个工具栏按钮之上时，状态栏左端显示该选项的动作和工作状态信息。

在执行操作时，显示当前工作的进度。

状态栏的最后部分表示 Caps Lock、 Insert 和 Number Lock 等用于切换的键盘键的状态。

2.1.4 Pop-up menus （弹出菜单）

许多窗口中有本地弹出菜单，可轻松访问频繁使用的功能。在窗口中单击鼠标右键或者同时按下

SHIFT+F10 键可打开弹出式菜单，选择需要的菜单选项。以下是弹出式菜单的示例。

图 2.11　弹出式菜单

有关各弹出式菜单的内容和操作的详细情况，请参照 [ 第 8 章 ] 中各个 FDT 窗口的说明。
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2.2 帮助系统（Help）
FDT 中有标准的 Windows® 帮助系统，可显示有关系统使用的在线帮助信息。

按下 F1 键，或者选择 Help 菜单，都可调出帮助信息。

2.3 快捷键（Hot Keys）
在经常使用的操作中，快捷键的分类如下所示。

内容 快捷键

帮助

　Help (H) F1

文件命令

　Close File Ctrl+F4

　Open S-Record Ctrl+R

　Save Ctrl+S

　Exit Alt+F4

编辑命令

　Undo Ctrl+Z

　Redo Ctrl+Y

　Cut Ctrl+X

　Copy Ctrl+C

　Paste Ctrl+V

　Select All Ctrl+A

　Find Ctrl+F

　Find In Files F4

　Replace Ctrl+H

工具命令

　Login Ctrl+ Shift+U

简化界面命令

　登录 Ctrl+ Shift+U

显示

　Workspace Alt+K

　Output Alt+U

窗口

　ASCII 列 Alt+A

　字节 Alt+1

　字 Alt+2

　双字 Alt+4

　8 字节边界 Alt+8
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内容 快捷键

芯片

　Connect Ctrl+Alt+C

　Erase Flash Blocks Ctrl+Alt+E

　Blank Check Ctrl+Alt+B

　Upload Image Ctrl+Alt+U

　Download Active File Ctrl+Alt+P

　Flash Checksum Ctrl+Alt+S

　Go From Address Ctrl+Alt+G

　Run Ctrl+Alt+R

　Block Locking... Ctrl+Alt+L

　Cancel Operation Ctrl+Break

　Configure Flash Project Alt+Shift+R

数据文件

　关闭数据文件时，不显示保存更改的请求（不保存更改） 关闭数据文件时，按住 Shift 键
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第 3 章 FDT 的使用方法

3.1 基本操作步骤

芯片的写入按照以下步骤进行。

1. 启动 FDT。请从 [Start → Programs → Renesas → Flash Development Toolkit 4.01] 中选择 [Flash 
Development Toolkit 4.01] 的快捷方式 （请参照 [3.3]）。

2. 创建工作空间 （Workspace）和工程 （Project）（请参照 [3.4.1]）。

3. 使用 FLASH Project Wizard 构建工程 （芯片、核心程序、端口和模式等的选择）（请参照 [3.4.2] ～
[3.4.8]、有关 Generic Boot 请参照 [3.5]）。

4. 在工程中添加欲下载的文件 （请参照 [8.1.2]、 [8.2.2]、 [3.7]）。在工作空间窗口中，通过右键单击各

文件进行下载，也可将多个文件整合成一个 Device Image （使用 [Project → Rebuild Image] 菜单），然

后下载此 Image （使用 [Project → Download Image] 菜单）。

另外，可通过以下步骤在 FDT Basic Simple Interface 模式中启动。

1. 从 [Start → Programs → Renesas → Flash Development Toolkit 4.01] 中选择 [Flash Development Toolkit 
4.01 Basic] 的快捷方式。（请参照 [3.3]）。

2. 使用 Wizard 配置设定 （芯片、核心程序、端口和模式等的选择）（请参照 [3.4.2] ～ [3.4.8]、有关

Generic Boot 请参照 [3.5]）。

3. 选择想要写入的闪存区 （User Area 或者 User Boot Area）。

4. 选择写入有效区的文件。

5. 按下 “Program Flash”按钮。

6. 结束写入后，切断连接。

3.2 背景信息 (Background Information)

3.2.1 User Area、 User Boot Area、 Data Area （用户区、用户引导区、数据区）

User Area 是用来保存用户程序的芯片内置闪存区。当芯片复位到 User Mode 后，芯片执行该闪存区的代

码。一般来说， User Area 可通过 Boot Mode 或者 User Mode 连接来写入。

在某些芯片中有追加的 User Boot Area 闪存区。User Boot Area 通常比 User Area 小得多，主要用于保存用

户的引导程序。当芯片复位到 User Boot Mode 后，执行该闪存区的代码。用户的引导程序可以经由其他的通

信媒体 / 协议，与芯片建立通信。通常， User Area 和 User Boot Area 都是从同一地址开始，这是因为每一次芯

片复位后，只有一方被映射到存储器映像。 User Boot Area 不能在 User Mode 下写入，只能在 Boot Mode 下写

入。

在某些芯片中有追加的 Data Area 闪存区。一般来说，这个区位于 User Area 的存储器映像的另一端。

和 User Boot Area 不一样， Data Area 和 User Area 不邻接，并且总是存在于存储器映像中。
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3.2.2 Boot Mode （引导模式）和 User Mode （用户模式）的区别

瑞萨闪存芯片有不同的工作模式，可通过芯片复位时模式引脚的状态来控制这些模式。几乎所有的芯片都

有异步串行 Boot Mode、 User Mode 和 User Program Mode 工作模式。

通常，（异步串行） Boot Mode 连接以自动波特开始通信——以某个波特率发送同步数据包来建立初始通

信。另外，大多数芯片的整个闪存区内容将在连接过程中被删除，从而防止芯片上的用户程序代码在 Boot 
Mode 下被读取。

有关 User Mode 连接，必须事先将含有 FDT 对话处理进程和写入许可处理进程的用户程序写入芯片。大

部分的芯片核心文件都提供用于 User Mode 工作模式的微型核心程序及测试程序 （一般称为 “uGenU.mot”

及 “xxxxtest.mot”）。此类文件提供 User Mode 编程的演示，必须在 FDT 尝试用 User Mode 连接前，将这

些文件写入芯片并执行它们。 User Mode 工作模式通常不在连接过程中强制删除闪存区内容，也不用自动波特

来设置通信。为了以默认值 9600 波特的速度建立初始通信，必须将所需的 Bit Rate Register 值编译到 User 
Mode 的测试程序中。因此，对于不同的系统时钟频率 User Mode 核心程序需要进行再创建。

【注】 * 将文件作为嵌入式监视程序的一部分来使用的情况下， User Mode 核心程序文件也可在没有复位向量时作为 2  
进制文件（.cde）输出。某些芯片在 User Mode 测试程序（例如， Protocol C 核心程序）中，只使用单一的

文件。

3.2.3 User Mode （用户模式）与 User Program Mode （用户程序模式）的区别

在一些芯片中添加有模式引脚，以防止对闪存的误写入或误擦除。此引脚若须在高电平写入时，一般称为

“Flash Write Enable”引脚 （FWE）；须在低电平写入时，称为 “Flash Write Protect”引脚 （FWP）。对于这

些芯片，此引脚可区别 “User Mode”和 “User Program Mode”。当写入和擦除时，最好在芯片的 User 
Program Mode 中进行 FDT User Mode 连接，如果使用 FDM，可以在断开连接时将芯片复位到 User Mode，执

行写入的代码。

3.2.4 “Protocol B” （协议 B）、“Protocol C”（协议 C）、“Protocol D” （协议

D）和“Protocol E” （协议 E）核心程序

· “Protocol B”：用于 0.35μm 芯片。支持 FDM，不支持 UPB。
Boot Mode – 核心程序（由 Boot Mode Micro Kernel、 Boot Mode Main Kernel 和写入／擦除模块构成）

保存在 PC 上，并在需要时下载。 Boot Mode 核心程序不需要根据不同的晶体频率再创建。此信息保存

在 FDT 的工程中，在运行时下载。另外，通过自动波特实现初始通信 （在芯片和 FDT 同步前， FDT 
一直传送 0x00 数据）。

User Mode – User Mode Test Program、及 User Mode Micro-Kernel 需要事先写入芯片并执行。 Bit Rate 
Register 初始值保存在 “gentest.h”文件中，并被编译到 User Mode Test Program。因此，核心程序可将

串行通信接口初始化为 9600 波特。如果时钟频率不是默认值，就需要改变 “gentest.h”（一般为

MA_BRR_SCI 或 MA_BRR_SCI1）中的 Bit Rate Register 的初始设置，并再次编译核心程序。 User 
Mode Main Kernel 和写入 / 擦除模块保存在 PC 上，并在需要时下载。

· “Protocol C”：用于具有嵌入式核心程序 （现在为 0.18μm）的芯片。支持 FDM，不支持 UPB。
Boot Mode – 配置文件保存在向 FDT 提供芯片详细情况的 PC 上，核心程序 （包括写入／擦除模块）

则存在于芯片内部。在 Boot Mode 下，对于不同的时钟频率无需进行再创建。此信息保存在 FDT 的工

程中，在运行时下载。另外，通过自动波特实现初始通信 （在芯片和 FDT 同步前， FDT 一直传送

0x00 数据）。

· “Protocol D”：用于 R8C 和以前的三菱芯片如 M16C、 M32C 等。

E8 和 FoUSB 电路板可以和某些 Protocol D 芯片一起使用。核心程序存在于芯片内部， FDT 使用配置

文件保存有关芯片特性的信息。

· “Protocol E”：用于部分 H8/Tiny 和 H8/SLP （Super Low Power）芯片 （详细请参照 “readme”文本

文件）。
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虽然 FDT 可通过 COM、 FDM 或 E8aDirect 与 H8H8/Tiny 和 H8/SLP 芯片通信（作为“Protocol B”），

但作为“Protocol E” FDT 也可通过 E8a 与 H8H8/Tiny 和 H8/SLP 芯片通信。请注意，在“Protocol E”
中不具备 FDT 的以下重要功能：

- 对闪存 ROM 数据的擦除功能 （但在连接时所有闪存 ROM 数据会被擦除）

- 对闪存 ROM 数据的上传功能

- 空白检查功能

- 读回验证功能 （但 FDT 在写入后会自动执行校验和）

3.2.5 何谓 fcf 文件及 fdm 文件 ? 是否可编辑 ?
Fcf (FLASH Configuration File) 及 .fdm (FLASH Development Module) 是与其他的核心程序文件保存在一起

的文件，记录了芯片和核心程序的详细情况。各核心程序目录中所支持的芯片都有自己的 .fcf 文件和 .fdm 文

件。 RAM 大小、闪存大小、 Erase Block Register 的详细情况、默认波特率及默认晶体频率等信息都保存在 fcf
文件中， FDM 的有效端口设置的详细情况则保存在 FDM 文件中。由于这些文件都有校验和保护，因此编辑会

使文件无效，同时会被 FDT 检测出来。当检测出 .fcf 文件或 .fdm 文件的无效校验和时， FDT 会向用户发出警

告，但不会停止修改过的文件的使用。

3.2.6 自己的 PC 中如果没有本地主机管理员权限，可否使用 FDT?
可以使用，不过要在安装和构建 FDT 后。 FDT 的安装及各种配置任务的执行，需要本地管理员权限，因

为某些设置是保存在 HKEY_LOCAL_MACHINE 注册区的。安装和构建 FDT 后，可在一定限制下使用。配置

任务 （比如：为了将来能在 Project Wizard 中使用新的核心程序项目，在登录表中添加这些项目等）的执行需

要本地主机管理员权限。这也包括 Prior Generic Device 项目的添加（管理者为了能创建 Prior Generic Device 项

目，开始时必须连接 Generic Device）。另外，用于变更设置 （如超时的微调等）的 FDT Advanced Setup 实用

程序，需要本地主机管理员权限来保存设置。密码管理也需要此权限。

3.2.7 如何再编译核心程序 ?
推荐将原始核心程序复制到其他目录进行编辑，而对其不作修改。初次使用核心程序时，需要浏览备用地

址来检索 fcf 文件。

使用 HEW 写入核心程序时，核心程序的工程子目录中将生成 HEW 的工作空间文件。此文件从 HEW 打

开。

如果核心程序是在编译基础上从命令行开始写入的，就需要在设定编译器的环境变量后，从 DOS 外壳

session 运行 buildall.bat 文件，以便编译器能从命令行开始执行。有关这种执行方法的详细情况请参照编译器手

册。瑞萨制 H8 编译器版本 4.0a 中环境设置时的批文件的示例如下。

Setenv.bat:

SET CH38=C:\hew\tools\Renesas\h8\4_0_A\INCLUDE

PATH=%PATH%;C:\hew\tools\Renesas\h8\4_0_A\bin

set DOS16M= @1M-31M

SET CH38TMP=c:\TEMP

【注】 对于操作系统 （Windows® 2000 等）使用 cmd.exe 而不使用 command.com。

为了反映所用编译器路径，需要更改上述批文件。

请确认指定的临时目录存在，并且为可写状态。
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3.2.8 如何使用演示 User Mode Kernel （用户模式核心程序） ?
使用演示 User Mode 核心程序时，首先要把 User Mode Micro Kernel 及 User Mode Test Program 从核心程序

目录 （“uGenU.mot”及“xxxxtest.mot”）添加到 Boot Mode Project，并创建 User Area Device Image。然

后，在 Boot Mode 下连接，把 Image 写入芯片，切断芯片并复位到用户模式 （User Mode）。在工作空间中创

建另一个工程，此工程设定为 User Mode Connection Type，并在 User Mode 下连接。 FDT 以 9600bps 的速率与

User Mode Test Program 开始通信，然后改为工程中设定的波特率。请注意：在 User Mode 下连接时，芯片无法

自动擦除。从闪存中执行代码的改写时，因为不能改写闪存，所以将所有需要与 FDT 保持连接的核心程序模

块都复制到 RAM 中，使 FLASH ROM 处于可改写的状态。所以，可在 User Mode 下擦除和改写整个闪存，但

必须注意，如果在擦除之后改写之前前复位芯片的话，将不能再次打开 User Mode 下的连接，直到芯片将 User 
Mode Micro Kernel 及 User Mode Test Program 改写到 Boot Mode。

3.2.9 是否能更改 User Mode （用户模式）核心程序，使用不同的时钟频率工作 ?
推荐将原始核心程序复制到其他目录进行编辑，而对其不作修改。初次使用核心程序时，需要浏览备用地

址来检索 fcf 文件。

想使用不同的时钟频率时，需要再次创建 User Mode 核心程序。 Bit Rate Register 的初始值保存在

“gentest.h”文件中，并被编译到 User Mode Test Program。因此，核心程序可将串行通信接口初始化为 9600 波

特。如果时钟频率不是默认值，就需要改变 “gentest.h”（一般为 MA_BRR_SCI 或 MA_BRR_SCI1）中的 Bit 
Rate Register 的初始设置，并再次编译核心程序。有关 Bit Rate Register 值的计算方法，请参照芯片的硬件手

册。

3.3 启动 FDT

3.3.1 在安全模式和 Simple Interface （简化界面）模式无效时启动 FDT
启动 FDT 时，从 Windows® 的 “Start”菜单中选择 [Programs → Renesas → FLASH Development Toolkit 

4.01]，然后选择 “FLASH Development Toolkit 4.01”的快捷方式。“Welcome”对话框以默认形式打开。

创建新的工作空间时，选择 “Create a new Project Workspace”，并单击 “OK”按钮 （详细情况请参照

[3.4.1]）。打开最近使用的工作空间，选择 “Open a recent project workspace”并从列表中选择想要打开的工作

空间。若想打开列表中没有的工作空间，选择 “Browse to another project Workspace”。最后单击 “OK”按

钮。

图 3.1　“Welcome”对话框
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3.3.2 在 Basic Simple Interface Mode （基础简化界面模式）中启动 FDT
在 Basic Simple Interface Mode 中启动 FDT 时，从 Windows® 的“Start”菜单中选择 [Programs → Renesas 

→ FLASH Development Toolkit 4.01]，然后选择 “FLASH Development Toolkit 4.01 Basic”的快捷方式。以前

的 FDT 基本设置将被恢复，并可通过 [Options →New Settings...] 菜单选项进行新的设置。

3.3.3 双击工作空间文件启动 FDT
在 Windows® Explorer 中双击工作空间文件可启动 FDT。启动时， FDT 读取选择的工作空间。

3.3.4 双击数据文件启动 FDT 
在 Windows®Explorer 中双击登录的数据文件可启动 FDT （如果安装时选择了此默认选项）。启动时，

FDT 读取选择的数据文件。

3.3.5 双击脚本配置文件 (.w4f) 启动 FDT
在 Windows®Explorer 中双击脚本配置文件 (.w4f)，可使 FDT 在等待脚本模式中启动，并读取所选的配

置。

3.3.6 Simple Interface Mode （简化界面模式）有效时启动 FDT
在 Simple Interface Mode （请参照 [ 第 9 章 ]）下结束 FDT 时， FDT 将再次返回该模式。

3.3.7 存取权限密码保护有效时启动 FDT
存取权限密码保护有效时， FDT 会在打开工作空间前显示登录对话框。详细情况请参照 [ 第 5 章 ]。

3.3.8 双击工程文件包 (.fpf4) 启动 FDT
在 Windows®Explorer 中双击工程文件包 (.fpf4)，可使 FDT 打开工程，并在 Simple Interface Mode 下启动。

3.3.9 从命令行启动 FDT
· 从命令行打开数据文件

"<FDT path>\FDT.exe" /DISCRETESTARTUP "osre \"< Filename >\""

eg:

"C:\Program Files\Renesas\FDT4.01\FDT.exe" /DISCRETESTARTUP "osre \"C:\Program 

Files\Renesas\files\myfile.mot\""

这是在 Windows®Explorer 中，双击 FDT 数据文件时使用的方法。

· 从命令行打开工作空间文件

"<FDT path>\FDT.exe" /DISCRETESTARTUP "ow\"<Long Path Workspacename>\""

eg

"C:\Program Files\Renesas\FDT4.01\FDT.exe" /DISCRETESTARTUP "ow \"C:\Program 

Files\Renesas\FDT4.01\Workspaces\1234\1234.AWS\""

这是在 Windows®Explorer 中，双击 FDT 工作空间时使用的方法。
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· 存取权限密码保护有效时从命令行打开数据文件

"<FDT path>\FDT.exe" "arl \"<Username>\" \"<Password>\"" /DISCRETESTARTUP "osre \"< 

Filename >\""

eg

"C: \Program Files\Renesas\FDT4.01\FDT.exe" "arl\"Administrator\" \"password\"" /

DISCRETESTARTUP "osre \"C:\Program Files\Renesas\files\myfile.mot\""

· 从命令行打开 w4f 脚本配置文件

"<FDT path>\FDT.exe" /DISCRETESTARTUP "w4fRun\"<filename>\""

eg

"C: \Program Files\Renesas\FDT4.01\FDT.exe" /DISCRETESTARTUP"w4fRun\"C: \Program 

Files\Renesas\FDT4.01\myconfig.w4f\""

这是在 Windows®Explorer 中，双击 FDT 脚本配置文件时使用的方法。

· 存取权限密码的保护有效时，从命令行打开 w4f 脚本配置文件

"<FDT path>\FDT.exe" "arl\"<Username>\"\"<Password>\"" /DISCRETESTARTUP "w4fRun 

\"<filename>\""

eg

"C:\Program Files\Renesas\FDT4.01\FDT.exe" "arl \"Administrator\" \"password\"" /

DISCRETESTARTUP "w4fRun \"C:\Program Files\Renesas\FDT4.01\myconfig.w4f\""

· 从命令行启动 FDTBasic Simple Interface Mode

"<FDT path>\FDT.exe" /DISCRETESTARTUP "SimpleInterfaceMode /u "<User Area Filename>" /b 

\"<User Boot Area Filename>\""

eg

"C:\Program Files\Renesas\FDT4.01\FDT.exe"/DISCRETESTARTUP "SimpleInterfaceMode /u 

\"c:\upload1.mot\" /b \"c:\upload0.mot\""

请注意 /u <User Area Filename>及 /b <User Boot Area>为可选。另外，添加 /r会使最后的设置复原，并

且不显示配置向导。

3.4 创建新的工作空间和工程

在 Full Mode （而不是 FDT 的 Basic Simple Interface Mode）下启动 FDT 时，必须打开或者创建工作空间

和工程。

在不设定工作空间和工程的情况下写入时，请参照 [ 第 10 章 ]。
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3.4.1 New Project Workspace （新的工程工作空间）

图 3.2　新工作空间

输入工作空间名 （默认为工程名）。输入结束后，单击 “OK”按钮。

想要改变或创建目录时，请输入目录名，或者使用 “Browse...”按钮。
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3.4.2 Choose Device and Kernel （not Generic Boot*）（选择芯片和核心程序）

（不是通用引导 *）
从列表中选择欲使用的芯片 / 核心程序。通过将内容输入 “Filter”（过滤）框，可过滤列表，注意：如果

工程名以 3 个或 3 个以上的数字开头，则其内容将被自动输入 “Filter”框。对于一个指定的芯片，可显示多

个核心程序选项。另外，双击核心程序，可打开包含了核心程序信息 （与核心程序同时创建的芯片、版本号

和编译器等）的可选文件 “readme.txt”。

当需要列表中没有的其他备用核心程序时，通过单击 “Other...”按钮来指定核心程序的闪存配置文件

（.fcf）。

【注】 * 有关与 Generic Boot 芯片的连接，请参照 [3.5]。

图 3.3　芯片和核心程序的选择
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3.4.3 Communication Port （通信端口）

在下拉列表中选择端口 （和可使用的接口），并单击 “Next”按钮。请注意：除了串行端口，也有使用 
FDM （USB 接口板）的选项。某些核心程序有 USB Direct （用于 2215UF 等）、 E8、 E8Direct 和 FoUSB 等其

他的端口选项。

图 3.4　通信端口

E8a 使用了 E8a 的调试接口

E8 使用了 E8 的调试接口

E8aDirect 使用了 E8a 的 UART

E8Direc 使用了 E8 的 UART

COM RS-232C

FDM 使用了 FDM 的 UART

USB Direct USB
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3.4.4 Device Settings （芯片的设置）

请输入芯片的设定值。输入时钟后，从下拉列表中选择主时钟及外围时钟的倍频，并单击 “Next”按钮。

图 3.5　芯片的设置

补充：

1. 时钟设置

选择芯片的外部时钟 （默认），或者一种以上的内部时钟速度。

2. CPU 晶体频率

输入 CPU 时钟或者晶体发生器的频率。小数点后 4 位有效。根据目标芯片、核心程序和时钟模式决定

有效范围。

3. 时钟模式

在可使用的情况下，从列表中选择需要的数值。

4. 主时钟 (CKM) 的倍频

在可使用的情况下，选择对应主时钟 （系统时钟）的输入时钟的倍频。有效的选项取决于目标芯片、

核心程序及时钟模式。

5. 外围时钟 (CKP) 的倍频

在可使用的情况下，选择对应外围时钟的输入时钟的倍频。有效的选项取决于目标芯片、核心程序及

时钟模式。

【注】 在进入时钟模式、输入时钟及倍频时，请参照芯片硬件手册和 / 或目标电路板手册，确认所需值。
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3.4.5 Connection Type （连接的种类）

请从“Connection Type”对话框中选择是 Boot Mode 连接还是 User Mode 连接。另外，当从以前的 session
（会话）对芯片中仍在运行的核心程序进行连接时，请选择 “Kernel already running”复选框。在默认值不正

确或者不存在的情况下，选择通信速度 （bps）。目标误差率达到 4% 以上，或者 FDM\E8Direct 误差率在 0%
以上的速度，将从推荐列表中自动删除。在使用 FDM\E8Direct 时，“User Specified”连接速度选项有效。通过

选择此项，用户可指定非标准波特率。显示的误差考虑了目标外围时钟速率、目标 Bit Rate Register 计算式及

FDM\E8Direct 的特性。

单击 “Next”按钮，进入下一步。

图 3.6　连接的种类

请注意 , “Use Default”是和瑞萨 Evaluation Board （评价电路板）或者 Evaluation Development Kits （评

价开发工具箱）一起使用的。取消 “Use Default”选项后，可手动选择位速率。
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3.4.6 Programming Options （写入选项）

选择写入 FLASH ROM 时的保护等级和信息等级，输入结束后，单击 “Finish”按钮。选择

FDM\E8Direct 时，单击 “Next”按钮进入下一步。

图 3.7　写入选项
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3.4.7 FDM\E8Direct\E8aDirect Pin Settings （FDM\E8Direct\E8aDirect 的引脚设置）

[ 只在选择 FDM、 E8Direct 或 E8aDirect 时 ] 选择 “Operating Mode”及 “Clock Mode”。在 “User 
Defined”选项下设置引脚。 [ 在 “Boot Mode”工程中，设定所需模式的 “Boot Mode Outputs”及 “Boot 
Mode Setting”；在 “User Mode”工程中，设定所需模式的 “User Mode Outputs”“User Mode Setting”及

“User Program Mode Setting” ] 单击“Next”按钮进入下一步。“Mode Outputs*”设定要驱动的引脚。“Mode 
Setting*”设定驱动引脚的是 High （选定）还是 Low （不选）。

【注】 * 在设定模式引脚时，需要注意∶即使默认设置有效，也需要参照硬件手册确认引脚的设置。请注意∶在某些芯

片中改变模式引脚的设置，会使最大电源电压发生变化。

图 3.8　FDM 的引脚设置
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图 3.9　E8Direct 的引脚设置

图 3.10　E8aDirect 的引脚设置
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3.4.8 Reset Pin Settings （复位引脚设置）

[ 只在选择 FDM、 E8Direct 或 E8aDirect 时 ] 选择 “Operating Mode”及 “Clock Mode”。在 “User 
Defined”选项下，设定复位引脚。断开连接后，立即设定所需模式的 “Reset Outputs”及 “Reset Setting”，

并单击 “结束”按钮。

“Mode Outputs*”设定 FDM 驱动引脚。“Mode Setting*” 设定输出引脚是 High （选定）还是 Low （不

选）。

【注】 * 在设定模式引脚时，需要注意∶即使默认设置有效，也需要参照硬件手册确认引脚的设置。在某些芯片中改变

模式引脚的设置，会使最大电源电压发生变化。

图 3.11　FDM 的复位引脚设置
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图 3.12　E8Direct 的复位引脚设置

图 3.13　E8aDirect 的复位引脚设置
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3.5 Generic Boot （通用引导）芯片的工程构建

可连接瑞萨的 Generic Boot 芯片。用户无需安装核心程序或者配置文件，而是由 FDT 从芯片本身导出所

需的信息。因此，创建工程时需要连接芯片，且必须设定为 Boot Mode。选择 Generic Boot 芯片时，会在在一

系列画面中显示查询函数的结果。这时，用户需要选择芯片以及时钟模式 （一个引导程序可能由多个芯片共

用）。

3.5.1 New Project Workspace （新的工程工作空间）

输入工作空间名，单击 “OK”按钮。

（请选择是否创建目录并指定路径。）

图 3.14　新工作空间
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3.5.2 Generic Boot – Choose Device and Kernel （通用引导 – 选择芯片和核心程序）

选择 “Generic Boot Device”（或者 Generic Boot 支持的芯片），单击 “Next”。

图 3.15　Generic Boot 芯片的选择

【注】 芯片列表中显示的部分 Protocol C 芯片通过使用 Generic Boot 被支持。即，当 Project Wizard 选择这些芯片中的

某个时， FDT 所进行的操作会和选择“Generic Boot Device”时一样。同时， FDT 会通过连接芯片来获取芯片特

征的信息，而不是通过现有的 fcf 文件。

图 3.16　Generic Boot 的芯片支持
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3.5.3 Generic Boot – Communication Port （通用引导 – 通信端口）

从下拉列表中选择端口 （和可使用的接口），单击 “Next”按钮。

图 3.17　通信端口

3.5.4 Generic Boot – FDM Pin Settings [FDM connection only]（通用引导 – FDM 的引

脚设置 [ 仅限于 FDM 连接 ]）
选择 FDM 后，显示以下画面。请将芯片设定为 Boot Mode 所需的引脚，然后单击 “OK”按钮。

图 3.18　FDM Generic 芯片的引脚设置

【注】 在使用 FDM 设定模式引脚时，需要注意：即使默认设置有效，也需要参照硬件手册确认引脚的设置。在某些芯片

中改变模式引脚的设置会使最大电源电压发生变化。
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显示 “Select USB Device”对话框时，必须选择设定连接的 FDM 单元。

图 3.19　USB 芯片的选择

3.5.5 Generic Boot – E8Direct Pin Settings [E8Direct connection only] （通用引导 –

E8Direct 的引脚设置 [ 仅限于 E8Direct 连接 ]）
选择 E8Direct 后，显示以下的两个画面。

首先，显示可经由 E8 向目标电路板供电的可选电源 （请参照 [3.6.1]）。

图 3.20　E8 目标电源的选择

注意∶选择不正确的电压设置时，有可能损坏目标芯片！
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接下来，显示模式引脚设置对话框，在此对话框中，可将芯片设置为 Boot Mode。单击 “OK”按钮进入

下一步。

图 3.21　E8Direct 的引脚设置

【注】 在使用 E8Direct 设定模式引脚时，需要注意∶即使默认设置有效，也需要参照硬件手册确认引脚的设置。在某些

芯片中改变模式引脚的设置会使最大电源电压发生变化。

E8 作为 E8Direct 芯片未能再启动时， FDT 输出窗口显示以下的信息。

Preparing for re-enumeration of E8 to E8Direct...

Sending re-enumeration command...

Request sent successfully, closing E8 Comms...

与此同时， Windows® 将再次进行芯片的识别 （请参照 [ 第 13 章 ]）。

“Select USB Device”对话框显示时，必须选择用于设定连接的 E8Direct 单元。

图 3.22　USB 芯片的选择
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3.5.6 Generic Boot – E8aDirect Pin Settings [E8aDirect connection only] （通用引导 -
E8aDirect 的引脚设置 [ 仅限于 E8aDirect 连接 ]）

选择 E8aDirect 后，显示以下的两个画面。首先，显示可经由 E8 向目标电路板供电的可选电源 （请参照

[3.6.1]）：

图 3.23　目标电源的选择

注意∶选择不正确的电压设置时，有可能损坏目标芯片！

接下来，显示模式引脚设置对话框，在此对话框中，要求将芯片设定为 Boot Mode。单击 “OK”按钮进

入下一步。

图 3.24　E8aDirect Generic 芯片的引脚设置

【注】在使用 E8aDirect 设定模式引脚时，需要注意∶即使默认设置有效，也需要参照硬件手册确认引脚

的设置。请注意：在某些芯片中 , 改变模式引脚的设置会使最大电源电压发生变化。
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显示 “Select USB Device”对话框时，必须选择用于设置连接的 E8aDirect 单元。

图 3.25　USB 芯片的选择

3.5.7 Generic Boot – Confirmation （通用引导 – 确认）

FDT 会等待用户确认芯片的连接及电源的接通。未使用 FDM 或者 E8Direct 时，在 Boot Mode 下等待。用

户单击 “OK”按钮后， FDT 准备连接芯片。

图 3.26　Generic Boot 的确认

之后， FDT 将显示 Boot 进程的对话框。在 Generic Boot 进程中，用户需要选择并确认芯片的详细情况。

具体情况请参照以下内容。
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3.5.8 Generic Boot Select Device （通用引导选择芯片）

因为多个芯片共用一个引导程序，所以提供了一个支持芯片的列表。从列表中选择正确的芯片，单击

“OK”按钮。

图 3.27　Generic Boot 芯片
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3.5.9 Generic Boot Select Clock Mode （通用引导选择时钟模式）

有些芯片有多种时钟模式，因此提供了所有可能的时钟模式的列表。从列表中选择正确的时钟模式，单击

“OK”按钮。请参照硬件手册或者目标电路板手册，确认是否选择了正确的模式。

图 3.28　时钟模式
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3.5.10 Generic Boot Setup Complete （通用引导设置结束）

选择时钟模式后，如下所示结束 Generic Wizard。

图 3.29　Generic Boot 设置的结束

之后的页面将继续显示 Project Wizard。

3.5.11 Generic Boot Device Settings （通用引导芯片的设置）

请参照 [3.4.4]。

3.5.12 Generic Boot Connection Type （通用引导连接的种类）

请参照 [3.4.5]。

3.5.13 Generic Boot Programming Options （通用引导写入选项）

请参照 [3.4.6]。

3.5.14 Generic Boot Reset Pin Settings[FDM Connection only] 
（通用引导复位引脚设置 [ 仅限于 FDM 连接 ]）

请参照 [3.4.8]。

3.5.15 Generic Boot Reinterrogate on connect option
（通用引导连接选项的再确认）

在 “Flash Properties”对话框的 “Programmer”选项卡中，可设定 FDT 是否在每次连接时都要对 Generic
芯片进行再确认。默认值是 “NO”，这样，建立一次连接后， FDT 会重复使用初始查询函数收集的数据。若

将此选项改为 “YES”， FDT 在由 Boot Mode 连接时，每次都会向芯片确认其详细情况。这意味着 Generic 
Boot 工程可在任何 Generic Boot 芯片中使用。
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3.5.16 Prior Generic Device （先前的通用芯片）

若选择 “Prior Generic Device”，可连接到上次用 “Generic Boot Device”配置的芯片，并使用最初通过

“Generic Boot Device”进行连接时生成的 .fcf 文件。

3.6 连接芯片

可以使用 Ctrl+Alt+C 的快捷键连接芯片，也可以单击 [Connect] 工具栏按钮，或者选择 [Device → Connect 
to Device]。在连接前选择了闪存的操作 （上传、下载、空白检查、校验和等）时， FDT 首先会自动进行连

接。

3.6.1 E8\E8a USB Connection （E8\E8a USB 连接）

打开工作空间使用 E8 USB 接口板第一次连接时，通过显示的对话框，可选择是否由 E8 向目标供电及提

供多大的电压。连接后，选择的电源将向目标芯片供电，切断连接时电源也随之断开。选择的电源设置会一直

保存到关闭工作空间为止。

注意∶选择不正确的电压设置时，有可能损坏目标芯片。

图 3.30　E8\E8a 目标电源的选择

3.6.2 ID Check Dialog （ID 校验对话框）

ID 校验用于解除芯片锁定。对于支持 ID 校验的芯片，在通过自动解锁未能奏效时， 将显示 “ID Check”
对话框。可通过 [Browse...] 按钮选择从 mot 还是从 ID 文件中收集 ID 代码。

图 3.31　ID 校验对话框
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3.6.3 Locking （锁定）

在使用支持擦除块锁定功能的芯片时，根据当前的锁定设置，FDT 还有可能向用户确认是否解除芯片的锁

定 （详细情况请参照 [15.2]）

图 3.32　锁定的询问对话框

3.7 向闪存 ROM 写入数据

3.7.1 将单个文件写入 User Area （普通闪存区）

1. 通过 [Project → Add Files...] 或者用 INS 键添加要下载到工程中的文件。

2. 在工作空间窗口中显示的文件上单击右键，选择 [Download File]。输出窗口中若显示 “Image 
successfully written to device”，表明写入结束。

3.7.2 将多个文件写入 User Area （普通闪存区）

1. 通过 [ Project → Add Files...] 或者用 INS 键将所有需要的目标文件添加到工程中。注意：多个文件可通

过 “Add File(s)”对话框快速添加。

2. 选择 [Project → Rebuild Image]，创建 User Area 的 Device Image （创建汇集所有目标文件结果的文

件）。

3. 在工作空间窗口中显示的 Device Image 文件 （<ProjectName>.ddi）上单击右键，选择 [Download 
Image] （或者选择 [Project → Download Image]）。

4. 输出窗口中若显示 “Image successfully written to device”，表明写入结束。

3.7.3 将单个文件写入 User Boot Area （用户引导区）

1. 通过 [Project → Add Files...] 或者用 INS 键添加要下载到工程中的文件。

2. 在工作空间窗口中显示的文件上单击右键，选择 “User Boot Flash”，就表示此文件用于 User Boot 
Area。

3. 在工作空间窗口中显示的文件上单击右键，选择 “Download File to [User  Boot Flash]”。输出窗口中

若显示 “Image successfully written to device”，表明写入结束。
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3.7.4 将多个文件写入 User Boot Area （用户引导区）

1. 通过 [Project → Add Files...] 或者用 INS 键添加要下载到工程中的文件。注意：多个文件可通过 “Add 
File(s)”对话框快速添加。

2. 在工作空间窗口中显示的每个 （预定用于 User Boot Area 的）文件上单击右键，选择 “User Boot 
Flash” ，就表示此文件用于 User Boot Area。

3. 选择 [Project → Rebuild Image]，创建 User Area 的 Device Image （创建汇集所有目标文件结果的文

件）。

4. 在工作空间窗口中显示的 Device Image 文件 （<ProjectName>.ddi）上单击右键，选择 “Download 
Image”（或者选择 [Project → Download Image]）。

5. 输出窗口中若显示 “Image successfully written to device”，表明写入结束。

3.7.5 将文件分别写入 User Area （用户区）和 User Boot Area （用户引导区）

1. 选择 [Project → Add Files...] 或者用 INS 键将所有需要的目标文件添加到工程中。注意：多个文件可通

过 “Add File(s)”对话框快速添加。

2. 在工作空间窗口中显示的每个 （预定用于 User Boot Area 的）文件上单击右键，选择 “User Boot 
Flash”，就表示此文件用于 User Boot Area。

3. 选择 [Project → Rebuild Image]，创建 User Boot Area 的 Device Image （创建汇集所有目标文件结果的

文件）。

4. 请选择 [Project → Download Image]。

5. User Area 和 User Boot Area 的输出窗口中若显示 “Image successfully written to device”，表明写入结

束。

【注】 在下载包含 ROM 区外的数据的文件时， FDT 只执行 ROM 范围内的数据传送。忽略 ROM 范围外的数据。
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3.8 擦除闪存 ROM 的数据

1. 选择 [Device → Erase FLASH blocks...]，显示 “Erase Blocks”对话框。

2. 选择要擦除的块。（单击复选框，选择块） *

3. 单击 “Erase”按钮，开始擦除。

4. 输出窗口中若显示 “Erase complete”，表明擦除结束。

图 3.33　块擦除对话框

* 【注】擦除整个块时，单击 “Select All”按钮，选定所有有效的复选框。擦除所有非空白块时，单击 “Select Written”
按钮，选定所有相关复选框。选定父项目时，其所有子项目的状态也随之改变。复选框呈灰色时，表示其子项目只

有一部分被选定。

3.9 闪存 ROM 数据的上传

1. 选择 [Device → Upload Image...] 显示 “Upload Image”对话框。

然后

2. 选择 “Address”选项卡。

3. 输入起始和结束地址，或者起始地址和长度。

4. 单击 “Upload”按钮，开始读入。

或者

5. 选择 “Tree”选项卡。

6. 选择上传的块 （对应擦除块及／或者芯片闪存区）。

7. 单击 “Upload”按钮，开始读入。

【注】 若 FDT 在 Boot Mode 下启动，闪存数据通常已被事先擦除 （取决于芯片种类）。
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图 3.34　上传对话框 （Address）

图 3.35　上传对话框 （Tree）

【注】 在上传对话框中有和块擦除对话框一样的选择功能。即单击“Select All”按钮会选定所有的块 （芯片全部上

传），单击“Select Written”按钮会选定非空白块 （上传已被写入的区）。

当输出窗口中显示 “Upload operation complete （上传操作完成）”，并且上传的数据显示在 16 进制编辑

器中时，表明读取结束。

当用户指定 Absolute Image 时，上传的数据将被放在上传前的地址中与闪存同样大小的 Image 里。需要在

工程中添加上传的数据时，使用 Absolute Image。闪存以外的区域不能上传到 Absolute Image 中。

上传正常结束以后， FDT 会在输出窗口中自动显示上传数据的校验和。显示形式为原始校验和，例如，对
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上传范围内的字节值进行简单的 32 位加法运算。如果上传了多个闪存区，就分别显示各个区域的校验和结

果。关于其他校验和选项，请参照 “FLASH Checksum （闪存校验和）”、“File Checksum （文件校验

和）”或 “Data File Properties （数据文件属性）窗口”的 “Checksum Tab （校验和选项卡）”。

【注】 在 Scripting Mode （脚本模式）中上传后不进行校验和的自动计算或显示。如果要在该模式中计算校验和，脚本

中必须包含专用的校验和命令。

3.10 空白检查

选择 [Device → Blank Check ] 菜单选项，可对支持本功能的核心程序进行空白检查。在所有有效的芯片区

（例如：User Area 和 User Boot Area）进行空白检查。

3.11 断开与芯片的连接

选择 [Device → Disconnect] 菜单选项，或按下 [Disconnect] 工具栏按钮。

3.12 保存工作空间

选择 [File → Save Workspace] 菜单选项，可保存 FDT 的工作空间。

3.13 关闭工作空间

关闭 FDT 的工作空间，请选择 [File → Close Workspace]。对工作空间或工程进行改动时，对话框会询问

是否保存工程。需要保存工作空间时，选择 “Yes”，不保存时选择 “No”。另外，返回工作空间时，选择

“Cancel”。当被提示保存 session 时，选择 “Yes”。可通过 [Tools → Options] 对话框的工作空间选项卡，来

设定上述提示是 ON 还是 OFF。

3.14 结束 FDT
结束 FDT 时，可选择 [File → Exit]，或按下 Alt+F4 键，或选择系统菜单中的“Close”选项（系统菜单可

通过单击 FDT 标题栏左上角的图标来打开）。
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第 4 章 等待脚本 （Wait For Script）

4.1 等待脚本概要

在此模式下，包含命令脚本的文本文件可控制 FDT，并使之自动化。当设定为等待脚本模式时， FDT 作

为服务器查询文件是否存在于预定的地点。检索到该文件后， FDT 将依次执行各条命令，并可在执行结束后

选择删除或者移动脚本文件，因而 FDT 处于可以检索下一个脚本文件的状态。使用简单的文本文件，在外部

应用程序的控制下， FDT 可进行连接、写入、擦除和空白检查等操作。（不对应 FDT 以外的命令）

可选择将输出窗口的消息写入日志文件，用于以后的分析及调查。另外，可创建有关当前及以前的脚本进

程状态信息的状态文件。通过外部应用程序，此状态文件可以用来判断脚本的处理是否正常进行。

设置 FDT 等待脚本时，需要创建配置文件来指定脚本的检索路径和其他参数 （如日志的设定、状态文件

等），以及对于错误的处理方法。

4.2 等待脚本–配置文件的创建

从 [Tools] → [ Wait For Script] → [ New Configuration...] 菜单启动。

4.2.1 Script File Page （脚本文件页面）

图 4.1　[Script File] 页面

这是等待脚本配置中唯一不可缺少的页面。

· Description （说明） :
为可选的文本说明，记述谁创建了文件、为何创建、什么样的文件等等。只能被用于显示。

· Script Path （脚本路径） :
是唯一必须填写的区域。在此编辑框中，用户可指定要运行的脚本文件的地址。它可以是特定的文件

（例如：c:\Scripts\MyScript.fsf），也可以是目录和 Wild card 的组合 （例如：c:\Scripts\*.fsf）。

此编辑区右侧的 [File...] 按钮可启动对话框，用于检索用户想使用的文件。 [File...] 按钮下方的 [Wild 
card...] 按钮可启动标准的 Windows 目录选择对话框。在此对话框中选择目录后，为了方便用户，会在

路径的末尾添加 “\*.fsf”（fsf 是默认的脚本扩展名）。此区域也可手动编辑。

· Timings （时序） :
查找、访问脚本文件后，用户可通过时序来控制 FDT 查询脚本文件的频度及处理前 FDT 的等待时间。
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· Save （保存） :
用于保存 FDT 脚本配置文件 （默认扩展名：.w4f）。 FDT 会询问用户是否立即执行保存了的脚本文

件。

4.2.2 Log File Page （日志文件页面）

为可选页面。不需要日志文件时，请将此区域设为空白。可选择改写或添加于已有的文件。

　

图 4.2　[Log File] 页面

· Log File Directory （日志文件目录） :
输入创建日志文件的目录。通过使用 %U、%M、%D 和 %T 等分隔符， FDT 可将用户名、机器名、日

期或时间等详细信息添加到目录路径中。

· Log File Name （日志文件名） :
输入日志文件的名称。通过使用 %U、%M、%D 和 %T 等分隔符， FDT 可将用户名、机器名、日期或

时间等详细信息添加到文件名中。

· Save （保存） :
用于保存 FDT 脚本配置文件 （默认扩展名：.w4f）。 FDT 会询问用户是否立即执行保存的脚本。
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4.2.3 Status File Page （状态文件页面）

为可选页面。如果不需要状态文件，就将 [Enable status output to file] 复选框置为空白。关于状态文件的

内容，请参照 [4.7]。

图 4.3　[Status File] 页面

· Status File Directory （状态文件目录） :
输入创建状态文件的目录。通过使用 %U 和 %M 等分隔符， FDT 可将用户名和机器名等详细信息添加

到目录路径中。

· Status File Name （状态文件名） :
输入状态文件的名称。通过使用 %U、%M、%D 和 %T 等分隔符， FDT 可将用户名、机器名、日期或

时间等详细信息添加到文件名中。

· Save （保存） :
用于保存脚本配置文件 （默认扩展名：.w4f）。 FDT 会询问用户是否想立即执行保存了的脚本。

4.2.4 Error Handling Page （错误处理页面）

为可选页面。

图 4.4　[Error Handling] 页面
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· On Script Fail （关于脚本失败） :
Abort （中止）：发生错误时，为了终止 FDT 的脚本处理，把 [On Script Fail] 单选按钮设定为默认的

[Abort]。
Continue （继续）：允许 FDT 忽略发生的错误，继续进行脚本处理。

Run Script （执行脚本）：发生错误时，强制 FDT 执行错误处理 （Error Handling）脚本。通过手动或

使用 [browse] 按钮，能在输入框输入错误处理脚本文件。通常，失败的脚本包含 Disconnect （断开）

命令、 Alert （警告）命令及 Abort （中止）命令。

# Script processing failure handling script example 1

# Disconnect to allow reconnection

Disconnect

# Display a message to the user

Alert output|******************************************************************

Alert output|********** THE CURRENT SCRIPT PROCESSING HAS FAILED **************

Alert output|******************************************************************

Alert output|**   The script which was being processed will now be deleted.  **

Alert output|**   Please reset the board and regenerate the script to retry  **

Alert output|******************************************************************

# Delete the script file which failed

# so that FDT will wait for it to be regenerated before retrying

delete $script

# Script processing failure handling script example 2

# Disconnect to allow reconnection

Disconnect

# Display a message to the user

Alert output|******************************************************************

Alert output|********** THE CURRENT SCRIPT PROCESSING HAS FAILED **************

Alert output|******************************************************************

Alert output|**        Wait For Script Processing will now be aborted        **

Alert output|**            To retry, use ‘Tools’ , ‘Wait for Script’ ,         **

Alert output|**      ‘Run configuration...’ and select the configuration     **

Alert output|******************************************************************

# Stop script processing

Abort

· Save （保存）

用于保存 FDT 脚本配置文件 （默认扩展名：.w4f）。 FDT 会询问用户是否想立即执行保存了的脚本。

4.3 等待脚本 – 配置文件的编辑 ...
从 [Tools] → [Wait For Script] → [Edit Configuration...] 菜单启动。用户可在这里编辑配置文件的设定。
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4.4 等待脚本 – 配置文件的执行 ...
从 [Tools] → [Wait For Script] → [Run Configuration...] 菜单启动。用户可在这里浏览并选择需要的脚本配

置文件 （.w4f），然后进入等待脚本模式。

图 4.5　　脚本的执行

4.5 等待脚本 – 脚本命令

脚本文件不过是包含了 FDT 能识别的一系列命令 （一行一个）的文本文件。另外，每个命令在同一行都

有一系列相关参数。这些脚本文件带有默认的 ‘.fsf’扩展名。

脚本各行的语法是 “命令 + 空格 + 需要的参数 （用运算符 ‘|’分开）”。后接可选的附加参数，能以任

意顺序配置。

通常，以 “delete $script”命令结束脚本文件。一旦结束处理， FDT 将删除脚本，因而能防止同一脚本的

重复处理。之后 FDT 开始搜索下一个脚本文件。或者，处理结束后，用 move 命令将脚本移到备用目录里。

需要把各脚本命令分别写在文本文件不同的行。 FDT 将对应 DOS 和 UNIX 格式的行中断 （CR 或

CRLF）。脚本文件内的文件路径可包含驱动字符或网络路径 （含 IP 地址）。

4.5.1 Workspace （工作空间）

· 说明：

将指定的工作空间 （Workspace）读取到 FDT 中 （注：使用与芯片相关的命令时，必须打开有效的工

作空间及创建的工程。）。

· 参数：

<Workspace Path> 必须 工作空间的路径
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· 例如：

Workspace C:\Workspaces\3069serial\3069serial.AWS

【注】 FDT 将使用此工作空间激活的工程。现在没有从脚本改变激活工程的功能。

4.5.2 Connect （连接）

· 说明：

连接芯片。

· 参数：

注意：连接只在工程的端口设定中进行，不改变用于连接的端口。在本命令中，指定了端口后，工程若不

符合此设置，将导致失败。另外，通过事先选择 PID/BID 或者 FDM 及串行序号，可以不显示用于 USB 芯片

的 [Select Device Connection] 对话框。

<PORT> 可选 指定的端口不符合工程端口的设置

时，命令会失败。为连接 USB 
Direct、FDM、E8 及 E8Direct，必须

设定为 “USB”

<
P
O
R
T
>
为

“
U
S
B
”
时

“USB” |<USB PID>|

<USB BID>

可选

( 其中一个 )

使用 USB 进行连接时，可以不显示

Select USB Device 对话框而继续执

行

USB” |“FDM” |” SN:”

<SERIAL NUM>

使用 FDM 时， PID 应设为

“FDM”、 BID 应设为后接 FDM 串行

序号的“SN:”

“USB” |” E8” |<USB

BID>|<CONNECT

VOLTAGE>|<DISCONNECT

VOLTAGE>

使用 E8、 E8a、 E8Direct 或
E8aDirect 时，可指定芯片的 BID、

最初连接时的电压和不连接时使用的

电压

（注意：当前支持的电压值为 5.0、
3.3 或 0）

“USB” |” E8a” |<USB

BID>|<CONNECT

VOLTAGE>|<DISCONNECT

VOLTAGE>

“USB” |” E8Direct”

|<USB

BID>|<CONNECT

VOLTAGE>|<DISCONNECT

VOLTAGE>

“USB” |” E8aDirect”

|<USB

BID>|<CONNECT

VOLTAGE>|<DISCONNECT

VOLTAGE>
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· 例如：

Connect

Connect COM1

Connect USB|0x000D|0

Connect USB|FDM|SN: 93506

Connect USB|E8|0001|5.0|0.0

4.5.3 Download （下载）

· 说明：

将所选的工程 Image 下载到芯片中。

· 参数：

· 例如：

Download image|user|norebuild|verify

Download C:\files\MySrecord.mot|userboot

4.5.4 Erase （擦除）

· 说明：

将指定的闪存块从芯片上擦除 （使用 Protocol E 时没有该功能）。

· 参数：

· 例如：

Erase 0|1|4|7

Erase device

“image”
必须 （其中一个）

下载 device image

<filename> 下载指定的文件

“user”

必须 （其中一个）

下载 user image 到用户区

“userboot” 下载 user boot image 到 user boot area。也可用于下载

到用户区

“both” 下载 user image 及 user boot image （只在指定

“image”时有效）

“norebuild”
可选

即使 Image 过期，在下载前也不要进行再创建 （只在指

定“image”时有效）

“verify”
可选

下载结束后，进行读回检验 （使用 Protocol E 时没有该

功能）

<block num(s)>

必须（其中一个）

需要擦除的块的序号列表

“written” 擦除所有当前标注为 “written”的块

“device” 擦除整个芯片
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4.5.5 BlankCheck （空白检查）

· 说明：

检查芯片是否空白 （使用 Protocol E 时没有该功能）。

· 参数：

· 例如：

BlankCheck

BlankCheck userboot|stoponwritten

4.5.6 Upload （上传）

· 说明：

从芯片上传数据 （使用 Protocol E 时没有该功能）。

· 参数：

· 例如：

upload none|0|0x6000

upload c:\upload\uploadtest.mot|0x100|0x200|userboot|noabsolute

4.5.7 Checksum （校验和）

· 说明：

在芯片上执行校验和 （使用 Protocol E 时没有该功能）。

· 参数：

· 例如：

Checksum device

4.5.8 Disconnect （断开）

· 说明：

断开与芯片的连接。在 FDT 未连接时，也可发出 Disconnect 命令，便于在连接前确认芯片是否处于非

连接状态。（注：对于 Protocol D 或基于 COM 的连接，该项无效）

“userboot” 可选 指示 FDT 检查闪存的用户引导区 （支持时）

“stoponwritten” 可选 芯片非空白时，终止脚本处理

“stoponblank” 可选 芯片空白时，终止脚本处理

<filename> 必须 写入了上传内容的文件——需要时创建或改写。不需要

时，指定 “none”

<start address> 必须 开始上传的 16 进制数的起始地址

<length> 必须 上传的字节数 （16 进制数）

“noabsolute” 可选 不要上传 Absolute image

“userboot” 可选 从 user boot area 或数据区上传 （支持时）

“device” 必须 进行芯片的校验和
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· 参数：

· 例如：

Disconnect

Disconnect reset

4.5.9 RebuildImage （再创建映像）

· 说明：

从工程目标文件中再创建指定的 Image （映像）。

· 参数：

· 例如：

RebuildImage user

RebuildImage both

4.5.10 #Comment （注释）

· 说明：

将 “#”置于行首，后接注释的内容。

· 参数：

· 例如：

# 此处为注释行。

4.5.11 Alert （警告）

· 说明：

通知用户有异常发生。

· 参数：

· 例如：

Alert output|Please make sure the board is connected

“reset” 可选 指示 FDT 进行复位 （在进行连接时）

“user”

其中一个

再创建 user image

“userboot” 再创建 User boot image

“both” 再创建 user image 及 user boot image

NONE — —

“beep” 必须

（其中一个）

FDT 发出警告声

“output” FDT 在激活的工程选项卡中输出信息
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4.5.12 Pause （暂停）

· 说明：

此命令使脚本文件的执行在指定的微秒时间段处于中断状态。

· 参数：

· 例如：

Pause 2000

4.5.13 Delete （删除）

· 说明：

删除脚本文件。注：删除前， FDT 的脚本处理只进行到此行。

· 参数：

· 例如：

Delete $script

4.5.14 Move \ Copy （移动 \ 复制）

· 说明：

移动或者复制脚本文件。注意：FDT 的脚本处理只进行到此行。

· 参数：

· 例如：

Move $script |\\server\networkfiles\done.txt

Copy $script|C:\backups\

4.5.15 Abort （中止）

· 说明：

终止脚本的处理。注意：此命令主要用于错误处理脚本 （Error processing script）。

· 参数：

· 例如：

Abort

<time> 必须 中断的微秒数

“$script” 必须 删除脚本文件

“$script” 必须 对脚本文件进行复制 / 移动 / 重命名

<filename>

<directory>

必须 源文件被复制 / 移动 / 重命名后的文件或目录

NONE — —
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4.5.16 Lock （锁定）

· 说明：

锁定芯片上指定的闪存块或设置芯片的主锁定位 （在不支持擦除块锁定的芯片中没有该功能）。

注意：在锁定单个的块 （参照 [4.5.17]）之前，必须先解锁芯片的主锁定位 （通过 “Unlock 
device”）。

· 参数：

· 例如：

lock 0|1|4|7

lock device

4.5.17 Unlock （锁定）

· 说明：

解除芯片上指定闪存块的锁定，或将芯片的主锁定位设置为无效 （在不支持擦除块锁定的芯片中没有

该功能）。

注意：在解锁单个的块 （参照 [4.5.17]）之前，必须先解锁芯片的主锁定位 （通过 “Unlock 
device”）。

· 参数：

· 例如：

Unlock device

Unlock 0|1|4|7

4.5.18 Exit （退出）

· 说明：

停止脚本的处理，并退出 FDT。

· 参数：

· 例如：

Exit

<block num(s)>
必须

（其中一个）

需要锁定的块的序号列表

“written” 锁定所有当前标注为 “written”的块

“device” 设置主芯片锁定位

<block num(s)>
必须

（其中一个）

需要解锁的块的序号列表

“written” 对所有当前标注为 “written”的块进行解锁

“device” 将主芯片锁定位设置为无效

NONE — —
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4.6 等待脚本 – 脚本文件的示例

FDT 的脚本文件如下所示 , 用于强调有效的命令，并对如何使用给于说明。

# EXAMPLE SCRIPT FILE

# open this workspace and associated project

# (for which the flash project wizard must have completed successfully)

workspace C:\Workspaces\2215usbdirect\2215UsbDirect.AWS

#  Ensure that comms is closed (in case previous attempt failed and didn’ t disconnect)
disconnect

#  connect over the USB to the device with this Product ID + Bus ID

connect USB|0x000D|0

#  do an initial blank check

blankcheck

# download the file "C:\2215uAuto.mot" and verify that programming was OK

# (script processing will stop if this verify fails)

download C:\2215uAuto.mot|user|verify

# upload data from address 0 to address 0x1000 and save to file “upload.mot”
upload c:\UPLOADS\upload.mot|0x0|0x1000

# erase all blocks

erase device

# do a blank check (and stop if the user area is dirty)

blankcheck stoponwritten

# rebuild the user area image

RebuildImage user

# download the user image

download image|user

# get the checksum for the user area of the device

checksum device

# pause for 100 milliseconds

pause 100

# disconnect from the device

disconnect

# Display message in output window

alert output|This text will be displayed in the output window and the log file

# delete this script

# (will stop FDT from running through the file again)

delete $script
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4.7 脚本 – 状态文件格式

FDT 在等待脚本模式时，远程用户可能希望了解当前应用程序处于何种状态。这可以通过创建一个外部用

户能读取的状态文件来实现，此状态文件为 FDT 执行动作时写入的文件。文件的选项如下所示：

状态文件默认不能写入。选定 [Enable] 复选框，打开编辑用的目录和文件名，可指定创建状态文件的地

址。

FDT 开始 Wait For File session （状态写入有效）时，首先检查指定的文件是否存在。在未找到时，将创建

此文件， FDT 继续运行。找到文件时，打开文件并进行检查。 CurrentStatus 为空白时 （表明以前的 session 正

常结束，并且没有其他人在使用此文件）， FDT 继续运行。当 CurrentStatus 中存在项目 （例如

“Processing”）时， FDT 会通过消息框警告用户：以前的 session 可能已经破坏，或者，另一个 FDT 的副本正

在运行，而且也在使用此文件。此时，用户可选择继续运行并改写数据，也可以选择终止处理。

[FDT Script Status v1.0] ← 配置文件的版本。

CurrentScript = ← 执行中的当前脚本地址，或者在等待状态使用的检索路径。

UserID= ← 使用 FDT 的副本（多个 FDT 中的一个）向此文件进行写操作的用户的

名称。

Machine= ← 使用 FDT 副本（多个 FDT 中的一个）的机器名。

LastUpdate= ← 此文件最后更新的时间和日期。

CurrentStatus = ← FDT 当前的状态。可以为 “waiting”（FDT 在检索脚本时），

“processing”（FDT 发现脚本后使用时），“error processing”（脚

本出错时），或者“waiting for user input”（对话框等待用户的回应

时）等状态。 FDT 正常退出等待文件模式（Wait For File Mode）时，

此项目为空白。

PreviousScript= ← 以前执行的脚本地址。

PreviousState= ← 以前执行的脚本结果。可以为“COMPLETED”或者 “FAILED”。

JobNo= ← 执行成功结束的次数。次数变为 32,768 时归 0。
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第 5 章 存取权限 （Access Rights）

5.1 存取权限的概要

在使用 FDT 写入芯片时 （特别是多用户时），为防止设置被意外更改，可利用存取权限的功能，创建用

户名和密码，使不同用户以不同的级别进行访问。通常，存取权限有三个级别。

Administrator 级别，允许用户创建和改变用户帐户。

Supervisor 级别，允许工程 （Project）的创建和编辑。

SIM User 级别，允许 Simple Interface Mode 用户仅有从 Simple Interface Mode 写入 device image 的权力。

在 SIM User 使用 FDT 前， Supervisor 需要创建工程。

5.2 设置存取权限有效

在 FDT 中提供有默认的上述指定的用户帐户，但没有设定密码。通过设定内部 Administrator 帐户的密码

可使存取权限有效，在这之前都无需登录，而直接通过 [Tools] → [Access Rights] → [Administration...] 菜单就

可以进入 FDT。首次运行 FDT 时，会提示用户输入 Administrator 帐户的密码。

5.3 存取权限管理

通过 [Tools] → [Access Rights] → [Administration...] 菜单来实现。

图 5.1　[User Admin] 对话框

5.3.1 Disable All （禁止所有帐户）

此按钮使所有的用户帐户无效，并关闭存取权限密码保护。
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5.3.2 Modify User （更改用户）

此按钮用于启动 [Modify User] 对话框，可更改所选的用户设置。

图 5.2　[Modify User] 对话框

有效的访问选项如下所示：

5.3.3 Add User （添加用户）

此按钮可创建新用户帐户。 FDT 会提示输入用户名和密码，然后启动 [Modify User] 对话框。

5.3.4 Delete User （删除用户）

此按钮可删除用户帐户。

5.3.5 Reset Pwd （重设密码）

此按钮可设定所选用户的密码。

5.3.6 Close （关闭）

此按钮用于关闭 [User Admin] 对话框。

AccessRights:Admin： 可管理用户帐户及密码。

FDT:Project Edit： 可编辑 FDT 工程。使 Simple Interface Mode 中的 [Back to Project]
按钮有效。

SimpleInterface:Exit： 可终止 FDT。使 Simple Interface Mode 中的 [Exit] 按钮有效。

SimpleInterface:Download File： 用户可选择下载的文件。使 Simple Interface Mode 中的 [Download 
File] 有效。

SimpleInterface:Download Project Image： 可下载一个或多个工程 Image。使 Simple Interface Mode 中的

[Download Project Image] 有效。
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第 6 章 用户界面的配置 （Configuring the User Interface）

FDT 用户界面旨在快速连接频繁使用的操作，并将相关操作合理地进行分组。但是，当用户处于一个较

长的 session （会话）中时，可能更希望能够重新配置用户界面的项目。 FDT 可帮助用户进行自定义。本章将

说明用户界面的配置和显示方式的自定义。

6.1 窗口的配置

6.1.1 Minimizing windows （最小化窗口）

在打开的编辑窗口中结束某个操作时，用户可能希望此操作以后能再次以当前的状态显示，此时可将该窗

口缩小成一个图标，这就称为窗口的最小化。可单击窗口的 “Minimize”按钮将窗口最小化。

窗口被最小化后，会以图标形式显示在编辑窗口的底部。

【注】 当另一个打开的画面覆盖此窗口的底部时，有可能看不到该图标。

要将图标还原到窗口时，可以双击图标，也可单击图标后，在弹出的菜单中选择 [Restore]，或者从菜单

栏 [Window] 的下拉菜单中选择所需窗口。

6.1.2 Tiling windows （平铺窗口）

屏幕中可能会有多个窗口同时打开的情况。若使用 “Tile Windows”选项，可以使所有窗口平铺开来，而

不彼此覆盖。可通过 [Window → Tile Horizontally] 或者 [Window → Tile Vertically] 菜单选项进行此操作。

【注】 选择此选项后，当前打开的所有窗口都被设置为平铺格式，而最小化为图标的窗口不受影响。

6.1.3 Cascading windows （层叠窗口）

使用 “Tile Windows 选项”，可将打开的窗口设置为层叠格式。可通过 [Window → Cascade] 菜单选项进

行此操作。

6.2 查找当前打开的窗口

当在 FDT 应用程序中打开多个窗口时，窗口会很容易彼此覆盖。

6.2.1 Locating a specific window （查找特定的窗口）

查找被覆盖的窗口有两种方法。

1. 选择特定的窗口时，点击 [Window] 菜单，在最下方的列表 （打开的窗口列表）中，单击需要的窗

口。在该列表中，当前选择的窗口旁边会有一个选定标记。

选择的窗口将显示在最前面。最小化此窗口时，窗口复原为图标。

2. 单击编辑窗口底部含有文件名的选项卡，也可选择特定的窗口。窗口未最小化时，选择的窗口会显示

在最前面。最小化时，图标会显示在最前面。

6.3  设置工具栏为有效／无效

用户可选择将工具栏设置为有效 / 无效。默认状态下，工具栏显示在 FDT 应用程序窗口的顶部。不希望

显示时，选择当前的所有工具栏，并设置为不显示。

使用 [Tools → Customise] 菜单选项，或右键点击工具栏区，可以设置工具栏的有效 / 无效。
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6.4 设置工作空间窗口为有效／无效

用户可选择将工作空间 （Workspace）窗口设置为有效 / 无效。默认状态下，会显示工作空间。不希望显

示时，选择 [View → Workspace] 菜单选项。

若选择 Disable 选项，可将工作空间设置为无效并从 FDT 应用程序窗口中删除。希望再次显示工作空间

时，要再次选择 [View → Workspace] 菜单选项。工作空间将被设置为有效并添加到 FDT 应用程序窗口中，此

时菜单选项处于被选择状态。

6.5 设置输出窗口为有效／无效

用户可选择将输出窗口设置为有效／无效。默认状态下，会显示输出窗口。不希望显示输出窗口时，选择

[View → Output] 菜单选项。

若选择 Disable 选项，可将输出窗口设置为无效并从 FDT 应用程序窗口中删除。希望再次显示输出窗口

时，要再次选择 [View → Output] 菜单选项。输出窗口将被设置为有效并添加到 FDT 应用程序窗口中，此时菜

单选项处于被选择状态。

6.6 自定义工具栏

可根据用户的喜好自定义用户栏中显示的按钮的种类和排列。改变显示时，选择 [Tools → Customise...] 菜
单选项。默认状态下，会显示 Editor、 Search、 FDT、 QzROM 和 S-Record 的工具栏。请注意 S-Record 工具栏

选项只在打开数据文件时有效。“自定义”对话框如下所示：

图 6.1　FDT 的自定义

“自定义”对话框中有很多选项卡。有关各个选项卡，在 ［第 8 章］中将作详细说明。
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6.6.1 Toolbars Tab （工具栏选项卡）

在工具栏选项卡中，用户可选择希望显示的工具栏。默认状态下，只显示 Editor、 Search 和 FDT 的工具

栏。

单击 “New...”按钮，可打开 “Toolbar Name”对话框。在此对话框中，用户可制作新的工具栏。输入新

名称、单击 “OK”后，新名称将被添加到 “Toolbars”列表中，界面上显示空的工具栏。

通过命令选项卡，用户可为新工具栏选择和添加按钮。用鼠标拖动新工具栏，可将新工具栏置于 GUI 上
任何地方。

“Toolbars”列表中，选择用户创建的工具栏时，“Reset”按钮变为 “Delete”按钮。单击此按钮，可将新

工具栏从列表和 GUI 中删除。

单击 “Reset”按钮，可将选择的工具栏还原为默认设置。
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第 7 章 菜单 （Menus）

本文档遵循标准的 Microsoft 菜单命名协议。

图 7.1　FDT 菜单

7.1 File （文件）菜单

“File”菜单用于 （访问数据文件的）程序方面。

7.1.1 Close （关闭）

关闭编辑窗口中当前激活的文件。

7.1.2 New Workspace （新的工作空间）

打开 “New Workspace”对话框。在此对话框中，可指定新工作空间的名字和地址，并创建新的工作空间

目录。

7.1.3 Open Workspace （打开工作空间） ...
打开 “Open”对话框。在此对话框中，可打开已有的 FDT 工作空间文件 （.aws）。

7.1.4 Save Workspace （保存工作空间）

保存当前激活的工作空间的详细信息。

7.1.5 Close Workspace （关闭工作空间）

关闭当前激活的工作空间。
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7.1.6 Open a Data File （打开数据文件） ...
打开 “Open a Data File”对话框。在此对话框中，可打开已有的文件。这些文件可以为 S-Record 文件

（.rec、 .mot、 .a20、 .a37、 .s2）、 Device Image （.fpr、 .ddi）或者 2 进制文件 （.bin、 .cde）。

7.1.7 Save （保存）

保存当前激活的文件。

7.1.8 Save As （另存为） ...
打开 “Save As”对话框。在此对话框中，可保存和命名当前打开的文件。

7.1.9 Recent Workspaces （最近打开的工作空间） ...
可通过列表显示最近在 FDT 中打开过的工作空间，选择其中一个后，可打开该工作空间。

7.1.10 Recent Data Files （最近打开的数据文件） ...
可通过列表显示最近在 16 进制编辑器中打开过的文件，选择其中一个后，可打开该文件。

7.1.11 Exit （退出）

关闭并退出 FDT 应用程序。

7.2 Edit （编辑）菜单

“Edit”菜单用于 （在编辑窗口中访问或更改数据的）程序方面。

7.2.1 Undo （撤消）

撤销上一步编辑操作，还原数据。

7.2.2 Redo （重复）

取消前面的撤销操作。

7.2.3 Cut （剪切）

将反显的块的内容从窗口中删除，并将该内容放在剪贴板中 （使用标准的 Windows® 方式）。此选项只在

块反显时有效。

7.2.4 Copy （复制）

将反显的块的内容复制到剪贴板中 （使用标准的 Windows® 方式）。此选项只在块反显时有效。

7.2.5 Paste （粘贴）

将 Windows® 剪贴板中的内容复制到子窗口中当前的光标位置。

7.2.6 Select All （全选）

选择编辑窗口中当前文件的所有信息。

7.2.7 Find （查找） ...
打开 “Find”对话框。在此对话框中，可输入 16 进制数或 ASCII 数据。编辑窗口中当前文件的检索范围

限定为被选择的区域。发现符合检索条件的数据时，将更新编辑窗口，显示找到的数据。



第 7 章   菜单 （Menus）

Rev.2.00  2008.04.24  Page 62 of 115
RCJ10J0052-0200

7.2.8 Find In Files （在文件中查找） ...
打开对话框，检索当前文件以外的文件中的数据。

7.2.9 Replace （替换） ...
打开 “Replace”对话框。在此对话框中，可输入想要检索的 16 进制数或 ASCII 数据。另外，也能以相同

的格式输入置换的数据。编辑窗口中当前文件的检索范围限定为被选择的区域。发现符合检索条件的数据时，

将更新编辑窗口，显示找到的数据。按下 “Replace”按钮，替换数据。

7.3 View （显示）菜单

“View （V）”菜单用于显示或删除 FDT GUI 的功能，如工作空间窗口、输出窗口等。

7.3.1 Workspace （工作空间）

显示工作空间窗口。

7.3.2 Output （输出）

显示输出窗口。

7.4 Project （工程）菜单

“Project”菜单提供对工作空间中的工程进行高级管理的功能。

7.4.1 Set Current Project （设定当前工程）

在工作空间的多个工程中选择当前的工程。

7.4.2 Insert Project （插入工程） ...
创建新的工程并添加到工作空间。

7.4.3 Add Files （添加文件） ...
打开 “Open”对话框。在此对话框中，可向工程添加数据文件。

7.4.4 Remove Files （删除文件） ...
从工程中删除选择的文件。
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7.4.5 File Extensions （文件扩展名） ...
选择 FDT 能识别的文件扩展名，并设定如何处理这些扩展名。

图 7.2　“File Extensions”对话框

· File Extention Add （添加文件扩展名） ...
选择 “Add...”时， FDT 可处理带有新扩展名的文件。

图 7.3　“Add File Extention”对话框
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· File Extention Modify （更改文件扩展名）…

选择 “Modify...”按钮时，可选择 FDT 处理带有此扩展名的文件的方法。

图 7.4　“Modify File Extention”对话框

7.4.6 Rebuild Image （再创建映像）

通过 Image 的再创建，合并工程中包含的所有文件。默认的 ROM 区为 User Area，某些芯片中还有 User 
Boot Area 或者 Data Area。组件文件重叠时， FDT 会发出警告。当希望写入的数据是由不同的组件文件构成时

（特别是来自不同文件的数据将存在于同一擦除块区域时）， Image 的创建是有利的。这是因为在使用自动保

护时，分别下载各个组件文件，可能会导致芯片在进行第二次下载前将块擦除掉。

7.4.7 Download Image （下载映像）

下载用“Rebuild Image”创建的 Image。 Image 过期时（即源文件已变更）， FDT 会提示在下载前进行再

创建。

7.4.8 Field Programming （现场写入）

有关详细情况，请参照 [ 第 11 章 ]。

7.5 Tools （工具） 菜单

“Tools”菜单中有与各个工程、目标芯片无关的 FDT 附加功能。

7.5.1 Administration （管理） ...
对应不同的范畴，显示用户可以利用的工具的对话框。

7.5.2 Customise （自定义） ...
自定义 FDT。详细情况请参照 [ 第 8 章、第 9 章 ]。

Publish… 创建传送给其他 FDT 用户的 （包含所有核心程序和数据文件的） .fpf4
文件。

Run Published File… 解开 .fpf4 文件，在 Simple Interface Mode 下使用。
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7.5.3 Options （选项） ...
可访问附加功能，将来会对其中的某些功能进行强化。工作空间选项卡是最有用的选项卡。通过该选项

卡，用户可指定启动时是否打开上次使用过的工作空间，以及在保存工作空间或 session 前是否进行提示，还

可指定新工作空间的默认目录。

7.5.4 Format Views （格式化显示） ...
改变不同窗口的外观。

7.5.5 Simple Interface （简化界面） ...
简化 FDT 的外观。详细情况请参照 [ 第 9 章 ]。

7.5.6 Wait for Script （等待脚本）

可创建、编辑或执行等待脚本的配置。详细情况请参照 [ 第 4 章 ]。

7.5.7 Access Rrights （存取权限）

· Access Rights – Login （存取权限 – 登录） ...
可切换登录到 FDT 的用户。通过快捷键 Ctrl + Shift + U 也可启动登录对话框。详细情况请参照

[ 第 5 章 ]。

· Access Rights – Change Password （存取权限 – 变更密码） ...
当前登录的用户可变更自己的密码。详细情况请参照 [ 第 5 章 ]。

· Access Rights – Administration （存取权限 – 管理） ...
可设定用户名及密码，从而限制对 FDT 的访问。详细情况请参照 [ 第 5 章 ]。

7.5.8 Unique Code Programming （识别码的写入） ...
可对 FDT 内部的识别码写入功能进行设定和控制。详细请参照 [ 第 16 章 ]。

7.6 Window （窗口）菜单

“Window”菜单用于改变 FDT GUI 中当前打开的窗口的显示方式。在下列选项之后附加有编辑窗口中显

示的文件的名称，并可通过文件名来识别这些文件。当前激活的文件有选定标记。

7.6.1 Cascade （层叠）

可将多个窗口错开显示，使每个文件都能看到。

7.6.2 Tile Horizontally （横向平铺）

可使窗口以最大水平宽度显示。

7.6.3 Tile Vertically （纵向平铺）

可使窗口以最大垂直高度显示。

7.6.4 Arrange Icons （排列图标）

可在屏幕底部排列文件图标。

7.6.5 Close All （全部关闭）

用于关闭编辑窗口中打开的文件。
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7.6.6 “File name”（“文件名”）

当文件名处于选定状态时，此选项有效。

7.7 Device （芯片）菜单

“Device”菜单具有控制功能，可以和目标芯片相互作用。

7.7.1 Connect to Device （连接到芯片）

GUI 与芯片未连接时，通过这里进行连接。输出窗口中显示进度信息。

7.7.2 Disconnect （断开连接）

GUI 与芯片连接时，通过这里切断。输出窗口中显示进度信息。

7.7.3 Erase FLASH blocks （擦除闪存块）

用于打开 “Erase”对话框。

在此对话框中，用户可指定要擦除的块。 Written 栏显示在块中是否有数据。

启动此操作时，在列表中选择想要擦除的块名，然后单击 “Erase”按钮。

7.7.4 Blank check （空白检查）

用于在闪存芯片中进行空白检查，并将结果显示在输出窗口。

7.7.5 Upload Image （上传映像）

用于打开 “Upload Image”对话框。在此对话框中，可从目标芯片上传数据。是用来访问闪存的功能。数

据显示在编辑窗口中。

7.7.6 Download Active File （下载激活的文件）

将当前激活的文件下载到目标闪存中。

7.7.7 FLASH Checksum （闪存校验和）

用于对闪存芯片进行校验和运算，结果显示在输出窗口。这是在闪存范围内，对字节值进行了 32 位加法

运算的 EPROM 校验和。该校验和将和空白区的 FF 数据一起被填入下一个 EPROM 的大小 （例如：64Kb、
128Kb 等）中。

7.7.8 Go From Address （执行的起始地址） ...
用于启动对话框，用户可通过此对话框选择代码执行的起始地址。因为可以选择间接地址模式，所以参照

地址为代码执行的起始地址本身。

7.7.9 Run （运行）

用于将芯片置为用户模式，必要时，提供电源以检测写入的芯片代码。在此模式下，无法使用其他的 FDT
功能。再次单击该选项时，可取消该模式。（注意：在完成该操作之前， FDT 可能需要询问用户模式中引脚和

电源的设定）

7.7.10 Block Locking （块的锁定） ...
用于启动锁定设置对话框 （仅限于支持该功能的芯片），用户可通过此对话框设置工程中块的锁定状态。

7.7.11 Cancel Operation （取消操作）



第 7 章   菜单 （Menus）

Rev.2.00  2008.04.24  Page 67 of 115
RCJ10J0052-0200

取消当前的闪存操作。

7.7.12 Configure Flash Project （配置闪存工程）

在芯片未配置时，显示 “Flash Properties”对话框，或者启动 Project Wizard。

7.8 Help （帮助）菜单

“Help”菜单用于访问关于 FDT 操作方法的附加信息。

7.8.1 Help Topics （帮助主题）

启动 FDT 的帮助系统。打开 FDT 的 “Help Topics”对话框，可通过多种方式访问用户所需要的 FDT 帮

助信息。

7.8.2 Technical Support （技术支持）

用户可报告 FDT 中发生的问题，也可通过网站查看最新升级信息。

7.8.3 About （关于） ...
打开 “About FLash Development Toolkit”对话框，可访问关于 FDT 的附加信息。

· FDT 的版本

· 著作权信息
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第 8 章 窗口 （Windows）

本章说明各个子窗口的种类和各自支持的功能，以及相关弹出式菜单中的有效选项。

FDT 有工作空间窗口、编辑窗口、输出窗口共三个主窗口。

大多数窗口有本地弹出式菜单，能够轻松访问经常使用的功能。在窗口中单击鼠标右键，或按

SHIFT+F10 键，可打开弹出式菜单，选择需要的选项。

窗口也可从一些主菜单选项中打开。

8.1 Workspace （工作空间）窗口

工作空间窗口显示工作空间中各项目的详细信息，包括工作空间名、工作空间的工程以及各工程的 Device 
Image 文件和目标文件。

8.1.1 Workspace （工作空间）

工作空间是窗口中的第一个项目。下面的例子为 “Industrial Controller”工作空间。

图 8.1　工作空间窗口

在工作空间窗口的弹出式菜单中单击选项，可打开对应该选项的窗口。

工作空间窗口的弹出式菜单有以下选项。

· Insert Project （插入工程）…

通过该选项，能够向工作空间添加工程。

· Allow docking （允许停靠）…

通过该选项，可选择窗口是停靠 （Dock）还是浮动在主窗口的周围。

· Hide （隐藏）

选择 “Hide”，可隐藏工作空间窗口。选择 [View → Workspace]，可再次显示工作空间窗口。

· Properties （属性）

显示包含文件路径的工作空间信息。
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图 8.2　工作空间属性

8.1.2 Project （工程）

工程是项目层级的第二个，位于工作空间下方。在下面的例子中，工作空间被称为 “Industrial 
Controller”，有两个工程。一个称为 “Industrial Controller”，另一个称为 “User Mode Reprogramming”。

图 8.3　工作空间工程

除了工作空间的 “Allow Docking”、“Hide”选项之外，工程的弹出式菜单还有以下选项。

· Add Files （添加文件） ...
打开 “Open”对话框。在这里，用户可将数据文件添加到工程中。

· Remove Files （删除文件） ...
打开对话框，选择要删除的文件。

· Add Folder （添加文件夹） ...
把文件夹添加到工程中。
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· Allow Docking （允许停靠）

请参照 [8.1.1]。

· Hide （隐藏）

请参照 [8.1.1]。

· Properties （属性）

显示工程属性对话框。请注意，这与 “Flash Properties”对话框 （通过选择 FDT 工具栏或芯片菜单中

的 “Configure Flash Project”选项，可打开此对话框）不同。

· Set as current Project （设定为当前工程）

把反显的工程设定为当前激活的工程。如果反显的工程已经处于激活状态，那么本选项无效。

· Remove Project （删除工程）

把反显的工程从工作空间中删除。如果反显的工程已经处于激活状态，那么本选项无效。

· Unload Project （卸载工程）

从工作空间中卸载反显的工程。如果反显的工程已经处于激活状态，那么本选项无效。请注意，卸载

工程时，最后一次保存后工程的变更不会被保存 （FDT 在卸载前不会提示用户对变更进行保存）。

· Add Files From Kernel Dir （从核心程序目录中添加文件） ...
用户可从当前的核心程序目录中选择文件，并将这些文件添加到当前工程。

8.1.3 Device Image – Folder （芯片映像 – 文件夹）

该文件夹保存了工程的 device image （芯片映像）。 Device image 的名字与工程名相同，但后接扩展名

.ddi。

图 8.4　Device Image 文件夹

除了工作空间的 “Allow Docking”、“ Hide”选项之外， Device Image 子文件夹的弹出式菜单还有以下选

项。

· Remove Folder
删除文件夹。

· Rename Folder
为文件夹重命名。
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8.2 芯片文件

芯片文件是包含写入芯片闪存的数据的选项。

图 8.5　芯片文件

芯片文件的弹出式菜单有以下选项。

8.2.1 Open “filename”（打开“文件名”）

打开选中的文件。

8.2.2 Add Files （添加文件） ...
将附加文件添加到工程中。

8.2.3 Remove Files （删除文件） ...
将文件从工程中删除。

8.2.4 Allow Docking （允许停靠）

使工作空间窗口停靠 （Dock）或浮动。

8.2.5  Hide （隐藏）

隐藏工作空间窗口。

8.2.6 Properties （属性） ...
打开芯片文件属性的对话框。
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8.2.7 Display Block usage （显示块的用法） ...
打开 “S-Record Properties”对话框，显示 Block Usage 选项卡。

8.2.8 Exclude “filename”（排除“文件名”） 
当文件被排除后，选择 “Rebuild Image”时，排除的文件将不用于 Image 的创建。用鼠标右键单击被排除

的文件时，可再次切换到 “Include ‘file name’”。

8.2.9 User Boot Flash （用户引导闪存）

选中该选项时，被选择的文件定为 User Boot Area 专用。如果不选中，将默认为用于 User Area。该选项仅

在目标芯片支持 User Boot Area 时有效。

8.2.10 Download File to [User Area] / [User Boot Flash] （下载文件到 [ 用户区 ] / [ 用户

引导闪存 ]）
把选中的文件下载到芯片的闪存中。注意：所用的闪存区决定于文件是否被定为 “User Boot Flash”文

件。

8.2.11 File Checksum （文件校验和）

文件校验和使用核心程序 （EPROM 形式）的算法，返回文件的校验和及原始校验和。原始校验和是在闪

存范围内对每字节值进行简单的 32 位加法运算。计算校验和前，把 EPROM 形式的校验和数据和空白区的 FF
数据一起填入下一个 EPROM 的大小 （例如：64Kb、 128Kb）中。结果显示在输出窗口。示例如下：

File Checksum: 0x007F8000 (EPROM style), 

Raw Checksum: 0x00000000 (over address range 0x00000000 – 0x00017FFF)

· 计算方法

例：芯片的 ROM 大小为 96kB

1. “File Checksum”是 128kB 的和值 （96kB 以后按 0xFF 计算）

2. “Raw Checksum”是 96kB 的和值 （无数据区按 0xFF 计算）

8.2.12 Compare File → Device Checksum （比较文件 → 芯片校验和）

通过此选项，用户可将选中文件的校验和与芯片的校验和进行比较。在输出窗口显示文件及芯片的校验

和。用户能够由此确认双方的结果是否相同。示例如下：

Calculating device checksum

FLASH Checksum: 0x007F8000 (User Area) 

File Checksum:  0x007F8000 (EPROM style), 

Raw Checksum:  0x00000000 (over address range 0x00000000 – 0x00017FFF)

· 计算方法

请参照 [8.2.11]( “FLASH Checksum”的计算方法与” File Checksum”相同 )

8.2.13 Compare File → Device （Complete Device）（比较文件 → 芯片（整个芯片））

在此模式下，将比较芯片闪存中的数据 （从芯片的起始地址开始）和文件中对应的数据。检查完整个芯

片或者发现差异的时候，就停止处理。因为文件未覆盖的区会被视为 0XFF，所以需要正确验证芯片内对应的

空白区。
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8.2.14 Compare File → Device （File Data Only）（比较文件 → 芯片（仅文件数据））

在此模式下，将比较文件中的数据和芯片中对应的数据。此操作与写入后的读回验证处理相同。不检查文

件未覆盖的区。因为没有必要上传整个闪存，所以通常此操作可以更快地进行，但相对来说，处理不会太彻

底。 

8.3 Workspace Properties （工作空间属性）

从工作空间的弹出式菜单 “Properties”中调用。“Workspace Properties”对话框显示以下信息。

· 工作空间名

· 文件名和路径

· 最后保存工作空间的时间和日期

图 8.6　工作空间属性

8.4 Project Properties （工程属性）

从工程的弹出式菜单 “Properties”中调用。“Properties”对话框显示以下信息。

· 工程名

· 工程文件的地址和文件名

· 最后修改日期和时间

图 8.7　工程属性
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8.5 Configure Flash Project (Flash Properties) （配置闪存工程（闪存属性））

可从 “Configure Flash Project”工具栏按钮或芯片菜单打开 “Configure Flash Project”对话框。默认状态

下，该选项停靠 （Dock）在 FDT 窗口的底部，也可被拖到其他地方停靠，或者设置为浮动状态。为了防止无

意停靠，请在拖动过程中按住 Ctrl 键。

8.5.1 Kernel Tab （核心程序选项卡）

该选项卡显示核心程序路径 (Kernel Path)、频率 (frequency)、协议 (protocol)、时钟倍频以及时钟模式

(clock mode)。在不连接时双击这些项目，可打开画面上的 Project Wizard。

图 8.8　核心程序属性

· Kernel Path
显示核心程序路径。

· Frequency
显示输入时钟，并指明该时钟在目标外部还是内部。

· Protocol

显示通信协议的种类。请参照 [3.2.4]。
Protocol B：0.35μm 芯片

Protocol C：0.18μm 芯片

Protocol D：R8C、 M16C、 M16C / Tiny、 M32C 或 740 芯片

· CKM

显示系统时钟 （主时钟）对输入时钟的倍频。

· CKP
显示外围时钟对输入时钟的倍频。

· Clock Mode
显示时钟模式。
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8.5.2 Communications Tab （通信选项卡）

该选项卡显示默认波特率和当前波特率以及当前的端口。另外，在不连接时，用户可在这里改变端口和波

特率。

图 8.9　通信属性

· Port （端口）

该下拉列表显示被支持的 COM 端口 （可用于连接芯片）。此列表还包括 USB 端口选项。

· Baud Rate （波特率）

显示当前选择的波特率。通过双击启动 Project Wizard 后，可对该项目进行编辑。

· Default Baud Rate （默认的波特率）

显示默认的波特率。

· Use Default Baud （使用默认的波特率）

选定此选项时，将使用默认的波特率。（仅在使用 Renesas Evaluation Board 或 Evaluation Development 
Kit 时设定此选项。）

· FDM Pins / E8Direct Pins （FDM 引脚／ E8Direct 引脚）

显示 （通过复位操作进行连接和断开时的）控制模式引脚的方向和状态。
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8.5.3 Device Tab （芯片选项卡）

该选项卡显示芯片的相关信息。在这里，用户可选择 BOOT Mode / USER Program Mode 和 “Direct 
Connection”接口。另外，可指明核心程序是否在目标芯片中。

图 8.10　芯片属性

· Device （芯片）

显示当前芯片的名称。双击启动 Project Wizard 后，能对该项目进行编辑。

· RAM Size, FLASH Size, FLASH Start （RAM 容量、闪存容量、闪存开始）

这些项目只能用于显示，不能编辑。

· Connection （连接）

BOOT Mode：这种连接方式指定板上写入 BOOT 模式顺序的初始化。因此，整个闪存将被擦除，并且

会载入核心程序。

USER (Program) Mode ：这种连接方式指定板上写入 USER Program 模式顺序的初始化 （通过以前装入

的用于闪存写入的用户程序）。

· Interface （接口）

在目标和主机直接连接时，应将连接接口选择为 “Direct Connection”。

双击启动 Project Wizard 后，能对该项目进行编辑。

· Kernel Resident （核心程序驻留）

可指明，在和 FDT 连接前，主核心程序已经存在，并且正运行于目标芯片上。双击启动 Project Wizard
（工程向导）后，能对该项目进行编辑。

· Available RAM, Free RAM （可使用的 RAM、空闲 RAM）

这些项目只能用于显示，不能编辑。

· Buffer Size （缓冲器容量）

显示写入闪存的大小。

· Device ID （芯片 ID）

在 Protocol B、 C 或 D 中不能使用。
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8.5.4 Programmer Tab （编程器选项卡）

该选项卡显示功能映像 （Function Map）的状态。另外，用户可通过此选项卡选择芯片保护选项

（Automatic、 Interactive、 None）和信息等级选项 （Advanced、 Standard）。

图 8.11　编程器属性

· Device Protection （芯片保护）

用户可通过此选项选择自动保护 （Automatic）或交互式保护 （Interactive），以防止闪存芯片被意外擦

除和意外写入。选择自动保护时，会根据需要，在写入前将块擦除。选择交互式保护时，在擦除前会

向用户确认。

另外，选择 None 时，可使芯片保护无效。双击该选项，能够编辑设置。

FDT 在和芯片连接时，通常会记录闪存块的状态，并能决定何时写入闪存。

【注】 如果芯片保护无效，那么写入前的擦除必须由用户进行。

· Message Level （信息等级）

用户可选择标准 （Standard）或高级 （Advanced）作为信息等级。在标准信息等级中，显示关于高位

通信的通用 FDT 及目标芯片状态的信息。在高级信息等级中，显示关于低位通信更详细的信息。双击

该选项，能够编辑设置。

· Readback Verification （读回验证）

写入结束后， FDT 能通过读回验证，来检验数据是否成功写入。通过此选项，用户可指定是否

（总是／只在确认后／从不）进行读回验证。双击该选项，能够编辑设置。

· Reset on Disconnect （断开时复位）

在芯片与 UPB 或 FDM 组合使用的情况下， FDT 和芯片断开时，能通过 FDT 复位目标硬件。用户可使

用此选项指定是否 （总是／只在确认后／从不）进行读回验证。双击该选项，能够编辑设置。

· Connection Reset （连接复位）

通过此选项，控制 FDT （在 User Mode 中通过 FDM 连接时）是否设置模式引脚以及是否进行复位。

该项目包含以下选项。

Default – 使用默认设置 （Set Reset & Mode Pins）。该设置保存在登录时的设置中。

Reset & Mode – 用于复位和模式引脚的设置。

Mode Only – 屏蔽复位，只进行模式引脚的设置。必须保证此操作不会损坏芯片、也不会引起意外的运

行。本选项主要用于 User Mode 和 User Program Mode 之间的切换。

None – 屏蔽复位以及模式引脚的设置。
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· Reinterrogate on Disconnect （断开时再确认）

该选项强制 FDT 再度确认 Generic Boot 芯片的连接。当选项设定为 “No”（默认）时，芯片的设置被

保存于自动生成的 fcf 文件中，并被重复使用。当选项设定为 “Yes”时， FDT 通常会再度确认芯片连

接的详细情况，这样，一个工程就能和多个 Generic Boot 芯片共同工作。当选项设定为 “Query”时，

FDT 会要求用户选择是否对芯片进行再度确认。双击该选项，能够编辑设置。

· Security Protection （安全性保护）

该选项控制 FDT 是否需要对 QzROM 芯片进行安全性保护 （当此芯片断开连接时）。这和 QzROM 工

具栏的设置相同 （请参照 [2.1.2]）。断开连接时，如果要自动设置为保护，就选择 “Automatic”。如

果需要用户确认，就选择 “Prompt”。如果不设置保护，就选择 “None”。

【注】 被保护的芯片可能无法再次连接。

· Function Map （功能映像）

在通信 Protocol B、 C、 D 或 E 中不使用该项。

8.5.5 Modules Tab （模块选项卡）

该选项卡显示核心程序文件名。因为大部分的核心程序不使用整个模块，所以某些项目为空白。

图 8.12　模块属性

8.6 Data File Properties （数据文件属性）窗口

在 16 进制编辑器窗口中选择已经打开的文件时，通过单击 “Properties”工具栏按钮或右键单击

“Properties”菜单来调用该对话框。

8.6.1 Block Usage Tab （块的用法选项卡）

该选项卡显示当前文件选项卡中所包含的数据块的起始地址、退出地址以及块的大小。当文件在编辑器窗

口中打开时，若双击某区域，可反显选中的数据。

图 8.13　　数据文件属性 – 块的用法
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8.6.2 Cursor Value （光标值）

该选项卡显示光标处的各种数据表示。显示结果取决于该显示单位被设定为 Byte、 Word 还是 DWord。因

为对显示单位大小进行了数据对齐，因此，会产生下列现象：比如在 DWord 内，无论光标在何处，显示的数

据都相同。

图 8.14　数据文件属性 – 光标值

8.6.3 Selection Value （选择值）

该选项卡显示当前选择处的各种数据表示。显示结果取决于选择 Byte、 Word 还是 DWord。
　

图 8.15　数据文件属性—选择值

8.6.4 Checksum Tab （校验和选项卡）

该选项卡显示所选数据范围的原始校验和。

图 8.16　数据文件属性—校验和选项卡
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8.7 输出窗口

输出窗口是 FDT GUI 的主窗口之一。

图 8.17　输出窗口

在输出窗口中可以使用弹出式菜单，该菜单包含以下选项。

8.7.1 Copy （复制）

将选择的文本复制到剪贴板。

8.7.2 Clear Window （清除窗口）

清除输出窗口。

8.7.3 Save （保存）

将窗口的内容保存到文本文件。通过 “Save”对话框，可以指定保存文件的路径。

8.7.4  Allow Docking （允许停靠）

通过选定该选项，可将输出窗口停靠 （Dock）在 FDT 应用程序窗口中。不选定此选项时，输出窗口为浮

动窗口。

8.7.5 Hide （隐藏）

选择 “Hide”时，隐藏输出窗口。通过 [Hide (V) → Output (U)] 菜单，可再次显示输出窗口。

【注】 输出窗口不会无限地记录信息。在当前的默认下，可以记录 500 行的文本，之后，较早记录的信息将被清除。

8.8 16 进制编辑器窗口

16 进制编辑器窗口是 FDT GUI 的主窗口之一。用于显示 FDT 内部的文件内容或目标的上传内容。有多种

在编辑器内部打开文件的方法。

· 在工作空间窗口中双击工程文件

· 在 Windows® Explorer 中双击 FDT 文件格式

· 将文件从 Windows® Explorer 拖到编辑器区

· 从 “File”菜单或工具栏图标中选择 “Open a Data File…”

· 由目标芯片上传数据
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图 8.18　16 进制编辑器窗口

在该窗口底部有一个或多个选项卡，对应于各自的工程目标芯片的闪存区。各个选项卡被设定为闪存区的

地址范围，显示区域中对应的数据。 DDI 文件或块中转的上传内容能够同时添加到多个选项卡上。因为普通的

S-Record 文件和二进制文件 （以及地址中转的上传内容），每次只能保持一个闪存区的数据，所以其他选项卡

一直闲置 （不过，可以手动编辑）。

在窗口顶部会显示当前的文件名 （或上传名称）、当前的光标位置 （或所选区域）以及端 （Endian）的

状态。 FDT 的默认状态为大端 （Big Endian）。（注意：切换文件的端状态时，不会对保存在文件中的数据产

生影响）

另外，当工程芯片支持 ID 代码的概念时 （详细内容请参照芯片的硬件手册）， FDT 就会突出显示与此相

关的字节位置。

图 8.19　ID 代码的突显示例

若要关闭打开了的文件，则请单击该文件右上角的 X 按钮。如果文件未保存， FDT 会询问用户是否保存

打开了的文件 （不过，按 Shift 同时单击 X 按钮的情况除外）。保存并关闭文件后，如果当前工程不包含该文

件， FDT 会询问用户是否添加该文件。

当以 S-Record 等不同的格式保存 .ddi 文件时， FDT 不能将每个 DDI 选项卡的数据输出到同一个文件中。

此时， FDT 会警告用户只有当前选项卡的数据才能保存在文件中。激活的选项卡是当前可见的选项卡。请注

意，与源 DDI 文件相比时，以不同格式保存的文件有可能丢失数据。
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另外，FDT 在默认状态下以大写字母保存文本基础的文件格式（S-Record 或 DDI），即使原文件为小写字

母。这是为了提高和其他 Renesas 工具的兼容性而设置的 3.06 的新功能。若在 FDT.ini 文件 （位于根安装目录

下）中添加如下项目，就可改变此功能：

[ECXSRecordView]

LowerCaseSRecordSave=1 

以上操作可使 FDT 区分大小写字母，并保证小写字母的文件按原格式保存。

在 16 进制编辑器窗口中单击右键，将显示弹出式菜单，可以选择以下选项：

8.8.1 Cut （剪切）

从窗口中删除反显的块的内容，并将该内容保存在剪贴板中 （使用标准的 Windows® 方式）。此选项只在

块反显时有效。

8.8.2 Copy （复制）

将反显的块的内容复制到剪贴板中 （使用标准的 Windows® 方式）。此选项只在块反显时有效。

8.8.3 Paste （粘贴）

把 Windows® 剪切板的内容复制到子窗口中当前的光标位置。

8.8.4 Undo （撤消）

取消对选中数据进行的上一步编辑操作，还原数据。

8.8.5 Redo （重复）

取消上一步还原操作。

8.8.6  Display Unit （显示单元）

以层叠格式显示以下菜单：

Byte： 以字节 （8 位）为单位显示数据。

Word： 以字 （16 位）为单位显示数据。

DWord： 以双字 （32 位）为单位显示数据。

8.8.7  Endian （端格式）

以层叠格式显示以下菜单：

Little Endian：以小端格式显示数据 （工程的新默认状态是基于 R8C 和以往的三菱芯片的）。

Big Endian： 以大端格式显示数据。

8.8.8 Align to 8 Bytes （对齐为 8 个字节）

以 8 个字节为单位显示每行的数据。各行所能够显示的字节数因窗口大小而异。默认设置为 “On”。

8.8.9 Toggle ASCII Column （切换 ASCII 列）

删除或显示 ASCII 列。



第 8 章   窗口 （Windows）

Rev.2.00  2008.04.24  Page 83 of 115
RCJ10J0052-0200

8.8.10 Create Selection （创建选择） ...
打开 “Create Selection”对话框。在该对话框中，用户可通过起始地址、退出地址和长度的输入，创建选

择区。可结合剪切板、 Fill、 Search 和 Replace 来使用该选择区。

8.8.11 Fill （指定数据） ...
打开当前激活的文件的 “Fill”对话框。可在该对话框中，向选中的区写入指定的数据。若选择了

“ASCII Fill”对话框，则可用 ASCII 字符指定写入的数据。

8.8.12 Find （查找） ...
打开 “Find”对话框。在该对话框中可输入 16 进制数或 ASCII 数据。搜索范围限定于编辑器窗口中当前

文件内的数据。若发现符合检索条件的数据，则更新编辑器窗口，显示找到的数据。

8.8.13 Replace （替换） ...
打开 “Replace”对话框。在该对话框中输入想要检索的 16 进制数或 ASCII 数据。另外，也能够用相同的

格式输入替换数据。检索范围被限定为编辑器窗口中当前文件内的数据。若发现符合检索条件的数据，则更新

编辑器窗口，显示找到的数据。单击 “Replace”按钮 （此时为有效），替换数据。

8.8.14 Properties （属性） ...
打开 “Data File Properties”对话框。

8.8.15 Add to Active Project （添加到当前工程）

把文件添加到当前的工程中。如果文件已经添加到工程中，那么该按钮无效。

8.8.16 Data EntryNote （数据输入注意事项）

要把数据输入到 “Find”、“Replace”或者 “Fill”对话框时，基于 ASCII Search 复选框，只能使用 16 进

制数或 ASCII 值。要输入 16 进制数时，在项目文本框中最初的部分默认显示为 “0x”，因此要在其后继续输

入 16 进制数。

8.8.17 Goto Address （设定光标位置）

双击地址列，将显示 “Goto Address”对话框。可在此对话框中输入 16 进制数地址，设定 16 进制编辑器

的光标位置。请注意，该命令与名称类似的核心程序命令 “Go From Address”完全不同。
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8.9 自定义工具栏

选择 “Customise”对话框中的 [Tool → Customise...]。

图 8.20　自定义对话框 （工具栏选项卡）

8.9.1 Show Tooltips （显示工具提示）

选中 “Show Tooltips”后，当鼠标 （箭头）放在按钮上时，会显示此按钮的动作。不选中时，则不显示

动作。

8.9.2 New （新工具栏） ...
单击 “New…”按钮，打开 “Toolbar Name”对话框。用户能在该对话框中制作新的工具栏。输入新的名

字后单击 “OK”，新名字将被添加到 “Toolbar”列表中，界面中显示空的工具栏。

选择 “Commands”选项卡，能够向新的工具栏添加按钮。用户可用鼠标将新的工具栏拖到 GUI 中任何地

方。 

8.9.3 Reset （复位）

单击 “Reset”按钮，可将工具栏复位到默认设置。

8.9.4 Toolbar Name （工具栏名）

显示列表中选择的工具栏名称。

8.9.5 OK

单击 “Toolbar Name”对话框的 “OK”按钮，将新名字添加到 “Toolbar”窗口的 “Toolbar”列表中，

并在 GUI 中打开空白工具栏。

单击 “Customise”对话框的 “OK”按钮，保存变更内容并关闭对话框。

8.9.6 Delete （删除）

新的工具栏添加到 “Toolbar”列表后，选择该工具栏时，“Reset”按钮将变为 “Delete”按钮。单击该按

钮，可将新的工具栏从列表和 GUI 中删除。
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8.10 自定义菜单

 选择 [Tools → Customise...]，打开 “Customise”对话框，然后单击该对话框中的 “Menu”选项卡。

图 8.21　自定义对话框 （菜单选项卡）

     添加新建菜单选项时

1. 选择 [Tools → Customise...]，显示上述对话框。然后选择 “菜单”选项卡。

用户必须首先决定添加对所有工作空间都有效的全局应用工具 （“Application wide tools:”），还是添

加仅对当前工作空间有效的工作空间工具 （“Workspace wide tools:”）。之后，选择对话框中相关的区

域。

2. 单击 “Add...”按钮。如果要把已有的系统工具添加到菜单，那么选择 “Select from existing system 
tools”单选按钮。接下来，从下拉式列表中选择工具，单击 “OK”。另外，如果用户想添加自己的工

具时，请按下列步骤进行。

3. 将工具名称输入到 “Name”区域。

4. 将参数以外的命令输入到 “Command”区域。

5. 将想要传递给命令的参数输入到 “Arguments”区域。

6. 将想要 （通过工具）执行的初始目录输入到 “Initial directory”区域。

7. 单击 “OK”，添加菜单选项到 “Tools”菜单。
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图 8.22　Add Tool （添加工具）对话框

默认状态下，新建菜单选项被添加到列表的底部（工具菜单底部）。 [Tools] 菜单中菜单选项的顺序可以更

改。

要更改菜单选项时

1. 选择 [Tools → Customise...]，显示以下的对话框。然后选择 “Menu”选项卡。

2. 选择想要更改的菜单选项，单击 “Modify...”按钮。

3. 在 “Modify Tool”对话框中更改，然后单击 “OK”。

图 8.23　Modify Tool （更改工具）对话框

要删除菜单选项时

4. 选择 [Tools → Customise...]，显示如图 8.21 所示的对话框。然后选择 “Menu”选项卡。

5. 选择想要删除的菜单选项，单击 “Remove”按钮。
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第 9 章 Simple Interface Mode （简化界面模式）

选择 [Tools → Simple Interface...]，可启动 FDT Simple Interface Mode。通过该模式，可在创建工程

（Project）后，简化 FDT 的界面风格。关于此模式和用户名及密码的并用，请参照 [ 第 5 章 ]。本章介绍

Simple Interface Mode 的总体情况。

有关 Basic Simple Interface Mode （基础简化界面模式）请参照 [ 第 10 章 ]。

图 9.1　FDT Simple Interface （FDT 简化界面）

9.1 Options （选项）菜单

9.1.1 Login （登录） ...
通过此选项，可切换登录到 FDT 的用户。也可通过快捷键 Ctrl+Shift+U 启动登录对话框。

9.1.2 Batch Erase Mode （批擦除模式） ...
通过此选项，可将对话框从写入画面切换到擦除画面。此时，“Program Flash”按钮变为 “Erase”，

File\Image 选择按钮及写入选项无效。单击 “Erase”，将擦除整个芯片 （不能指定擦除的区）。
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9.1.3 AutoDisconnect （自动断开）

写入 （Batch Erase Mode 时为擦除）完成后，强制 FDT 自动断开连接。这样，用户不需要按

“Disconnect”按钮。

9.1.4 Readback Verify （读回验证）

此选项用于控制 FDT 在写入完成后是否自动进行读回验证操作。在工程设置 （“Project Properties”窗口

中 “Programmer”选项卡上的 “Readback Verification”）中配置有默认设定。用户也可忽视默认设置，直接选

择该菜单项目。

9.1.5 Request Checksum （请求校验和）

此选项用于控制 FDT 在写入完成后是否自动进行校验和请求操作。即使 session 改变，这个设置仍然有

效。

9.1.6 Erase Device Before Program （写入前擦除芯片）

此选项用于控制 FDT 在写入芯片前是否自动执行擦除。如果选择自动执行，将在写入前擦除闪存区的所

有块。即使 session 改变，这个设置仍然有效。

9.1.7 Security Protection （安全性保护）

此选项用于控制 FDT 是否需要对 QzROM 芯片 （断开连接时）进行保护。如果要在断开连接时自动设定

保护，就选择 “Automatic”。 如果需要用户确认，就选择 “Prompt”；如果不设定保护，就选择 “None”。

【注】 不能再次连接被保护的芯片。

9.1.8 Field Programming → Run Published File （现块写入 → 执行发布的文件） ...
打开 . fpf4 文件，在 Simple Interface Mode 下使用。

9.1.9 Unique Code Programming （识别码的写入） ...
可对 FDT 内部的识别码写入功能进行设定和控制。详细请参照 [ 第 16 章 ]。

9.1.10 About （关于） ...
显示 “About”对话框。

9.2 对话框的控制

9.2.1 Back to Project （返回工程）

用于返回 FDT 的主画面。当前登录到 FDT 上的用户，在未访问 “FDT:Project Edit”时，此按钮无效。

（有关详细情况，请参照 [ 第 5 章 ]。）

9.2.2 Exit （退出）

单击此按钮将退出 FDT。在下次装入时，FDT 以 Simple Interface Mode 启动。当前登录到 FDT 上的用户，

在未访问 “SimpleInterface:Exit”时，则此按钮无效。（有关详细情况，请参照 [ 第 5 章 ]。）

9.2.3 Download Project image / Download File radio buttons
（下载工程映像／下载文件单选按钮）

不能同时选择两者。用户可指定下载 Project Image 还是下载其他文件。如果当前在 FDT 上登录的用户，

未访问 “SimpleInterface:Download File”或 “SimpleInterface:Download Project Image”，则该按钮无效。（有

关详细情况，请参照 [ 第 5 章 ]）
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9.2.4 Project Image / Download File Area （工程映像／下载文件区）

按下 “Download Project Image”单选按钮， FDT 将显示下载 image 的文件名。

在带有 User Boot Area 的芯片上按下 “Download File”单选按钮时，可选择将文件下载到 User Area 还是

User Boot Area 中。

9.2.5 Program Flash / Erase （写入闪存／擦除）

单击 “Program Flash”按钮， FDT 可将指定的文件或 image 下载到闪存中。另外，如果 Readback Verify
处于 Off 状态，则计算校验和，结果显示在画面中。在 Batch Erase Mode 中，此按钮变换为 “Erase”，并擦除

整个芯片。

9.2.6 Disconnect （断开连接）

单击 “Disconnect”按钮，强制 FDT 断开连接。

9.2.7 File Selection （文件选择）

在文件选择区，可直接将文件名输入编辑区中，也可通过点击箭头形按钮后，在最近使用过的文件列表中

浏览或选择文件名 （文件列表最多可记录 4 个文件名）。
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第 10 章 Basic Simple Interface Mode （基础简化界面模式）

从 “Start”菜单中的 “FLASH Development Toolkit 4.01 Basic”选项启动 Basic Simple Interface Mode。通

过此模式，可简化 FDT 的界面风格，并且不需要工作空间 （Workspace）或工程 （Project）。关于该模式和用

户名及密码的并用，请参照 [ 第 5 章 ]。本章说明 Basic Simple Interface Mode。有关 Simple Interface Mode 的总

体情况，请参照 [ 第 9 章 ]。
Basic Simple Interface Mode 在启动时恢复以前的所有设置。如果要变更芯片、核心程序或端口的设置，就

通过 [Options → New Settings...] 菜单启动 Wizard，来配置新的设定。

　

图 10.1　FDT 基础文件写入 
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10.1 Options （选项） 菜单

10.1.1 Login （登录）

通过此选项，能切换登录到 FDT 上的用户。也可用快捷键 Ctrl + Shift + U 启动 “Login”对话框。

10.1.2 Batch Erase Mode （批擦除模式） ...
通过此选项，可将对话框从写入画面切换到擦除画面。此时，“Program Flash”按钮变为 “Erase”，

File\Image 选择按钮及写入选项无效。单击 “Erase”，将擦除整个芯片 （不能指定擦除的区）。

10.1.3 AutoDisconnect （自动断开）

写入 （Batch Erase Mode 时为擦除）完成后，强制 FDT 自动断开连接。这样，用户不需要按

“Disconnect”按钮。

10.1.4 Readback Verify （读回验证）

此选项用于控制 FDT 在写入完成后是否自动进行读回验证操作。即使 session 改变，这个设置仍然有效。

10.1.5 Request Checksum （请求校验和）

此选项用于控制 FDT 在写入完成后是否自动进行校验和请求操作。即使 session 改变，这个设置仍然有

效。

10.1.6 Erase Device Before Program （写入前擦除芯片）

此选项用于控制 FDT 在写入芯片前，是否自动执行擦除。如果选择自动执行，将在写入前擦除闪存区的

所有块。即使 session 改变，这个设置仍然有效。

10.1.7 Security Protection （安全性保护）

此选项用于控制 FDT 是否需要对 QzROM 芯片 （断开连接时）进行保护。如果要在断开连接时自动设定

保护，就选择 “Automatic”。如果需要用户确认，就选择 “Prompt”；如果不设定保护，就选择 “None”。

【注】 不能再次连接被保护的芯片。

10.1.8 New Settings （新的设置） ...
启动 Wizard，可输入新的设置。

10.1.9 About （关于） ...
用于显示 “About”对话框。 

10.2 对话框的控制

10.2.1 Exit （退出）

单击此按钮，将退出 FDT。在下次装入时， FDT 以 Simple Interface Mode 启动。如果当前登录到 FDT 上

的用户，未访问 ‘SimpleInterface:Exit’，则此按钮无效。（有关详细情况，请参照 [ 第 5 章 ]。）

10.2.2 Download File radio button （下载文件单选按钮）

如果当前登录到 FDT 的用户，未访问 ‘SimpleInterface:Download File’，则此单选按钮无效。有关详细情

况，请参照 [ 第 5 章 ]。
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10.2.3 Download File Area （下载文件区）

用户可在带有 User Boot Area 的芯片上选择将文件下载到 User Area 还是 User Boot Area 中。

用户可在带有 Data Area 的芯片上选择将文件下载到 User Area 还是 Data Area 中。

10.2.4 Program Flash / Erase （写入闪存／擦除）

单击 “Program Flash”按钮， FDT 可将指定的文件或 Image 下载到闪存中。另外，如果 Readback Verify
处于 Off 状态，则计算校验和，结果显示在画面中。在 Batch Erase Mode 中，此按钮变换为 “Erase”， 并擦除

整个芯片。

10.2.5 Disconnect （断开连接）

单击 “Disconnect”按钮强制 FDT 断开连接。

10.2.6 File Selection （文件选择）

在文件选择区，可直接将文件名输入编辑区中，也可通过点击箭头形按钮后，在最近使用过的文件列表中

浏览或选择文件名 （文件列表最多可记录 4 个文件名）。
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第 11 章 现场写入 （Field Programming）

本功能用于辅助 FDT 用户向其他 FDT 用户发送 FDT 工程 （Project）的操作。如果正确创建了工程和工

程 Image， FDT 就能把需要的全部文件 （核心程序和数据文件）放在一个文件中 （扩展名为 .fpf4）。该文件

可被发送到使用同一版本 FDT 的其他用户。接收用户只需双击该文件，就可启动 FDT 并打开工程文件。 FDT
将打开文件，根据新的地址更新文件路径的参照，并且允许拥有正确存取权限的用户对使用了 FDT Simple 
Interface Mode 的工程 Image 进行写入。

创建包文件时，在 FDT 工作空间的主窗口中，选择 [Project → Field Programming → Publish…]。因为工

程 Image 是创建工程的前提，所以当工程还没有创建工程 Image 时， FDT 会询问用户是否希望现在创建。然

后， FDT 会提示用户为已创建的包文件选择输出目录。

运行创建的文件时，在 FDT 工作空间的主窗口中，选择 ['Project → Field Programming → Run Published 
File…]。或者，从 Simple Interface Mode 窗口中选择 [Options → Field Programming → Run Published File…]。
另外，在 Windows® 中双击 “.fpf4”文件，可使该文件以 Simple Interface Mode 启动 FDT。

在打开包文件时， FDT 将检查该文件创建时的版本，如果无法解开该文件， FDT 将警告用户并以当前安

装的版本运行此文件。运行该包文件所需的版本将突出显示在消息框。

FDT 将在子目录 [Published Projects] 中解开 .fpf4 文件。

 

图 11.1　FDT 现场写入界面
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11.1 Options （选项）菜单

11.1.1 Login （登录）

通过此选项，能切换登录到 FDT 上的用户。也可用快捷键 Ctrl+Shift+U 启动 “Login”对话框。

11.1.2 Batch Erase Mode （批擦除模式）

通过此选项，可将对话框从写入画面切换到擦除画面。此时，“Program Flash”按钮变为 “Erase”，

File\Image 选择按钮及写入选项无效。单击 “Erase”， 将擦除整个芯片 （不能指定擦除的区）。

11.1.3 Auto Disconnect （自动断开）

写入 （Batch Erase Mode 时为擦除）完成后，强制 FDT 自动断开连接。这样，用户不需要按

“Disconnect”按钮。

11.1.4 Readback Verify （读回验证）

此选项用于控制 FDT 在写入完成后是否自动进行读回验证操作。即使 session 改变，这个设置仍然有效。

11.1.5 Request Checksum （请示校验和）

此选项用于控制 FDT 在写入完成后是否自动进行校验和请求操作。即使 session 改变，这个设置仍然有

效。

11.1.6 Erase Device Before Program （写入前擦除芯片）

此选项用于控制 FDT 在写入芯片前，是否自动执行擦除。如果选择自动执行，将在写入前擦除闪存区的

所有块。即使 session 改变，这个设置仍然有效。

11.1.7 Security Protection （安全性保护）

此选项用于控制 FDT 是否需要对 QzROM 芯片 （断开连接时）进行保护。如果要在断开连接时自动设定

保护，就选择 “Automatic”。如果需要用户确认，就选择 “Prompt”；如果不设定保护，就选择 “None”。

不能再次连接被保护的芯片。

11.1.8 Field Programming → Run Published File （现场写入→运行发布的文件）

打开其他的 .fpf4 文件，在 Simple Interface Mode 下使用。

11.1.9 About （关于）

用于显示 “About”对话框。 

11.2 对话框的控制

11.2.1 Back to Project （返回工程）

返回 FDT 工作空间的主画面。如果当前登录到 FDT 上的用户，未访问 ‘FDT:Project Edit’，则此按钮无

效。（有关详细情况，请参照 [ 第 5 章 ]。）

11.2.2 Exit （退出）

单击此按钮，将退出 FDT。在下次装入时， FDT 以 Simple Interface Mode 启动。如果当前登录到 FDT 上

的用户，未访问 ‘SimpleInterface:Exit’，则此按钮无效。（有关详细情况，请参照 [ 第 5 章 ]。）
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11.2.3 Download Project image radio button （下载工程映像单选按钮）

如果当前登录到 FDT 上的用户，未访问 ‘SimpleInterface:Download Project Image’，则此单选按钮无效。

（有关详细情况，请参照 [ 第 5 章 ]。）

11.2.4 Program Flash / Erase （写入闪存／擦除）

单击 “Program Flash”按钮， FDT 可将指定的文件或 Image 下载到闪存中。另外，如果 Readback Verify
处于 Off 状态，则计算校验和，结果显示在画面中。在 Batch Erase Mode 中，此按钮变换为 “Erase”， 并擦除

整个芯片。

11.2.5 Disconnect （断开）

单击 “Disconnect”按钮，强制 FDT 断开连接。
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第 12 章 E8 和 E8a 的升级

连接 E8 或 E8a 接口适配器电路板时， FDT 将检查固件（适配器软件）的版本是否正确、是否可与选中的

芯片进行连接。如果版本不符合要求，那么 FDT 为了继续连接，将会提示对固件进行升级。另外， 如果固件

的校验和不正确，也会有升级提示。注意：在某些情况下，如果当前的版本不支持被选中的芯片，就需要对当

前的旧版本进行升级。在升级过程中，请勿拔出接口板，否则，可能会使该接口板进入擦除状态。

【注】 E8 和 E8a 有 2 个固件区，“Level 0”及 “Level 1”（分别为 Bootstub 和 Adaptor Software）。一般情况下，

FDT 只更新 Level 1 区，但有时，也需要更新 Level 0，通常在第一次以 E8Direct 模式连接 E8 （请参照第 13 章）

时会出现这种情况，因此其升级过程也会稍有不同。区别如下所示 （该过程与 E8a 相似）：

对 Level 0 及 Level 1 的更新 （例）：

E8 target power has been set to ON at 5.0V

Connecting to device 'R5F21174' on 'E8'

Configuration:

'BOOT Mode' connection - using emulated interface

Opening port 'E8' ...

Checking for E8 update...

Adaptor checksum OK

Processing Data file :'c:\FDT\ADPFiles\E8-Rel-Img.mot'

Mismatched (Level 0) version number found (current E8 version = 0.00.00.018, FDT holds 

version 2.00.00.000, FDT requires version 2.00.XX.XXX)

 

Update selected

Adaptor update started (do not unplug)...

Processing Data file :'c:\FDT\ADPFiles\MonpMain.mot'

  Adaptor update program downloaded...

Processing Data file :'c:\FDT\ADPFiles\AdpErase0.mot'

  Adaptor erased...

Processing Data file :'c:\FDT\ADPFiles\AdpWrite0.mot'

  Updating...

Adaptor updated successfully

<Connection continues…>
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仅对 Level 1 的更新 （例）：

E8 target power has been set to ON at 5.0V

Connecting to device 'R5F21174' on 'E8'

Configuration:

'BOOT Mode' connection - using emulated interface

Opening port 'E8' ...

Checking for E8 update...

Adaptor checksum OK

Processing Data file :'c:\FDT\ADPFiles\E8-Rel-Img.mot'

Adaptor version number OK

 (current E8 (Level 0) version = 2.00.00.000, FDT holds version 2.00.00.000, FDT 

requires version 2.00.XX.XXX)

Adaptor version type OK

 (current type = E8EMULATOR)

Processing Data file :'c:\FDT\ADPFiles\E8-Rel-Img.mot'

Mismatched (Level 1) version number found (current E8 version = 0.02.00.000, FDT holds 

version 2.00.00.000, FDT requires version 2.00.XX.XXX)

 

Update selected

Adaptor update started (do not unplug)...

Processing Data file :'c:\FDT\ADPFiles\MonpMain.mot'

  Adaptor update program downloaded...

Processing Data file :'c:\FDT\ADPFiles\AdpErase.mot'

  Adaptor erased...

Processing Data file :'c:\FDT\ADPFiles\AdpWrite.mot'

  Updating...

Adaptor updated successfully

<Connection continues…>
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第 13 章 接口板

FDT 可与多个接口板进行通信，并控制目标芯片的模式引脚。

13.1 闪存开发模块（Flash Development Module， FDM）

FDM 是闪存写入的 USB 接口板，用于将数据从 USB 转换至异步串行，并可控制多个模式引脚。 FDM 不

能向目标电路板供电，但是其电压必须与目标电路板的输入 / 输出和串行电压相符。

13.2 E8 （包括 E8Direct）
E8 是 USB 调试和闪存写入的接口板，用于将数据从 USB 转换至串行，最多可控制 4 个模式引脚，并可

进行引脚的复位。 E8 可向目标电路板进行 3.3V 或 5.0V 的供电，但输入 / 输出和串行电压必须相同。 E8 具有

两种运行模式：

E8 模式：在插入 E8 时，该模式为默认模式，模式引脚的设定在该模式中是预定好的。

E8Direct 模式：当用户通过与 FDM 相似的方式指定目标模式引脚的设定时，此模式为通用运行模式。进

入该模式时， FDT 会发送一个特殊的命令，使 E8 作为 E8Direct 被重新识别。当从 E8Direct 模式返回到

E8 模式时，必须拔出 E8 后再次插入。

13.3 E8a （包括 E8aDirect）
E8a 与 E8 相似，也是 USB 调试和闪存写入的接口板，用于将数据从 USB 转换至串行，最多可控制 6 个

模式引脚，并可进行引脚的复位。 E8a 可向目标芯片进行 3.3V 或 5.0V 的供电，但输入 / 输出和串行电压必须

相同。 E8a 接口板可利用时钟合成器提高并改善波特率，使接口板和目标电路板之间的波特率相符。 E8a 具有

两种运行模式，但这两种模式之间的切换是自动进行的：

E8a 模式：在插入 E8 时，该模式为默认模式，模式引脚的的设定在该模式中是预定好的。

E8aDirect 模式：当用户通过与 FDM 和 E8Direct 相似的方式指定目标模式引脚的设定时，此模式为通用

运行模式。

【注】 当有效连接到 E8a 时， FDT 会在状态栏中显示当前有效 E8a 序列号的详细情况。

警告：E8Direct 专用于 Renesas Starter Kits （RSK），不支持 E8Direct 和其他电路板一起使用。

E8aDirect 也可用于 Renesas Starter Kits （RSK）、 Generic Boot （通用引导）芯片和某些 0.35um 的芯片。

不正确的设定可能会损坏硬件，另外请注意：在将连接器插入目标电路板时，目标电路板的电源必须为关闭状

态。
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13.4 E8 固件与芯片 ID
初次插入 E8 时，显示为 “Renesas E-Series Device”。

 

图 13.1　E8 的初始识别

使用 E8Direct 功能时，需要重新启动 E8， FDT 在连接过程中自动执行该任务 （可能伴随有固件的升级。

请参照 [ 第 12 章 ]）。输出窗口显示以下信息。

Preparing for re-enumeration of E8 to E8Direct...

Sending re-enumeration command...

Request sent successfully, closing E8 Comms...

 
此时 Windows 认为 E8 是 E8Direct 芯片。 

【注】 在断开连接或机器掉电之前， E8 都被认为是 E8Direct 芯片。

 

图 13.2　E8Direct 的识别
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13.5 硬件的区别

虽然 FDM 没有向目标供电的功能，不过 E8Direct 能够提供 3.3V 或 5V。另外， FDM 和 E8Direct 的引脚

使用方法不同。就是说，不能简单的把 FDM 和 E8Direct 交换。 FDM 的通用 I/O 引脚是 MD0 ～ MD4 和

FWE，在这些引脚和目标芯片上相同名称的模式引脚之间进行了直接映射。因为在 E8 上能够使用的通用 I/O
引脚数量减少，而且连接在 14 引脚标头上的位置不同，所以不能再在芯片模式引脚名和 E8 的 I/O 引脚之间进

行直接映射，因此分别标以“A”、“B”、“C”、“D”。 E8Direct 的引脚需要设定为电路板专用而不是芯片专

用。

E8a 与 E8 引脚兼容， E8a 的大部分引脚与 FDM 也兼容 （除 MD3 引脚——12 号引脚以外）。
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引

脚

号

FDM 的引脚名

E8 Direct 的引脚名 E8a Direct 的引脚名
14 引脚 连接器

20 引脚 连接器

（仅限于日本）

1 SCK /RES Output D Output D

2 GND GND GND GND

3 FWx FWx Output C Output C

4 MD0 GND Output A Output A

5 Txd （由目标芯

片的 Txd向 FDM

上 2148AF的

Rxd输入）

MD0 Target Txd （由目标芯

片的 Txd向 E8上 2215UF

的 Rxd0输入）

Target Txd （由目标芯片的

Txd向 E8a上 2215RUF的

Rxd0输入）

6 MD1 GND GND (连接到 E8的 GND) Output E

7 MD4 MD1 Output B Output B

8 UVCC Input GND UVCC

（可提供 3.3V或 5V电源，

或检测目标电路板是否处于

供电状态）

UVCC

（可提供 3.3V或 5V电源，或检

测目标电路板是否处于供电状

态）

9 PVCC Input MD2 BUSY (不能用于

E8Direct)

BUSY\UVCC2 Serial

voltage input (用于 CLK、

Data、Tx 和 Rx，可提供 3.3V

或 5V电源，或检测目标电路板

是否处于供电状态 )

10 MD2 GND GND (连接到 E8的 GND) Output F

11 Rxd （由 FDM上

2148AF的 Txd0

向目标芯片的

Rxd输出）

MD3 Target Rxd（由 E8上

2215UF的 Txd0向目标芯

片的 Rxd输出）

Target Rxd（由 E8a上

2215RUF的 Txd向目标芯片的

Rxd输出）

12 MD3 GND GND (连接到 E8的 GND) GND (连接到 E8的 GND)

13 RESET MD4 RESET RESET

14 UCONNECT GND UCONNECT (连接到目标电

路板的 GND)

UCONNECT (连接到目标电路板

的 GND)

15 — RXD 

(用户系统的 TXD)

—

16 — GND —

17 — TXD

 (用户系统的 RXD)

—

18 — VIN (Vcc或 PVcc) —

19 — NC —

20 — VIN (PVcc) —
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FDM 使用了内置有 18.432MHz 晶体振荡器的 H8S/2148AF，而 E8 使用内置有 16MHz 晶体振荡器的 H8S/
2215UF， E8a 使用 H8S/2215RUF 和时钟合成器，该时钟合成器用于产生波特率。

【注】 如下所示的编号系统适用于 14 引脚的 FDM、 E8 和 E8a，但不适用于 20 引脚的 FDM 连接器。
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第 14 章 QzROM 的程序设计 （QzROM Programming）

QzROM 是新型的可写入闪存，内置于某些 4 位或 8 位的 MCU 中。该程序设计几乎是以 Protocol D 形式

的芯片为基础的，不过 QzROM 和 Protocol D 有如下重要的不同之处。

· 一次性写入——QzROM 的各字节只能被写入一次。

· QzROM 不能被擦除——没有擦除命令。

· 安全性保护——QzROM 具有安全性保护功能。若在保护状态下启动目标 MCU 进行连接，则可能会出

错。之后，不能从芯片读出或写入。

空白检查——QzROM 具有空白检查命令，而其他 Protocol D 芯片没有。如果设定芯片保护选项为

“Automatic”或 “Interactive”，那么 FDT 会使用空白检查命令，在写入前检查芯片的写入状态。

FDT 能识别基于 （为工程而构建的）芯片的 QzROM。

14.1 保留区（Reserved Areas）
QzROM 向 FDT 引入了 “Reserved Areas”的概念。例如， M37545G4 的 ROM 内有 8 字节的保留区。保

留区是被定义的闪存区， FDT 不能对此区域进行读出、写入或空白检查。在 16 进制编辑器中，这样的保留区

被显示为字符串 “**”。

 

图 14.1　16 进制编辑器中的保留区 

忽略对保留区的数据输入和数据复制。由 16 进制编辑器保存的文件不包含保留区的数据 （在 FDT 内部，

不论读取了什么内容，都把数据当作 0xFF 处理）。
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14.2 安全性保护（Security Protection）
QzROM 还向 FDT 引入了安全性保护的概念，可在 FDT 断开连接时选择设定 （不过，一旦设定就不能解

除）。

大多数的芯片中，有 Full( 禁止以后再连接该芯片 ) 和 None （可正常再连接） 2 个等级的保护。版本越新

的芯片，保护等级会越多，可对芯片进行局部保护，且允许以后再连接 （但是被保护的数据区将被屏蔽）。

安全性保护的设定有以下 3 个选项。

1. Automatic （自动） : 断开 FDT 的连接时保护芯片。最初选择 Automatic 时，将决定保护的等级 （一般

为 [Full]）。当芯片提供多个等级的保护时，将显示对话框，用户可通过此对话框选择自动适用的等

级。

 

图 14.2　自动保护的选择

2. Prompt （提示） : 断开连接时， FDT 将询问该如何处理 （即是否保护）。可选择全保护 （或芯片支持

的其他的等级）或不保护。默认为不保护。

 

图 14.3　断开连接时的保护选择

3. None （无保护） : 断开 FDT 的连接时不保护芯片。

当实际断开连接时，操作结果将显示在输出窗口。变更该设定的方法因当前的操作模式而不同。
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14.2.1 Toolbar （工具栏）

在 FDT 的 Full Mode 中，如果选择了基于 QzROM 的工程， 就能够使用 QzROM 工具栏。该工具栏显示当

前选择的选项，单击旁边的图标，能轻松改变当前选项。

 

图 14.4　Automatic （自动）

 

图 14.5　Prompt （提示）

 

图 14.6　None （无保护）

【注】 单击图标并不会立即保护芯片，而在断开连接时执行。

14.2.2 Project （工程）

在工程属性对话框中，除了能够改变选项，还能显示当前的设定。用 “Programmer”选项卡设定。

 

图 14.7　安全性保护的属性

双击 “Security Protection”区域会显示新的对话框，通过该对话框，可以改变项目。
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图 14.8　安全性保护对话框的改变 

14.2.3 Simple Interface / Basic Mode （简化界面／基础模式）

如果使用了仅能访问 “Simple Interface”对话框的模式，那么能够在菜单选项中改变设定。

 

图 14.9　Simple Interface 的保护设定

选定标记显示了当前选择的选项。

【注】 如果不是基于 QzROM 的工程，那么此菜单选项无效。
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第 15 章 锁定

15.1 概要

一部分 M16C 族芯片支持防止写入或擦除的擦除块锁定功能。

在 FDT 中，可于连接、断开以及正常运行时通过工具栏按钮和菜单选项进行锁定设置。 

图 15.1　工具栏按钮

 

图 15.2　菜单选项 

可分别锁定和解锁支持该功能的各个擦除块 （注：只能通过块的擦除进行解锁），但是，在芯片的连接断开前，

设置都不会有效。 FDT可在断开时自动设置各个擦除块的锁定状态。
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15.2 连接

FDT 在连接到支持锁定功能的芯片时，会确认各个擦除块当前的锁定状态，每个擦除块都有一个对应的锁

定位 （如工程配置文件中所定义的）。然后，根据当前的连接设置 （可通过 15.3 中所示的锁定设置对话框来

选择）， FDT 会进行以下其中一种操作：

1. 自动禁止锁定

FDT 会在连接时自动禁止芯片的锁定，从而使芯片中所有的块都可以被写入或擦除 （无论这些块当前

是否被锁定）。

2. 询问用户

FDT 会在连接时询问用户是否禁止芯片的锁定：

 

图 15.3　关于连接信息的询问 

如果点击 “Yes”，就会使主锁定位无效 （如 1 所述）。如果选择 “No”，则保持当前的锁定设置

（如 3 所述）。

3. 什么也不做

FDT 不会改变当前芯片上的任何锁定设置。因此，当试图对锁定了的块进行写入或擦除时， FDT 会自

动中止该操作。

15.3 锁定设置对话框

当 FDT 连接于支持擦除块锁定功能的芯片时，可通过工具栏或 “Device → Block Locking...”菜单进入锁

定设置对话框，在该对话框中可设置 FDT 的操作。对话框的设置例如下所示：

 

图 15.4　块锁定设置对话框
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1. 连接时

当 FDT 连接于具有锁定功能的芯片时，通过对话框左边的 “On Connect”部分对 FDT 的操作进行控

制，详细情况请参照 [15.2  连接 ]。

2. 断开时

当 FDT 与具有锁定功能的芯片断开连接时，通过对话框右边的 “On Disconnect”部分对 FDT 的操作

进行控制，详细情况请参照 [15.4  断开连接 ]。

3. 锁定状态的树形图

对话框的中间部分以树形图显示了芯片的锁定状态，这近似于擦除块对话框。该树形图反映了信息的

重要部分。

 

图 15.5　锁定状态树形图设置

连接时的锁定状态
“Lock State at Connection”一栏显示了在 FDT 最初连接时各个擦除块的锁定状态，分别用下列两种标志来

表示：

– 擦除块在最初连接时为锁定状态

– 擦除块在最初连接时为非锁定状态

有的擦除块没有任何标志，呈灰色显示，这表示该块不支持锁定功能。FDT 会从工程配置文件中自动检测

出该状态。

断开连接时的状态
“State at Disconnect”一栏显示了在 FDT 和芯片断开连接时各个擦除块将被设置为何种锁定状态 （假定用

户不选择 “Do Nothing”单选项）。有以下两种可能值：

Locked – 擦除块将在断开连接时受到保护。

Unlocked – 擦除块在断开连接时不受保护。（注：如果块在连接时处于锁定状态， FDT 就得进行块的擦

除以解除锁定。该操作会在需要时得到确认，详细情况请参照 [15.4  断开连接 ]。）

如果擦除块不支持锁定功能，那么该项将显示为 “N/A”。断开连接时的状态在默认情况下会和连接时的

锁定状态一样。若要改变此默认设置，就选定树形图右边的 “Enable Editing”复选框，这样可改变显示和断

开连接时的设置。双击设置可切换当前状态。

【注】 在 FDT 还没连接芯片时，该树形图为空，且“Enable Editing”复选项框不能使用。
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15.4 断开连接

当用户通过工具栏或菜单选择 “Disconnect”时， FDT 会根据当前的连接设置 （可通过 15.3 中所示的锁

定设置对话框来选择）进行以下其中一种操作：

1. 自动设置

在断开连接的过程中， FDT 会对锁定设置对话框中指定了的块自动进行锁定或解锁。（注：当锁定的

块需要解锁时， FDT 会先向用户确认是否擦除这些块。 ）
  

图 15.6　擦除确认信息

如果用户选择了 “Yes”， FDT 就会按要求进行锁定或解锁。如果用户选择了 “No”，就不会发生任

何擦除或锁定，但断开连接的操作会继续进行。 

2. 询问用户

如果选择了询问用户 （“Query User”）选项， FDT 就会显示锁定设置对话框的一部分。该对话框显示

了连接时芯片的锁定状态，以及芯片在断开连接时将要设置的锁定状态。该状态还可通过选定

“Enable Editing”复选框来设置。有两种可选项：设置锁定或什么也不做 （默认状态下为该项）。

  

图 15.7　断开连接时的询问对话框 

若选择设置锁定， FDT 就会按要求进行锁定和解锁 （如 1 所述）。若选择什么也不做， FDT 就会忽略

所有的锁定设置，而直接跳到断开操作 （如 3 所述）。若此时点击 “Cancel”，则会同时取消对话框和

断开操作。

3. 什么也不做

FDT 将不发出任何锁定或解锁的命令，芯片将保持当前的锁定状态，断开操作将如常进行。
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第 16 章 识别码的写入（Unique Code Programming）

识别码写入是 FDT 的一种功能，可将自增代码写入闪存区。该功能主要用于进行序列编号，编号过程可

通过用户指定的外部文件来控制。

在通常的 FDT 工程模式中，可通过工具菜单中的 [Tools → Unique Code Programming…] 来允许、禁止

或配置识别码的写入。

在 Simple Interface Mode （简化界面模式）中，通过 [Options → Unique Code Programming…] 菜单可找

到与上述相同的对话框。在 Basic Mode （基本模式）中，不能进行识别码的写入。

将识别码的写入设定为有效状态以后， FDT 会在每次的写入操作中添加一个指定的序列号，并在下一次

写入操作时自动迭代到下一个号码。在所有读验证和校验和操作中都会考虑该序列号。另外，还可将整个过程

写入脚本语言中进行自动控制。

当操作执行到外部文件的末尾 （或文件内所指定的最终值）时， FDT 会在工程关闭和重启 （“Restart on 
Session （会话时重启）”模式时）或者手动复位索引 （“User Specified （用户指定）”模式时）之前暂停写入

操作。

识别码写入功能的当前状态显示于状态栏中。

 

图 16.1　识别码状态显示栏

当该功能设定为有效状态时，此处显示写入的前一个代码以及下一个使用值。当该功能设定为无效状态

时，此处为空白显示。
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16.1 配置对话框

 

图 16.2　识别码配置对话框

16.1.1 Enale/Disable （有效 / 无效）

这两个单选钮用于控制 FDT 是否使用识别码功能。如果该功能没有设置为有效状态，则其他设定都无效。

16.1.2 File Location （文件位置）

从编辑区指定文件内的列表中读取识别码。可通过 “Browse （浏览） ...”按钮手动寻找文件，也可将文

件直接施放至对话框。 FDT 不指定文件扩展名，但文件必须为文本格式。关于文件结构的详细情况请参照

[16.2]。

16.1.3 File Start Point （文件起始点）

在该处可通过下述选项选定 FDT 从指定的代码文件中读取数据的方式：

16.1.3.1 Restart on Session （会话时重启）

FDT 从 （代码文件中）列表的开头开始读取数据，并在读取操作进行到末尾之前连续对列表中的每个值

进行迭代。当 FDT 重新启动时又会从列表的开头重新开始读取操作。

16.1.3.2 Continue From Previous/User Specified （接上次的操作 / 用户指定）

通过该项可使用代码文件列表中值的子集。

Next Index （下一个索引）：该项表示作为识别码写入的下一个点， FDT 应该使用的索引值 （内含的）。

FDT 将查找与此索引相关的值并将结果显示于编辑区下方。如果要使 FDT 从代码文件列表的开头自动开始读

取，需将此处留为空白 （编辑区下方会显示 “Start-Of-File （文件开头）”）。在正常写入以后，该号码会被迭
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代到代码文件列表中的下一个索引。更新后的这个起始点将被保存在 FDT 的 Session （会话）中。

End Index （最终索引）：该项表示作为列表迭代的最终点， FDT 应该使用的索引值（内含的）。 FDT 将

查找与此索引相关的值并将结果显示于编辑区下方。如果要使 FDT 自动读到代码文件列表的末尾，需将此处

留为空白 （编辑区下方会显示 “End-Of-File （文件末尾）”）。

16.1.4 Data Overwrite （数据的改写）

通过该项，FDT 可在代码文件中指定的存储位置插入识别码。如果在该处已经存在数据，那么对于即将写

入的数据文件，以下两个选项可控制 FDT 的操作：

Continue （继续）：识别码将被写入编程数据的指定位置，并且该处所有既存的内容将被改写。

Abort （中止）：在检测到冲突时，写入操作将被中止。

16.2 文件格式

在 FDT 中要求识别码文件是基于文本格式的，并且要有一个详细说明识别码写入位置和写入方式的标头

段 （Header Section），而且最后要有一个显示索引值和识别码值的双列表。数据可以用制表符 （Tab）、空格

或逗号隔开。以 “//”开头的行将被作为注释行而忽略。另外，所有空白行也会被忽略。

16.2.1 标头段（Header Section）

16.2.2 代码段（Code Section）
该识别码列表的标题行为 “Index”和 “Data”，其余行的内容为代码索引和代码值，具体如下所示：

index data
000001 ACD24000001
000002 ABD24000002
000003 ....
.... ....

【注】 索引不需要从 0 开始，但要求为 10 进制的递增数。

format （格式） 该项说明 FDT 应该如何解释存储在列表中的识别码值。有效值为：

ASCII (codes 0x20 to 0x7E)
Hex

area （区域） 该项表示 FDT 应该在哪个“Memory Area （存储区）”添加识别码 （没有指

定时默认为用户闪存区）。

address （地址） 该项表示在指定的存储区内 FDT 应在哪个地址写入识别码。

size （长度） 该值是以十进制数表示的写入指定地址的字节长度（例如：对于 ASCII 格式为

“one file character = one byte （1 个文件字 =1 个字节）”，但对于 16 进制值

为“one file character = one nibble （1 个文件字 = 半个字节）”）
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16.2.3 示例文件（Eample File）
// config info

format HEX

area User Flash

address 0xF000

size 6

// code list

index data

000001 ABCD24000001

000002 ABCD24000002

000003 ABCD24000003

000004 ABCD24000004

000005 ABCD24000005
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第 17 章 升级到 FDT4.01

FDT4.01 的安装不会影响其他版本 FDT 的安装。一旦安装 FDT4.01， USB 驱动程序就会升级，拥有存取

权限的用户名和密码将会共用，不过只有这些是共享成分。 FDT 的各个版本安装各自的核心程序，并保持各

自的设定。 FDT4.01 的安装还会更新某些旧版 FDT 中提供技术支持的电子邮件地址。双击带有 FDT 扩展名的

文件时，最新安装的 FDT 版本将作为登录的应用程序打开这些文件。因此，在 Windows® Explorer 上双击文件

时，将使用最新安装的版本。

如果已经使用过 FDT，要把既存的工程 （Project）转移到 FDT4.01 时，需要注意以下几点：

如果工程对由旧版 FDT 提供的核心程序 ( 或基于旧版的自定义核心程序 ) 有具体要求，可在 “Other”选

项中选择 “User Defined”核心程序。不过，在可能的情况下，还是推荐用户使用最新的核心程序。使用旧版

FDT，可能会导致功能下降 （例如， FDT3.1 以后的核心程序包含了 FDT 计算异步串行错误率所需要的信息，

但使用 FDT3.1 以前的版本提供的核心程序时，不能使用该功能）。

对于使用了 FDT3.0 以前的 FDT 版本的工程，需要用 Wizard 创建新的工作空间和工程。这样可保证按照

FDT 的需求创建新的设定，而且通过使用 Project Wizard，该处理将非常迅速。因为在 FDT3.0 以后，强化了功

能，所以 3.0 以前的 FDT 版本使用的工作空间文件没有与 FDT4.01 的兼容性。

能够用 FDT4.01 打开 FDT 以前版本 （FDT3.0 以后）的工作空间，但升级后不要再在原版本中打开。此

时，可忽略与 “SyntaxHighlightingFile.dbs”有关的错误。打开旧格式的工作空间，可能会影响工作栏的位置

和状态。升级工程后，需要设定文件的扩展名和启动程序间的链接，才能双击打开选定的文件并进行下载。

新型的 device image （不是基于 .fpr，而是基于 .ddi），意味着 FDT 将要对旧版本的工程 image 进行再创

建。旧的 image 不会被删除，但今后会添加和使用新的 image。如果需要在下载时使用旧的 image，只需右键

单击工作空间窗口的项目，并从右键菜单中选择 “Download File”。

FDT4.01 具有以下新功能：

· 具有识别码写入功能，可进行序列编号等

· 可使用调试接口和 E8a 对 H8-Tiny / H8-SLP 进行编程 （仅限于某些芯片）

· 在上传和选择时，可显示校验和
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