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e
2
 studio IDE 

Usage of Memory Debug Feature  

Introduction 

The Memory view in the debug perspective enables user to monitor and modify user memory of interest.  

 

This application note focuses on the usage of memory view demonstrating ‘Image’ and ‘Hex Integer’ data formats, with 

Renesas Starter Kit for RX111 CPU board (referred as RX111 CPU Board) and E1 emulator under the e2 studio IDE.   

 

e2 studio V.2.2.0.13 

C/C++ Compiler for Renesas RX Family: V2.01.00 
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1. Overview 

The “Memory” includes two (2) panes: the Memory Monitors pane and the Memory Rendering pane. The monitor 

represents a section of memory specified by its location called “base address”. The memory data in each Memory 

Monitor represents in different “Memory Renderings”, which are the pre-defined data format (e.g.: Hew Integer, Signed 

Integer, Unsigned Integer, Floating Points, ASCII, Image and etc). ‘Hex Integer’ is displayed automatically as the 

default format when global variable is added in Memory Monitor pane. In common practice, to monitor a variable, it is 

always useful to monitor it by the label (e.g. variable name prefix with ‘&’), and not by address. 

As shown in Figure 1, the Memory Rendering pane also can be configured to display the renderings simultaneously by 

using the toolbar option: Toggle spilt pane. Besides, the Memory view provides other toolbar options, e.g. New 

Memory View, Toggle Memory Monitor Pane, Real-time Refresh, Import/export and etc.  

 

 

 

 

Figure 1 Memory View 

 

2. Usage of Memory View 

Using RX111 CPU Board as an example, targets for RX111 MCU device (part number: R51115AxFM), the sections 

below explain the usage of Memory by selecting ‘Image’ and ‘Hex integer’ formats.  

 

 

 

 

Figure 2 Assign Global Variable in “flashled.c” 
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It is a pre-requisite to prepare a ‘Tutorial’ project with a graphical image targets for the RX111 CPU Board. 

1) Convert image file (.bmp) into char array named ‘rawData[5358]’ using image converter software.  

Refer to the “Renesas Starter Kit for RX111: Quick Start Guide” to prepare for a sample project workspace: 

2) Install RSK software from the DVD. Invoke e2 studio IDE to import sample workspace “Tutorial” (located at 

the root project directory: ‘C:\Renesas\Workspace\RSK\RSKRX111’). 

3) Copy array data “rawData[5358]” to “flashled.c” (as shown in Figure 2). Then, assign array data “rawData” 

and local variable “ulLed_Delay” as global variables in the “flashled.c”. 

4) Click [Project] → [Build All] to build the project, and then click [Run] → [Debug configuration] to connect 

E1 emulator to the RX111 target board. 

 

2.1 Usage of ‘Image’ Memory Type 

The ‘Image’ Memory Rendering represents the memory content in graphical image format in the Memory view. It 

supports the following formats:  

 Windows BMP, GIF, ICO, JPEG, PNG, TIFF, OS/2 BMP 

 

 

 

 

Figure 3 Add Memory Monitor - &rawData 

 

To monitor global variable “rawData” using Image format: 

1) Click [Windows] → [Show View] → [Memory] or icon  to open the Memory view. 

2) In ‘Memory Monitor’ pane, click icon  to add monitor: &rawData or address: 0x800 and click [OK] to 

proceed. 
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Figure 4 Add Rendering(s) – ‘Image’ Type 

 

To choose an image format to present “&rawData”: 

3) Click ‘New Renderings…’ in Memory Rendering pane.  Select ‘Image’ and click ‘Add Rendering(s)’ to 

display the graphical image – ‘Renesas’ logo. 

 

 

 
 

Figure 5 Message Shown on Image Rendering. 
 

At first, due to uninitialized section, “&rawData” memory rendering pane shows the “Unsupported or unrecognized 

format” message.  
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Figure 6 Memory Rendering Pane – ‘Renesas’ Logo 
 

4) Click  to execute a section initialization routine (ie. function “_INITSCT()”) for sections initialization to 

reflect the memory monitor “&rawData” in the Memory Rendering pane. As shown in Figure 6, the ‘Renesas’ 

logo is displayed in Memory Rendering pane.  

 

Typically, if the content of memory at the specified start address is not recognized as a valid image in any of the 

supported image formats (e.g. Windows BMP, GIF, ICO, JPEG, PNG, TIFF, OS/W BMP), an error message 

(similar to Figure 5) is shown within the image rendering. 

 

 

2.2 Usage of ‘Hex Integer’ Memory Type 

The ‘Hex Integer’ (default) Memory Rendering represents the memory content in Hexadecimal format in Memory view.  

 

 

 

 

Figure 7 Add Memory Monitor – &ulLed_Delay 
 

To monitor global variable “ulLed_Delay” using ‘Hex Integer’ format: 

1) Click [Windows] → [Show View] → [Memory] or icon  to open the Memory view. 

2) In Memory Monitor pane, click icon  to add monitor: &ulLed_Delay or address: 0x2100 and click [OK] 

to proceed. 

 

Note:  

The differences between “Hex Integer” and “Hex” are 

“Hex integer”: Always set as big endian, regardless of debugger endian setting 

“Hex”: To display with the debugger endian setting  
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Figure 8 Memory Rendering Pane – ‘Hex Integer’ Type (when Program halts) 
 

The ‘Hex Integer’ Rendering (by default) is displayed automatically when the Memory Monitor is created. The address 

shown for “&ulLed_Delay” is 0x2100 as in Figure 8. 

 

 

 
 

Figure 9 Memory Rendering Pane – ‘Real-time Refresh’ (when Program is running) 
 

To observe the updates for the memory monitor: “&ulLed_Delay” while the program is running: 

3) Click icon  to enable the ‘Real-time Refresh’ and click icon  to execute the program. 

 

The value of address ‘0x2100’ keeps changing until icon  is pressed or it reaches the maximum value. 

 

When debugging starts, the text shows in red which reflect a value change.  
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Figure 10 References - ‘Real-time Refresh’ Dialog 
 

The Memory view allows user to configure the expression refresh interval via the ‘Real-time Refresh’ Preferences. By 

default, ‘Expression refresh interval (ms)’ is set as 200 while ‘Image refresh interval (ms)’ is set as 500. Before 

executed, user must ensure the ‘Real-time Refresh’ button is enabled.  

4) Click the downward arrow  to select ‘Real-time Refresh Preferences…’ to open the ‘Preferences’ dialog 

box.  

5) Type ‘500’ in ‘Expression refresh interval (ms)’, click [Apply] and [OK] button to proceed. 

6) Click icon  to perform the program. By monitoring the value for “&ulLed_Delay”, the running speed 

becomes slower. 

 

To modify the memory monitor, the program must be suspended.  
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Figure 11 Memory View – Modify Memory Address 
 

7) Click icon  to suspend the program, and then double-click the specified memory address to edit the value.  

8) Click icon  to run the program, the value starts to execute after ‘0000632D’. 

 

 

 

3. Summary 

 

 The Memory view supports different Memory Rendering types (e.g. ‘Image’ and ‘Hex Integer’) for user to 

monitor and edit variable at the specific memory location.  

 

 ‘Hex Integer’ is the default rendering format once the memory monitor is created. To add memory monitors, it 

is a pre-requisite to assign the specified local variables as global variables in program file. 

 

 By using the ‘Real-time Refresh’ feature (e.g. ‘Hex Integer’ format), user can set refresh interval and track the 

changes for the memory monitors. 

 

 The Memory display the graphic image in ‘Image’ rendering format after the section initialization (e.g. 

function “_INITISCT();”).  
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Website and Support  

Renesas Electronics Website 

http://www.renesas.com/ 
 
Inquiries 

http://www.renesas.com/contact/ 
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General Precautions in the Handling of MPU/MCU Products 

 
The following usage notes are applicable to all MPU/MCU products from Renesas. For detailed usage notes on the 

products covered by this document, refer to the relevant sections of the document as well as any technical updates that 

have been issued for the products. 

 

1.  Handling of Unused Pins 

Handle unused pins in accordance with the directions given under Handling of Unused Pins in the 

manual. 

 The input pins of CMOS products are generally in the high-impedance state. In operation with an 

unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of LSI, an 

associated shoot-through current flows internally, and malfunctions occur due to the false 

recognition of the pin state as an input signal become possible. Unused pins should be handled as 

described under Handling of Unused Pins in the manual. 

2.  Processing at Power-on 

The state of the product is undefined at the moment when power is supplied. 

 The states of internal circuits in the LSI are indeterminate and the states of register settings and 

pins are undefined at the moment when power is supplied. 

In a finished product where the reset signal is applied to the external reset pin, the states of pins 

are not guaranteed from the moment when power is supplied until the reset process is completed. 

In a similar way, the states of pins in a product that is reset by an on-chip power-on reset function 

are not guaranteed from the moment when power is supplied until the power reaches the level at 

which resetting has been specified. 

3.  Prohibition of Access to Reserved Addresses 

Access to reserved addresses is prohibited. 

 The reserved addresses are provided for the possible future expansion of functions. Do not access 

these addresses; the correct operation of LSI is not guaranteed if they are accessed. 

4.  Clock Signals 

After applying a reset, only release the reset line after the operating clock signal has become stable. 

When switching the clock signal during program execution, wait until the target clock signal has 

stabilized. 

 When the clock signal is generated with an external resonator (or from an external oscillator) 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. 

Moreover, when switching to a clock signal produced with an external resonator (or by an external 

oscillator) while program execution is in progress, wait until the target clock signal is stable. 

5.  Differences between Products 

Before changing from one product to another, i.e. to a product with a different part number, confirm 

that the change will not lead to problems. 

 The characteristics of an MPU or MCU in the same group but having a different part number may 

differ in terms of the internal memory capacity, layout pattern, and other factors, which can affect 

the ranges of electrical characteristics, such as characteristic values, operating margins, immunity 

to noise, and amount of radiated noise. When changing to a product with a different part number, 

implement a system-evaluation test for the given product. 

 



 

 

 

Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples.  You are fully responsible for

the incorporation of these circuits, software, and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the

use of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free.  Renesas Electronics

assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or

technical information described in this document.  No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or

others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.  Renesas Electronics assumes no responsibility for any losses incurred by you or

third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality".  The recommended applications for each Renesas Electronics product depends on

the product's quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; and industrial robots etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical

implantations etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.).  You must check the quality grade of each Renesas Electronics product before using it

in a particular application.  You may not use any Renesas Electronics product for any application for which it is not intended.  Renesas Electronics shall not be in any way liable for any damages or losses

incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage

range, movement power voltage range, heat radiation characteristics, installation and other product characteristics.  Renesas Electronics shall have no liability for malfunctions or damages arising out of the

use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and

malfunctions under certain use conditions.  Further, Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to guard them against the

possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because the evaluation of microcomputer software alone is very difficult,

please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product.  Please use Renesas Electronics

products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive.  Renesas Electronics assumes

no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or

regulations.  You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the

development of weapons of mass destruction.  When exporting the Renesas Electronics products or technology described in this document, you should comply with the applicable export control laws and

regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify such third party in advance of the

contents and conditions set forth in this document, Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics

products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

http://www.renesas.com

Refer to "http://www.renesas.com/" for the latest and detailed information.
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