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RX72M Group  
EtherCAT EoE Sample Program  
Introduction  
This document explains Sample Program setup procedures for EtherCAT® slave functionalities with the 
adapted EtherCAT Stack Code for Renesas RX72M platform. This describes steps to confirm slave behavior 
and stack features using TwinCAT®Master Configuration tool. 

 
 
Target Device  
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1. Overview 
This document describes the procedure for testing the EtherCATof Ethernet over EtherCAT function using 
EtherCAT stack code compatible with the Renesas RX72M platform. The scope of the documentation is 
limited to explaining how to use the SSC tool for EtherCAT slave stack code generation and testing its 
behavior against TwinCAT masters and test applications. 

 
EtherCAT(Ethernet for Control Automation Technology) is an Ethernet based fieldbus system, developed by 
Beckhoff Automation. Development of EtherCAT was to apply Ethernet for automation applications (e.g., for 
motion control, I/O, sensors) requiring short data update times with low communication jitter and reduced 
hardware costs. 
 
Tools to generate EtherCAT Slave Stack Code (SSC Tool) are available to the ETG members free of charge. 
This can be downloaded from the ETG website. SSC tool can be used to generate customized stacks, 
device description files (ESI) and individual source code documentation to suit the developer’s own needs. 
 
 

1.1 Abbreviations/Definitions 
Table 1.1 Abbreviations/Definitions 

Index Abbreviations 
/Definitions Description 

1 CoE CAN application protocol over EtherCAT 
2 EEPROM Electrically Erasable Programmable Read-Only Memory 
3 ESC EtherCAT Slave Controller 
4 ESI EtherCAT Slave Information 
5 FoE File Access Over EtherCAT 
6 I2C Inter-Integrated Circuit 
7 MB Mail Box 
8 PDO Process Data Object 
9 SSC Slave Stack Code 
10 EoE Ethernet Over EtherCAT  

 
 
1.2 Reference 
Technical information about EtherCAT is available via ETG member site, and information about RX72M is 
available via Renesas. 

 
Table 1.2 Technical Inputs 

Index Technical Inputs 
1 R01UH0804xxxxx-rx72m 
2 REN_r20ut4391xxxxxx-rsk+rx72m-usermanual_MAT_20190731.pdf 
3 REN_r20ut4388xxxxxx-rsk+rx72m-qsg_MAT_20190731.pdf 

 
  

https://en.wikipedia.org/wiki/Ethernet
https://en.wikipedia.org/wiki/Automation
https://en.wikipedia.org/wiki/Technology
https://en.wikipedia.org/wiki/Fieldbus
https://en.wikipedia.org/w/index.php?title=Beckhoff&action=edit&redlink=1
https://en.wikipedia.org/wiki/Jitter
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2. Features 
EtherCAT slave stack code generated by SSC Tool provides the functionality of EtherCAT slave controller. 
 
Includes the following features: 
 ESM (EtherCAT State Machine) 
 Mailbox protocols: 

- CoE (CAN application protocol over EtherCAT) 
 

 Synchronization Modes: 
- Free Run 
- Sync Manager Synchronization 
- DC Synchronization 
 

 Ethernet over EtherCAT Profile: 
- M3S-T4-Tiny 

 

 
 

EtherCAT is a registered trademark and patented technology, licensed by Beckhoff Automation GmbH, 
Germany. 
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3. Software structure 
Table 3. shows the software structure of the sample program.  

The sample program consists of the EtherCAT sample part and the TCP/IP sample part.  

EoE enables Ethernet-based services and protocols to be used by encapsulating Ethernet communication 
frames in EtherCAT communication data.  

The fragmentation of the Ethernet communication frame during assembly and transmission of the segmented 
Ethernet communication frame at the time of reception due to the encapsulation of the communication data 
is implemented as the EoE service of the SSC.  

The virtual Ethernet driver replaces the Ethernet driver on the physical layer of the normal TCP/IP stack and 
is responsible for passing the Ethernet communication frame between the TCP/IP protocol stack and the 
EoE service.  

The TCP/IP sample has the function of an echo server and echoes back received TCP or UDP packets. 

The EtherCAT sample has the function of an I/O controller, and it is possible to check input/output control 
from the master with the LEDs and DIP SW on the RSK board. 

 

Table 3. Software structure 
 
Layer / Sample EtherCAT Sample TCP/IP Sample 

Application layer I/O Controller* TCP Echo Server* 

Protocol stack layer 
EtherCAT Slave Stack (SSC)**  M3S-T4-Tiny 
including EoE Service 

Wrapper to driver layer EtherCAT SSC port M3S-T4-Tiny Ethernet driver  
Driver layer EtherCAT Slave Controller driver Virtual Ethernet* 

 
*:   provided by sample project 
**: provided by Beckhoff, patched by sample project 
      unmarked: provided by FIT 
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4. Operating Environment 
The sample programs described in this manual run in the following environment. 

 

4.1 Testing Environment 
 

Table 4.1  Testing environment  

Supported MCU RX72M Group 
Evaluation board Renesas Starter Kit+ for RX72M (product type name: RTK5572MNxCxxxxxBJ) 

RX72M evaluation board TS-RX72M-COM from Tessera Technology 
RX72M CPU Card with RDC-IC 

Integrated development 
environment (IDE) 

e2 studio 2024-07 from Renesas Electronics 

Cross tool C/C++ Compiler Package for RX Family V3.06.00 from Renesas Electronics 
Emulator GCC for Renesas RX 8.3.0.202405 

 
 

4.2 FIT Module Configuration 
The sample program covered in this application note is configured with the use of the following FIT modules. 

 

Table 4-1   FIT Module Configuration 

Type Module Name FIT Module Name Rev. 
Board Support 
Package 

Board support package (BSP) r_bsp 7.50 

Device Driver Compare-match timer (CMT) r_cmt_rx 5.60 
Middleware M3S-T4-Tiny r_t4_rx 2.10 
Device Driver EtherCAT r_ecat_rx 1.31 

 
 

4.3 Support Projects 
Projects covered in this application note are listed below. 
 

Table 4-2   List of Projects 

MCU Evaluation Board Name Project Name 
RX72M RSK board ecat_eoe_demo_comrx72m 

Communications board ecat_eoe_demo_cpurx72m 
CPU card ecat_eoe_demo_rskrx72m 

 
 

The following sections use the RX72M communications board project as an example. If you are using an 
RSK board or CPU card project, please modify the communications board statements as necessary. 
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5. Board Setting and Connection 
5.1 Setting up and connecting the Communication board 
For detailed information on the evaluation board, refer to "RX72M Communication Board Hardware Manual". 

 

Figure 5.1  RX72M Communication board configuration 

 
 
5.1.1 Communication board setting 
Before powering on the evaluation board, make jumper settings and connect each cable. Configure the 
configuration mode of JTAG. Usually, it is used at 2-3 short of jumper pin. To use the hot plug-in function, 
change it to 1-2 short and use it. 

For more information about the position of the relevant parts, refer to the [RX72M communication board 
hardware manual]. 

 

Figure 5.2 Jumper pin setting 
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5.1.2 Power supply selection 
This board can supply power for RX 72 M by inputting DC 5 V by DC Jack or USB. select either. 

 
5.1.3 Connection of communication board 
Connect each cable as follows. 
(1) Connect Ethernet cable (category 5 or higher recommended) to Ether port (CN 2 IN). 
(2) Connect JTAG connector of ICE to JTAG Connector, USB connection with host computer. 
(3) Connect DC 5 V from DC Jack or USB and turn on the power. 
 
 

5.2 Setting up and connecting the RSK board 
For detailed information on the evaluation board, refer to " Renesas Starter Kit + for RX72M Board User's 
Manual".( REN_r20ut4391jg0100-rsk+rx72m-usermanual_MAT_20190731.pdf) 

 

Figure 5.3  RX72M RSK board configuration 

 
5.2.1 Power supply selection 
This board can supply power for RX72M by inputting DC 5 V by DC Jack. 
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5.2.2 Connection of RSK board 
Connect each cable as follows. 
(1) Connect Ethernet cable (category 5 or higher recommended) to Ether port (ETHERNET0). 
(2) Connect JTAG connector of ICE to JTAG Connector, USB connection with host computer. 
(3) Connect DC 5 V from DC Jack and turn on the power. 
 
 

5.3 Setting up and connecting the CPU Card 
For detailed information on this board, refer to the "RX72M CPU Card with RDC-IC User's Manual" 
(R12UZ0098EJ0100). 

 

Figure 5.4  RX72M CPU Card configuration 

 
 
5.3.1 CPU Card setting 
Set the jumper pins before powering on the CPU Card. 
Using E2OB           : Short the Debugger switching Jumper pin. 
Setting the device ID: Install the jumper pins (JP2,3) according to the ID. Equivalent to Bit "1" in short. 
 
5.3.2 Power supply selection 
CPU Card does not have DC Jack, input DC5V from USB connector. 
 
5.3.3 Connection of communication board 
Connect each cable as follows. 
(1) Connect an Ethernet cable (Category 5 or higher is recommended) to Ether port (CN8 IN). 
(2) Connect the common USB connector for the emulator and power supply to the host computer. 
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5.4 Generating the Slave Stack Code 
SSC Tool is used for generating the slave stack code. 
Note). Replace the folder name in the following description according to the tool to be used. 
 
1. Start the SSC Tool from the Windows Start menu. 

 
 
 
2. Select File > Open. 

 
 
 
3. Select and double-click the following file, 

“FITDemos\ecat_eoe_demo_xxxrx72m\utilities\ssc_config\ RX72M EtherCAT EoE.esp” 
 
Note). xxx is “com” or “rsk” or “cpu.” 

 
 
4. After clicking, the following window opens. 
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5. Select Project > Create new Slave Files. 

 
 
 
6. Click the [Start] button to start creating the EtherCAT Slave Stack Code. 

 
 
 
7. When a message “New file created successfully” appears, the creation processing is completed, and the 

source files are located in the following folder. 
“FITDemos\ecat_eoe_demo_xxxrx72m\utilities\ssc_config\ssc_config” 
 
Note). xxx is “com” or “rsk” or “cpu.” 
 

 
 
Note), If an error occurs during generation, uncheck "Create device description" in [Tool]-> [Option]->  

[Create Files] of the SSC tool. 



RX72M Group EtherCAT EoE Sample Program 

R01AN7520EJ0100  Rev.1.00  Page 12 of 29 
Oct.15.24 

 
8. Right-click on the apply_patch.bat file and select [Run as an administrator] → [Yes].                            

The patch file contains modifications to make the SSC source file suitable for the RX72M. 
“FITDemos\ecat_eoe_demo_xxxrx72m\utilities\patch\apply_patch.bat” 
 
Note). xxx is “rsk” or “cpu.” 

 

 
After execution of the patch, the modified source file is stored in the following folder. 

 
“FITDemos\ecat_eoe_demo_xxxrx72m\project\src\application\ecat\beckhoff” 

 
 

Note). If the patch command is not installed on your PC, you will need to install it (see Appendix A). If it 
is already installed, skip this step. 
 

Note). xxx is “com” or “rsk” or “cpu.” 
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6. Setting up a TwinCAT3 
6.1 Copying the ESI Files 
Before starting TwinCAT, copy the ESI files that are included in the release folder to TwinCAT destination 
“\TwinCAT\3.x\Config\IO\EtherCAT” 
 
ESI file for current release available at, 
“FITDemos\ecat_eoe_demo_xxxrx72m\utilities\esi\ESI\RX72M EtherCAT EoE.xml” 
 

Note). xxx is “com” or “rsk” or “cpu.” 
 
 

6.2 Add Driver  
Add the Ether driver for TwinCAT. (First time only) 
From the start menu, select [TwinCAT3] → [Show Realtime Ethernet Compatible Devise]. 
 
Select the connected Ether port from the communication ports and install it. 

 

 
Note). Depending on the network card installed in your PC, 

it may not be "Installed and ready to use device (realtime capable)" but 
it may be "Installed and ready to use device (for demo use only)". 
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7. Adding the FIT Module to Your Project 
By adding the EtherCAT FIT module to e2 studio, it can be used with Smart Configurator. 
Here is how to add it manually. 
Copy the EtherCAT FIT module to the folder where the FIT module of e2 studio is saved. 
 
Check the location of the FIT module in e2 studio. 
[Window]→[Preferences]→The Preferences window opens.  
[Renesas] →[Module Download]→[Location (RX)] 
 
“Location (RX):” is the folder where the FIT module of e2 studio is saved. 

 
 

EtherCAT FIT module is stored in the FITModules folder of the sample program. 
Copy the files in the “r01an7520xx0100-rx72m-ecat-eoe\FITModules” folder to the location where the FIT 
modules are saved. 

r_ecat_rx_vN.NN.xml 
 
r_ecat_rx_vN.NN.zip 
 
r_ecat_rx_vN.NN_extend.mdf 
 

N.NN is numerical values that represent the version. 
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8. Execution of EtherCAT EoE Sample Program 
This section describes the instructions for communicating with the Modbus sample application. 
Refer to section 4 ,Operating Environment and section 5, Board Setting and Connection in advance to 
complete tool installation and hardware connection. 
 
1. Import the sample project after starting the e2 studio by selecting  

File > Import > Existing Projects into Workspace.  
Click Select root directory and select “01an7520xx0100-rx72m-ecat-eoe\FITDemos 
\ecat_eoe_demo_xxxrx72m” folder. 
 
Note). xxx is “rsk” or “cpu.” 
 

 
 
 
2. Open "ecat_eoe_demo_xxxrx72m.scfg" in the " ecat_eoe_demo_xxxrx72m " project 

 
Note). xxx is “com” or “rsk” or “cpu.” 
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3. Open the Components tab. 

Make sure all components are enabled and then run code generation. 

  
 
 
4. Execute the build. 

At this time, confirm that there are no build errors. 

 
 
 
Note). If build error occurs during build, please correct the following. 
 
Error:  

 
 
Code location to be modified: 
“ecat_eoe_demo_xxxrx72m\src\smc_gen\r_con fig\r_bsp_config.h” 
 
#define BSP_CFG_EXPANSION_RAM_ENABLE  (0) →  (1) 
 
 
Note). Component dependencies give errors, but no issues 
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5. Download the application and run the debugger. 

After connecting the board and J-Link, start debugging using the following procedure. 
In Project Explorer view, right-click the node of project to be debugged and select  
Debug As > Debug Configurations. 

   
 
 
6. Program download. 

Select Renesas GDB Hardware Debugging > ecat_eoe_demo_comrx72m, then click Debug. 
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The following dialog appears, switch to the debug screen. 

  
 
 
7. Program starts. 

Click the Resume button. 
When debugging starts, the program is interrupted at main.c;  
Click the Resume button again to run the program. 
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9. Evaluation of EoE 
This section describes the steps to use the evaluation tool to evaluate the sample program. 

9.1 IP Address Setting 
In order to operate the EoE sample program, it is necessary to set the IP address of the EtherCAT master 
and the EtherCAT slave as fixed IP addresses. 

Set the IP address of the EtherCAT slave in the network configuration file of the TCP/IP stack of the sample 
program at the same time. 
 
 
1. Enable EtherCAT and TCP/IP in the network connection settings as below figure.  

  
 
 
2. Configure the host PC network connection as below figure. 

  
 
 
3. When changing the IP address, etc, change it using the FIT T4 settings. 
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9.2 Connecting to TwinCAT3 
Start TwinCAT3 by using the procedure described below, 
From the start menu, select [Beckhoff] → [TwinCAT3] → [TwinCAT XAE]. 
 
After the program is started, by selecting [File] → [New] → [Project], create a new project of the TwinCAT 
XAE Project type. The subsequent procedure is described below. 
 
9.2.1 Scanning I/O Devices 
1. Under solution explorer -> I/O -> Devices, select ‘Scan’ as in Figure below. 

  
 
 
2. EtherCAT port will be displayed as below. Select and press OK. 

 

 
Note). If a valid slave exists in the network, TwinCAT will display the candidate with a checkbox. 
 
 



RX72M Group EtherCAT EoE Sample Program 

R01AN7520EJ0100  Rev.1.00  Page 21 of 29 
Oct.15.24 

 
3. Start scanning the device. 

 

 
 

4. If the detected device is "Box1 (PFFFFFFFF)" as shown in the figure, ESI file has not downloaded,  
so, proceed without Free Run. 

If the detected device shows desired ESI filename like "Box1 (Renasas EtherCAT xxxx)", select Free run. 
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9.2.2 Updating EEPROM Data 
If the data of another application has already been written to the EEPROM, replace the data. 
The following shows the procedure for replacing the data on the EEPROM: 
 
1. Double-click [Box 1] to display a panel on the right side of the window. 

 
2. Select the [EtherCAT] tab. 
 
3. Click the [Advanced Setting] button. 

 
 
 
4. Select [ESC Access] → [EEPROM] → [Hex Editor]. 
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5. Select [Download from List] → Select ESI File 
“FITDemos\ecat_eoe_demo_xxxrx72m\utilities\esi\ RX72M EtherCAT EoE.xml” 

 
 
6. OK and Download. 

 

 
 
7. Apply the ESL file settings.  

Select the device and remove it. 
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8. Scan the device again.               

If the desired ESI file is displayed, it is correct operation. 

 
 
 
9.2.3 TwinCAT3 setting for EoE 
Set TwinCAT3 for EOE operation.  
 

1. Double-click [Device], and Click [EtherCAT tab] → [Advanced Settings] button.  

 

 
 

2. Check the [EoE Support] items→[Virtual Ethernet Switch Enable] and [Connect TCP/IP Stack]. 
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3. Set the slave information.               

Double-click [Renesas EtherCAT RZ/N2 EoE], and Click [EtherCAT tab] → [Advanced Settings]  

 

 
 

4. Select [Mailbox] →[EoE]                   
Select IP Port and set the following:        
 IP Address: 192.168.10.100         
 Subnet Mask: 255.255.255.0        
 Default Gateway: 192.168.10.1 
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5. Check TCP/IP operation. Start the command prompt and execute ping 192.168.10.100, If get a 

response, connection is complete. 

 

 
 
9.2.4 Checking operation with echo server 
Check the operation of the TCP echo server.  

Start SockV 
Select socket type → [TCPClient] Enter the following settings      
Host IP: 192.168.10.100          
Host Port: Enter 1024           
and click the [Create] button. TCP client socket will appear under the console.  

 
Open the send instruction console. 
Select [Communication] → Check the [send instruction dialog] ,Open the send instruction window.   
Enter text in the main window (upper area) and click the 1-line send button in the send instruction window, 
the same text you entered will be displayed in the sub-window (lower area). 

  

 
 
  

2 

1 

3 
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10. Appendix 
10.1 Appendix A : How to install patch  
This section describes how to install patch in MinGW. 
 
1. Download “mingw-get-setup.exe” from the following URL. 
 

https://osdn.net/projects/mingw/downloads/68260/mingw-get-setup.exe/ 
 
 
2. Execute “mingw-get-setup.exe”, install “Mingw-installation-manager” according to the dialog. 
 
 
3. If It’s completed and the Mingw-installation-manager window is displayed, select “Basic Setup” in the left 

window,  right-click on “msys-base-bin” in the right window, and select “Mark for Installation”. 

  
 
 
4. Select “All Packages” in the left window,  right-click on “msys-patch-bin” in the right window, and select 

“Mark for Installation”. 

  
 
  

https://osdn.net/projects/mingw/downloads/68260/mingw-get-setup.exe/
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5. Select “Apply Changes” in “Installation” in the above menubar. 

  
 
 
6. “Schedule of Pending Actions” window is displayed, click “Apply” button. 
 
 
7. If “All changes were applied successfully; you may now clone this dialogue.” is displayed, Installing 

patch.exe is succeeded. 
 
 
8. Register the path to the installed patch.exe into system environment variables. 

After registering, reboot your PC. 
 
 
9. Start Command Prompt, enter “where patch”. 

If the path to the installed patch.exe is displayed, there are no problem. 
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General Precautions in the Handling of Microprocessing Unit and Microcontroller 
Unit Products 
The following usage notes are applicable to all Microprocessing unit and Microcontroller unit products from Renesas. For detailed usage notes on the 
products covered by this document, refer to the relevant sections of the document as well as any technical updates that have been issued for the products. 

1. Precaution against Electrostatic Discharge (ESD) 

A strong electrical field, when exposed to a CMOS device, can cause destruction of the gate oxide and ultimately degrade the device operation. Steps 

must be taken to stop the generation of static electricity as much as possible, and quickly dissipate it when it occurs. Environmental control must be 

adequate. When it is dry, a humidifier should be used. This is recommended to avoid using insulators that can easily build up static electricity. 

Semiconductor devices must be stored and transported in an anti-static container, static shielding bag or conductive material. All test and 

measurement tools including work benches and floors must be grounded. The operator must also be grounded using a wrist strap. Semiconductor 

devices must not be touched with bare hands. Similar precautions must be taken for printed circuit boards with mounted semiconductor devices. 
2. Processing at power-on 

The state of the product is undefined at the time when power is supplied. The states of internal circuits in the LSI are indeterminate and the states of 

register settings and pins are undefined at the time when power is supplied. In a finished product where the reset signal is applied to the external reset 

pin, the states of pins are not guaranteed from the time when power is supplied until the reset process is completed. In a similar way, the states of pins 

in a product that is reset by an on-chip power-on reset function are not guaranteed from the time when power is supplied until the power reaches the 

level at which resetting is specified. 
3. Input of signal during power-off state 

Do not input signals or an I/O pull-up power supply while the device is powered off. The current injection that results from input of such a signal or I/O 

pull-up power supply may cause malfunction and the abnormal current that passes in the device at this time may cause degradation of internal 

elements. Follow the guideline for input signal during power-off state as described in your product documentation. 
4. Handling of unused pins 

Handle unused pins in accordance with the directions given under handling of unused pins in the manual. The input pins of CMOS products are 

generally in the high-impedance state. In operation with an unused pin in the open-circuit state, extra electromagnetic noise is induced in the vicinity of 

the LSI, an associated shoot-through current flows internally, and malfunctions occur due to the false recognition of the pin state as an input signal 

become possible. 
5. Clock signals 

After applying a reset, only release the reset line after the operating clock signal becomes stable. When switching the clock signal during program 

execution, wait until the target clock signal is stabilized. When the clock signal is generated with an external resonator or from an external oscillator 

during a reset, ensure that the reset line is only released after full stabilization of the clock signal. Additionally, when switching to a clock signal 

produced with an external resonator or by an external oscillator while program execution is in progress, wait until the target clock signal is stable. 
6. Voltage application waveform at input pin 

Waveform distortion due to input noise or a reflected wave may cause malfunction. If the input of the CMOS device stays in the area between VIL 

(Max.) and VIH (Min.) due to noise, for example, the device may malfunction. Take care to prevent chattering noise from entering the device when the 

input level is fixed, and also in the transition period when the input level passes through the area between VIL (Max.) and VIH (Min.). 
7. Prohibition of access to reserved addresses 

Access to reserved addresses is prohibited. The reserved addresses are provided for possible future expansion of functions. Do not access these 

addresses as the correct operation of the LSI is not guaranteed. 
8. Differences between products 

Before changing from one product to another, for example to a product with a different part number, confirm that the change will not lead to problems. 

The characteristics of a microprocessing unit or microcontroller unit products in the same group but having a different part number might differ in terms 

of internal memory capacity, layout pattern, and other factors, which can affect the ranges of electrical characteristics, such as characteristic values, 

operating margins, immunity to noise, and amount of radiated noise. When changing to a product with a different part number, implement a system-

evaluation test for the given product. 
 
 

 
 ・Arm® and Cortex® are registered trademarks of Arm Limited (or its subsidiaries) in the EU and/or elsewhere.  

All rights reserved.  
・Ethernet is a registered trademark of Fuji Xerox Co., Ltd. 
・IEEE is a registered trademark of the Institute of Electrical and Electronics Engineers Inc  
・EtherCAT® and TwinCAT® are registered trademark and patented technology, licensed by Beckhoff Automation 

GmbH, Germany. 
・Additionally all product names and service names in this document are a trademark or a registered trademark 
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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples. 

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall be responsible for determining what licenses are required from any third parties, and obtaining such licenses for the lawful import, export, 
manufacture, sales, utilization, distribution or other disposal of any products incorporating Renesas Electronics products, if required. 

5. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

6. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

7. No semiconductor product is absolutely secure. Notwithstanding any security measures or features that may be implemented in Renesas Electronics 
hardware or software products, Renesas Electronics shall have absolutely no liability arising out of any vulnerability or security breach, including but 
not limited to any unauthorized access to or use of a Renesas Electronics product or a system that uses a Renesas Electronics product. RENESAS 
ELECTRONICS DOES NOT WARRANT OR GUARANTEE THAT RENESAS ELECTRONICS PRODUCTS, OR ANY SYSTEMS CREATED USING 
RENESAS ELECTRONICS PRODUCTS WILL BE INVULNERABLE OR FREE FROM CORRUPTION, ATTACK, VIRUSES, INTERFERENCE, 
HACKING, DATA LOSS OR THEFT, OR OTHER SECURITY INTRUSION (“Vulnerability Issues”). RENESAS ELECTRONICS DISCLAIMS ANY AND 
ALL RESPONSIBILITY OR LIABILITY ARISING FROM OR RELATED TO ANY VULNERABILITY ISSUES. FURTHERMORE, TO THE EXTENT 
PERMITTED BY APPLICABLE LAW, RENESAS ELECTRONICS DISCLAIMS ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, WITH 
RESPECT TO THIS DOCUMENT AND ANY RELATED OR ACCOMPANYING SOFTWARE OR HARDWARE, INCLUDING BUT NOT LIMITED TO 
THE IMPLIED WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 

8. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. Renesas 
Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products outside of such 
specified ranges. 

9. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you are 
responsible for evaluating the safety of the final products or systems manufactured by you. 

10. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

11. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

12. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

13. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
14. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics.  
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