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In the box 
The following components are included in the DK-S3A7 Development Kit: 

• DK-S3A7 Main Board (DK-S3A7M)  

• DK-S3A7 Breakout Board (DK-S3A7B) 

• DK-S3A7 Segment LCD panel (DK-S3A7LCD) 

• One USB Type A to Micro-B cable 

• Multi-region 5V, 2.0A power supply 

• Quick Start Guide (this document) 

 

Overview 
This kit and the associated development tools provide the user with a platform to develop products with the Renesas Synergy™ 
S3 microcontrollers. This Quick Start Guide walks you through using the out-of-box demo then provides step-by-step directions 
to develop, configure, generate, build, download and execute the Blinky Project on the Renesas Synergy™ Software Package 
(SSP). 
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DK-S3A7 Kit 
NOTE: This Quick Start Guide is for the DK-S3A7 Development Kit. 

Prerequisites 
Required software and tools 

• Minimum workstation requirements: Microsoft® Windows® 7 with Intel® Core™ family processor running at 2.0 GHz 
or higher (or equivalent processor), 8 GB memory, 250 GB hard disk or SSD, USB 2.0, Internet connection 

• Renesas e2 studio Integrated Solution Development Environment (ISDE)  

• Renesas Synergy™ Software Package (SSP) 

Installation 

Tools are available for download at: https://synergygallery.renesas.com. 

NOTE: Version numbers of the tools may change. Following we show the versions that were available when this document was 
developed. 

Download and install the latest revision of the e2 studio (ISDE) as follows:  

NOTE: Unless informed otherwise in the following steps, use the default options. 

1) In the e2 studio Setup dialog, select at least the Renesas Synergy™ Device Family when the following dialog box 
appears. 
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2) Select the additional software GCC ARM Embedded 4.8.2014q3 when the following dialog box appears: 

 

3) Download and install the latest revision of the SSP using the default options. 

Connecting the board components 
To power the boards and connect the boards to the PC, follow these steps: 

1) Set the JTAG DIP switch 7 on S5 to ON, toward the LEDs. 
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2) Using the power supply provided with the DK-S3A7 kit, apply power through the 5V barrel connector (J1) on the Main 
Board.  

LED13 turns green with a flashing red beside it. The solid green and flashing red LED13 means that the kit cannot 
communicate with the PC on the debug port. This is normal. 

 

3) Connect the USB cable provided with the DK-S3A7 to the J-Link OB (J15) on the Main Board. 

 

4) Connect the other end of the USB cable to a USB port of the workstation. 

Now, LED13 turns green with no flashing red. This indicates a good connection. 
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Running the Out-of-Box Demo 
The Out-of-Box Demo starts by flashing the Configuration (Light Scale) and USER LEDs for about 6 seconds. It then turns on 
and off all segments of the segment LCD. This is actually a configuration test that is verifying performance of the hardware. If 
a problem is found, then USER LED 1 and 2 are red. If no problems exist, then USER LED 3 and 4 are green. 

 

After about 12 seconds, the S3 MCU starts sensing the amount of light at the Ambient Light Sensor, U105. The Demo takes the 
A/D reading and uses it to display a Light Scale on the Configuration LEDs and as a battery level and digital count on the 
segment LCD. The elapsed time of the Demo is also shown on the segment LCD. 

Do the following steps: 

1) Move a light source closer and farther from the Ambient Light Sensor and observe the LEDs and LCD values. 

2) When the light sensors output reaches or exceeds their maximum value, the MCU flashes the LCD cycles on and off 
quickly. 

Running the Blinky Project 
The Blinky Project in the SSP provides a simple example of an SSP application and familiarizes you with the e2 studio 
environment. Before running the project, ensure that the J-Link On-Board is connected to the workstation. See the steps in 
Connecting the board components on page 3. 

To run the Blinky Project, first create a Renesas Synergy Project in the e2 studio ISDE. You can then debug and run the project on 
the DK-S3A7.  

Ambient Light Sensor 

Light Scale 
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Creating the Blinky Project 

To create a project, do the following steps: 

1) Start the e2 studio ISDE by clicking Start Menu > Renesas Electronics e2studio > e2 studio. 

NOTES: 

• The e2 studio ISDE confirms the installed tool chain(s) the first time it is started after installing the toolchains.  

• The e2 studio ISDE displays the Welcome to e2 studio screen by default. If you click the [X], it does not display again. 

• If you do not have a compatible tool chain installed, see Prerequisites on page 2. 

2) If the Workspace Launcher dialog box displays, click OK.  

NOTE: If you select Use this as the default (workspace) and do not ask again, the Workspace Launcher window does not 
display. 

 

3) Start a new Synergy Project by clicking File > New > Synergy Project. 

The ISDE displays the Project Configuration (Synergy Project) dialog box: 

 

4) Enter Blinky_DK_S3A7 as the Project name. 
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5) The first time you configure a project you need to load a license file. Click the browse icon of the License File field 
and, if needed and you installed to the default locations, browse to 
C:\Renesas\e2_studio\internal\projectgen\arm\Licenses\. 

NOTE: After you have loaded the license file, it is loaded and displayed in the License window by default. 

6) Click Next. 

The ISDE displays the Project Configuration (Synergy Project) window with the Board options. 

 

7) Select S3A7 DK and leave all other options at their default settings.  

8) Click Next. 

The ISDE displays the Project Configuration (Synergy Project) window with the Project Template Selection 
options. 

 

9) Select S3A7-DK Blinky. 

10) Click Finish. 
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11) If the Open Associated Perspective dialog box appears, click Yes. 

NOTE: The e2 studio ISDE has built in Perspectives. Until you inform the tool to Remember my decision, it asks if it can use 
the Synergy Configuration perspective: 

  

The ISDE automatically configures the SSP to load and generate the necessary configuration files for the microcontroller 
hardware associated with the selected board. 

The ISDE displays the Synergy Project Editor where you can see all generated files and configurations by selecting 
the Clocks, Pins, Threads, ICU, and Components tabs. 

NOTE: Do try different things. Edit > Undo reverses almost any action you most recently performed. 

  

12) Generate the project content by clicking . 

13) Build the project by clicking Project > Build Project or clicking on the Build icon, .  
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Debugging and running the Blinky Project 

To debug and run the project, do the following steps: 

1) Configure the debugger by selecting the drop-down menu next to the debug icon and select Debug Configurations: 

 

2) On the Debug Configurations dialog, select Renesas GDB Hardware Debugging > Blinky_DK_S3A7 Debug. 
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3) Click Debug. 

a. If the Confirm Perspective Switch dialog displays, click Yes. 

NOTE: If you click the Remember my decision check box before clicking Yes, you will not see this dialog again. 
 

 

b. If the J-Link Firmware update dialog displays, we highly recommend that you click Yes. 

 

The ISDE downloads the project onto the board.  

4) Click on the Resume icon,  and the software runs until hal_entry ().  

5) Click on the Resume icon, , and the software runs turning LED1 on and off. 
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Next steps 
You can review the code for the Blinky Project in the src directory of your project: 

 

Application Notes and Demonstration Applications are available from https://synergygallery.renesas.com/ssp. 

Examples of the categories that Renesas is developing are: 

• Wired connectivity (CAN, RS232/485, TCP/IP, Web Server, networking services) 

• Bluetooth connectivity (Bluetooth Classic and Bluetooth Low Energy connection to mobile devices using various 
profiles ) 

• WiFi connectivity (Access Point Enumeration, Access Point connection using secure protocols, TCP/IP, Web Server, 
networking services) 

• Multi-media (webcam, audio playback & record, audio processing, GUIX tutorials) 

• MCU performance & power measurement (thread, throughput, and I/O performance, low-power modes & power 
measurement) 

• Security (protected memory and bus access examples, stack security examples, security protocols and services 
examples) 

Reloading the Out-of-Box Demo 
Should you desire to reload the original Out-of-Box Demo application, you can find it and the instructions to reload it from 
https://synergygallery.renesas.com/ssp. 

NOTE: The Out-of-Box Demo on the Synergy Gallery may be an updated and improved demo. This kit contains version 1.0 of 
the DK-S3A7 Out-of-Box Demo. 
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Support 
Support: https://synergygallery.renesas.com/support 

Technical contact details: 

• America: https://renesas.zendesk.com/anonymous_requests/new 

• Europe: http://www.renesas.eu/support/index.jsp 

• Japan: http://japan.renesas.com/contact/index.jsp  
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Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples.  You are fully responsible for 

the incorporation of these circuits, software, and information in the design of your equipment.  Renesas Electronics assumes no responsibility for any losses incurred by you or third parties arising from the 

use of these circuits, software, or information.

2. Renesas Electronics has used reasonable care in preparing the information included in this document, but Renesas Electronics does not warrant that such information is error free.  Renesas Electronics 

assumes no liability whatsoever for any damages incurred by you resulting from errors in or omissions from the information included herein.

3. Renesas Electronics does not assume any liability for infringement of patents, copyrights, or other intellectual property rights of third parties by or arising from the use of Renesas Electronics products or 

technical information described in this document.  No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or 

others.

4. You should not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part.  Renesas Electronics assumes no responsibility for any losses incurred by you or 

third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics product.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality".  The recommended applications for each Renesas Electronics product depends on 

the product's quality grade, as indicated below.

 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic 

equipment; and industrial robots etc.

 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control systems; anti-disaster systems; anti-crime systems; and safety equipment etc.

 Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical 

implantations etc.), or may cause serious property damages (nuclear reactor control systems, military equipment etc.).  You must check the quality grade of each Renesas Electronics product before using it 

in a particular application.  You may not use any Renesas Electronics product for any application for which it is not intended.  Renesas Electronics shall not be in any way liable for any damages or losses 

incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas Electronics.

6. You should use the Renesas Electronics products described in this document within the range specified by Renesas Electronics, especially with respect to the maximum rating, operating supply voltage 

range, movement power voltage range, heat radiation characteristics, installation and other product characteristics.  Renesas Electronics shall have no liability for malfunctions or damages arising out of the 

use of Renesas Electronics products beyond such specified ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of its products, semiconductor products have specific characteristics such as the occurrence of failure at a certain rate and 

malfunctions under certain use conditions.  Further, Renesas Electronics products are not subject to radiation resistance design.  Please be sure to implement safety measures to guard them against the 

possibility of physical injury, and injury or damage caused by fire in the event of the failure of a Renesas Electronics product, such as safety design for hardware and software including but not limited to 

redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures.  Because the evaluation of microcomputer software alone is very difficult, 

please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product.  Please use Renesas Electronics 

products in compliance with all applicable laws and regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive.  Renesas Electronics assumes 

no liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technology may not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws or 

regulations.  You should not use Renesas Electronics products or technology described in this document for any purpose relating to military applications or use by the military, including but not limited to the 

development of weapons of mass destruction.  When exporting the Renesas Electronics products or technology described in this document, you should comply with the applicable export control laws and 

regulations and follow the procedures required by such laws and regulations.

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, who distributes, disposes of, or otherwise places the product with a third party, to notify such third party in advance of the 

contents and conditions set forth in this document, Renesas Electronics assumes no responsibility for any losses incurred by you or third parties as a result of unauthorized use of Renesas Electronics 

products.

11. This document may not be reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products, or if you have any other inquiries.

(Note 1)  "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2)  "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

http://www.renesas.com
Refer to "http://www.renesas.com/" for the latest and detailed information.
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