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Notice 
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products 

and application examples. You are fully responsible for the incorporation or any other use of the circuits, software, and information in the design of your 
product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by you or third parties arising from the use 
of these circuits, software, or information. 

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other claims involving patents, copyrights, 
or other intellectual property rights of third parties, by or arising from the use of Renesas Electronics products or technical information described in this 
document, including but not limited to, the product data, drawings, charts, programs, algorithms, and application examples.  

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics 
or others. 

4. You shall not alter, modify, copy, or reverse engineer any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any 
and all liability for any losses or damages incurred by you or third parties arising from such alteration, modification, copying or reverse engineering. 

5. Renesas Electronics products are classified according to the following two quality grades: “Standard” and “High Quality”. The intended applications for 
each Renesas Electronics product depends on the product’s quality grade, as indicated below. 
 "Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home 

electronic appliances; machine tools; personal electronic equipment; industrial robots; etc. 
 "High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key 

financial terminal systems; safety control equipment; etc. 
Unless expressly designated as a high reliability product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas 
Electronics document, Renesas Electronics products are not intended or authorized for use in products or systems that may pose a direct threat to 
human life or bodily injury (artificial life support devices or systems; surgical implantations; etc.), or may cause serious property damage (space 
system; undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas Electronics 
disclaims any and all liability for any damages or losses incurred by you or any third parties arising from the use of any Renesas Electronics product 
that is inconsistent with any Renesas Electronics data sheet, user’s manual or other Renesas Electronics document. 

6. When using Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, “General Notes for 
Handling and Using Semiconductor Devices” in the reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by 
Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat dissipation characteristics, installation, etc. 
Renesas Electronics disclaims any and all liability for any malfunctions, failure or accident arising out of the use of Renesas Electronics products 
outside of such specified ranges. 

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific 
characteristics, such as the occurrence of failure at a certain rate and malfunctions under certain use conditions. Unless designated as a high reliability 
product or a product for harsh environments in a Renesas Electronics data sheet or other Renesas Electronics document, Renesas Electronics 
products are not subject to radiation resistance design. You are responsible for implementing safety measures to guard against the possibility of bodily 
injury, injury or damage caused by fire, and/or danger to the public in the event of a failure or malfunction of Renesas Electronics products, such as 
safety design for hardware and software, including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for 
aging degradation or any other appropriate measures. Because the evaluation of microcomputer software alone is very difficult and impractical, you 
are responsible for evaluating the safety of the final products or systems manufactured by you. 

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas 
Electronics product. You are responsible for carefully and sufficiently investigating applicable laws and regulations that regulate the inclusion or use of 
controlled substances, including without limitation, the EU RoHS Directive, and using Renesas Electronics products in compliance with all these 
applicable laws and regulations. Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance 
with applicable laws and regulations. 

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable domestic or foreign laws or regulations. You shall comply with any applicable export control laws and regulations 
promulgated and administered by the governments of any countries asserting jurisdiction over the parties or transactions. 

10. It is the responsibility of the buyer or distributor of Renesas Electronics products, or any other party who distributes, disposes of, or otherwise sells or 
transfers the product to a third party, to notify such third party in advance of the contents and conditions set forth in this document. 

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics. 
12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas 

Electronics products. 

(Note1) “Renesas Electronics” as used in this document means Renesas Electronics Corporation and also includes its directly or indirectly controlled 
subsidiaries. 

(Note2) “Renesas Electronics product(s)” means any product developed or manufactured by or for Renesas Electronics. 
 

(Rev.4.0-1  November 2017) 
 

Corporate Headquarters  Contact information 
TOYOSU FORESIA, 3-2-24 Toyosu, 
Koto-ku, Tokyo 135-0061, Japan 
www.renesas.com 

 For further information on a product, technology, the most up-to-date 
version of a document, or your nearest sales office, please visit: 
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Renesas Synergy™ Platform 

IAR Embedded Workbench® for Renesas Synergy™ v8.23.3 
Introduction 
This document provides supplemental release notes for the IAR Embedded Workbench® for Renesas 
SynergyTM v8.23.3. This version of the IAR EW for Synergy supports Synergy Standalone Configurator 
(SSC) v7.3.1, Synergy Software Package (SSP) software, executing on S7G2, S5D9, S5D5, S5D3, S3A7, 
S3A6, S3A3, S3A1, S124, S128, and S1JA MCU Groups. 

Release Information 
IAR EW for Synergy Release Version v8.23.3.18530 
Supported SSC Version v7.3.1 
Supported Operating Systems Microsoft® Windows® 7 and Microsoft® Windows® 10 
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1. Installing IAR EW for Synergy v8.23.3 
1.1 Using the individual IAR EW for Synergy Installer 
To install IAR EW for Synergy and get it ready for use, follow the IAR EW for Synergy Getting Started Guide 
on the Synergy Gallery.  

The individual IAR EW for Synergy installer does not include the Synergy Standalone Configurator (SSC) or 
the Synergy Software Package (SSP). 

• Both SSC and SSP are required to create Synergy projects using IAR EW for Synergy. 
• Both SSC and SSP have their own Release Notes, which can be found on following pages: 

www.renesas.com/synergy/ssc 
www.renesas.com/synergy/ssp 

Familiarize yourself with the SSC and SSP Release Notes before starting any Synergy project as these 
documents contain important information. 

2. Updating your IAR EW for Synergy License 
If you have a time-limited IAR EW for Synergy license, after installing IAR EW for Synergy v8.23.3, update 
your IAR EW for Synergy license to a permanent license as follows: 
1. In IAR EW for Synergy, select Help > License Manager. 
2. In the IAR License Manager, select License > Check for License Renewal. 
3. Select your license number and click the Check selected licenses button. 

The IAR License searches for license renewals for your license. 
4. After the IAR License Manager has retrieved the updated license keys, click the Renew selected button. 

The IAR license Manager presents you with the renewal results. 

 
You have now updated your IAR EW for Synergy license to a permanent license. 

3. Building IAR Projects from Command Line 
To build an EW Synergy project using an IAR compiler (.ewp) from the command line, the 
<projectname>.custom_argvars file needs to be invoked in the command line as it contains the tool 
and license information. 

The custom_argvars file contains the following variables and their respective values: 

RENESAS_SYNERGY_INSTALLDIR: Path to the directory where Synergy Standalone Configurator (SSC) is 
installed. 

RENESAS_SYNERGY_LICENSEFILE: Path to the license file in the SSP installation directory within the SSC 
directory. 

AMS_KEEP_FILE: Option to replace the encrypted files with decrypted files. 
 
The following command should be used to build the EW Synergy project (*.ewp) from the command line: 

<IAR installation dir>\common\bin\IarBuild.exe Project_Name.ewp Debug -varfile 
Project_Name.custom_argvars 

or with some helpful extra options, 
<IAR installation dir>\common\bin\IarBuild.exe Project_Name.ewp Debug -log all -
parallel 8 -varfile Project_Name.custom_argvars 

http://www.renesas.com/synergy/ssc
http://www.renesas.com/synergy/ssp
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4. Summary of New Features and Updates to IAR EW for Synergy v8.23.3 
A newer version of the toolchain has been added in this build, which includes minor improvements and bug 
fixes. 

5. Recent Important Feature Additions 
5.1 Added Synergy User Pack Exporter 
IAR EW for Synergy v8.23.3 and SSC v6.2.0 introduced the ability to export a Synergy User Pack (as known 
from e2 studio). 

Two variants of packs can be created as follows: 
• Standard user pack, containing non-SSP (that is, custom) components and SSP component settings 
• Board pack 

Users cannot export: 
• SSP components and SSP source files (for example, <Project>\synergy\ssp) 
• SSP generated files (for example, <Project>\synergy_cfg\ssp_cfg) 

A pack file will be generated based on the details and selections in the Synergy User Pack Exporter 
wizard. The pack file will also contain a .PDSC file describing any exported components (in CMSIS format). 

To access the User Pack Exporter from within IAR EW for Synergy, open a Renesas Synergy project, then 
click on the Renesas Synergy menu and select the Export Synergy User Pack... menu item as shown in 
the following graphic. 

 
The main use case is to create a pack for a custom board (rather than a Renesas board). New Synergy 
projects can then be based on the custom board. 

For a description of how to create a custom board pack, see the ISDE User’s Guide inside the SSP User’s 
Manual on the Renesas Synergy Solutions Gallery. 

Note:  In order for the Synergy User Pack Exporter in IAR EW for Synergy/SSC to be able to include files in 
the user pack (*.pincfg files), the files need to be part of the Synergy project in IAR Embedded 
Workbench for Synergy. To add files to a project, go to Project > Add Files. Set the file name filter to 
All Files (*.*). After you add a file to a project, it will become visible in the project in the Workspace 
window. 

6. Synergy Hardware Platform Support 
MCU Groups supported: S7G2, S5D9, S5D5, S5D3, S3A7, S3A6, S3A3, S3A1, S128, S124, and S1JA. 

7. Issues fixed in Release v8.23.3 
7.1 Thread List in IAR EW for Synergy is not displayed 
Issue ID: 13347 

The information of Threads used in the project is not available in the Thread list view of IAR EWSYN. 

7.2 Error message popup when trying to download and debug a project on S3A7 
Issue ID: 12750 

Trying to download a project using flash loader in EWSYN may result in J-Link Driver popup messages 
offering the user to abort the debug session. 
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8. Known Issues in Release v8.23.3 
8.1 Creating a new Synergy project fails if Workspace/Project is saved on C:\ (root) 
Issue ID: 9611 

Creating a new Synergy project fails if the Workspace/Project is saved on C:\ (root). 

Workaround: Create your workspaces and project files in proper subdirectories. 

8.2 C++ projects may require additional linker option ‘--skip_dynamic_initialization’ 
When creating C++ projects using EW for Synergy v8.23.3, the additional linker option ‘--
skip_dynamic_initialization’ may be required (in Project > Options > Linker > Extra Options). 

  
Not adding this linker option in C++ projects may result in the following linker error: 

Fatal Error[Lp049]: there was no reference to __iar_data_init3, but it is needed 
to call extra init routines 

After adding the ‘--skip_dynamic_initialization’ linker option, check the behavior of your 
application and make sure the SSP performs the correct initialization for C++. If not, a call to 
__iar_dynamic_initialization() needs to be included in the application. See the following entry 
from the IAR EW for Synergy User’s Manual about the ‘--skip_dynamic_initialization’ linker option. 

https://renesasgroup.sharepoint.com/sites/iot/WF/AppNotes/ApplicationNotes/Best%20Practices%20for%20Analog%20PCB%20Layout%20Using%20RA2A1%20MCU/r01an5287eu0100-ra-best-practices-for-analog-pcb-layout-ra2a1.docx?web=1
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8.3 Including ‘stdarg.h’ requires additional preprocessor flag 

__ICCARM_OLD_DEFINED_VAARGS__ 
Issue ID:  IDE-17580  
When including ‘stdarg.h’ in a project, the preprocessor flag __ICCARM_OLD_DEFINED_VAARGS__ needs 
to be defined manually (in Project > Options > C/C++ Compiler > Preprocessor). 

 
Not adding this preprocessor flag in projects including ‘stdarg.h’ will result in build errors. 
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8.4 When using the standalone installer to install IAR EWSYN, a warning message 
is sometimes shown by the windows defender 

In such a scenario, click Run anyway as seen in the following graphic, to install the application. 

 
8.5 CRUN under EWSYN 
Issue ID: 12972 

C-Run with bounds checking is not supported with Synergy projects in EWSYN. 

Applies to: All MCUs 

Workaround: None 

8.6 Cannot debug the program when selecting “Download and Debug” option after 
setting an ID code in the project 

Issue ID: 12845 

Cannot debug the program when selecting the option “Download and Debug” in EWSYN or “Debug” in 
e2 studio for the first time after setting an ID code in the project. 

Workaround: When the debug fails, select the option to “Debug without download” in EWSYN or “Debug” in 
e2 studio again to successfully debug the program. 

8.7 Project build fails after migrating the project to new SSP version 
Issue ID:13900 

In some cases, the build fails with the error "Secure builder required" after migrating the project to a newer 
SSP version in EWSYN. 

Workaround: Select Project > Make (F7) after the issue occurs. The project should then build without 
errors. 

8.8 Selecting .tar format does not export the project in tar format 
Issue ID: 12925 
When exporting the project, selecting .tar format option does not export the project in the tar format, but 
exports it in .zip format. 

Applies to: Not Applicable 

Workaround: Edit the archive file name by replacing the .zip with .tar and the project will be exported 
in .tar format. 
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Website and Support 
Visit the following vanity URLs to learn about key elements of the Synergy Platform, download components 
and related documentation, and get support. 

 
Synergy Software   www.renesas.com/synergy/software 
 Synergy Software Package www.renesas.com/synergy/ssp 
 Software add-ons  www.renesas.com/synergy/addons 
 Software glossary  www.renesas.com/synergy/softwareglossary 

Development tools  www.renesas.com/synergy/tools 
 

Synergy Hardware   www.renesas.com/synergy/hardware 
 Microcontrollers   www.renesas.com/synergy/mcus 
 MCU glossary   www.renesas.com/synergy/mcuglossary 
 Parametric search  www.renesas.com/synergy/parametric 

Kits    www.renesas.com/synergy/kits 
 

Synergy Solutions Gallery  www.renesas.com/synergy/solutionsgallery 
 Partner projects   www.renesas.com/synergy/partnerprojects 

Application projects  www.renesas.com/synergy/applicationprojects 
 
Self-service support resources:  

Documentation    www.renesas.com/synergy/docs 
Knowledgebase    www.renesas.com/synergy/knowledgebase 
Forums     www.renesas.com/synergy/forum 
Training    www.renesas.com/synergy/training 
Videos    www.renesas.com/synergy/videos 
Chat and web ticket   www.renesas.com/synergy/resourcelibrary 

  

https://www.renesas.com/synergy/software
https://www.renesas.com/synergy/ssp
https://www.renesas.com/synergy/addons
https://www.renesas.com/synergy/softwareglossary
https://www.renesas.com/synergy/tools
https://www.renesas.com/synergy/hardware
https://www.renesas.com/synergy/mcus
https://www.renesas.com/synergy/mcuglossary
https://www.renesas.com/synergy/parametric
https://www.renesas.com/synergy/kits
https://www.renesas.com/synergy/solutionsgallery
https://www.renesas.com/synergy/partnerprojects
https://www.renesas.com/synergy/applicationprojects
https://www.renesas.com/synergy/docs
https://www.renesas.com/synergy/knowledgebase
https://www.renesas.com/synergy/forum
https://www.renesas.com/synergy/training
https://www.renesas.com/synergy/videos
https://www.renesas.com/synergy/resourcelibrary
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Revision History 

Rev. Date 
Description 
Page Summary 

1.00 Feb.28.19 - Initial release 
1.01 Apr.02.19 - Second release 
1.02 Dec.19.19 - Third release 
1.03 Feb.11.20 - Fourth release with updates to section 1 
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